summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/neovim-python-client/ChangeLog8
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.0.32.ebuild23
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-python/neovim-python-client/ChangeLog b/dev-python/neovim-python-client/ChangeLog
index 10099fba2c8c..3b60058d7a81 100644
--- a/dev-python/neovim-python-client/ChangeLog
+++ b/dev-python/neovim-python-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/neovim-python-client
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/neovim-python-client/ChangeLog,v 1.2 2015/03/26 12:32:21 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/neovim-python-client/ChangeLog,v 1.3 2015/03/29 04:08:05 yngwin Exp $
+
+*neovim-python-client-0.0.32 (29 Mar 2015)
+
+ 29 Mar 2015; Ben de Groot <yngwin@gentoo.org>
+ +neovim-python-client-0.0.32.ebuild:
+ version bump
*neovim-python-client-0.0.31 (26 Mar 2015)
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.0.32.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.0.32.ebuild
new file mode 100644
index 000000000000..c44ad07d6058
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.0.32.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/neovim-python-client/neovim-python-client-0.0.32.ebuild,v 1.1 2015/03/29 04:08:05 yngwin Exp $
+
+EAPI=5
+#PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python2_7 ) # currently only works on py2
+inherit distutils-r1
+
+DESCRIPTION="Python client to connect to Neovim thru its msgpack-rpc API"
+HOMEPAGE="https://github.com/neovim/python-client"
+SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/click-3.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/greenlet[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3} 'pypy*')"
+RDEPEND="${DEPEND}"