summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pathlib')
-rw-r--r--dev-python/pathlib/ChangeLog8
-rw-r--r--dev-python/pathlib/pathlib-1.0.1.ebuild18
2 files changed, 24 insertions, 2 deletions
diff --git a/dev-python/pathlib/ChangeLog b/dev-python/pathlib/ChangeLog
index 019a9dac0f5b..afa7964e608b 100644
--- a/dev-python/pathlib/ChangeLog
+++ b/dev-python/pathlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pathlib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pathlib/ChangeLog,v 1.2 2014/08/14 16:24:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pathlib/ChangeLog,v 1.3 2014/09/05 20:04:05 hasufell Exp $
+
+*pathlib-1.0.1 (05 Sep 2014)
+
+ 05 Sep 2014; Julian Ospald <hasufell@gentoo.org> +pathlib-1.0.1.ebuild:
+ version bump
14 Aug 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org> pathlib-1.0.ebuild:
x86 stable wrt bug #518212
@@ -10,4 +15,3 @@
30 Mar 2014; Julian Ospald <hasufell@gentoo.org> +pathlib-1.0.ebuild,
+metadata.xml:
initial import
-
diff --git a/dev-python/pathlib/pathlib-1.0.1.ebuild b/dev-python/pathlib/pathlib-1.0.1.ebuild
new file mode 100644
index 000000000000..e43bc138ad38
--- /dev/null
+++ b/dev-python/pathlib/pathlib-1.0.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pathlib/pathlib-1.0.1.ebuild,v 1.1 2014/09/05 20:04:05 hasufell Exp $
+
+EAPI=5
+
+# In Python 3.4, pathlib is now part of the standard library.
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+inherit distutils-r1
+
+DESCRIPTION="Object-oriented filesystem paths"
+HOMEPAGE="https://pathlib.readthedocs.org/"
+SRC_URI="mirror://pypi/p/pathlib/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""