summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/sbcl')
-rw-r--r--dev-lisp/sbcl/ChangeLog6
-rw-r--r--dev-lisp/sbcl/sbcl-1.2.6.ebuild9
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index 2231a2b007ce..4ffb1f8e8fdc 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.217 2015/02/01 06:34:48 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.218 2015/02/01 07:39:07 gienah Exp $
+
+ 01 Feb 2015; Mark Wright <gienah@gentoo.org> sbcl-1.2.6.ebuild:
+ Applied my fix from sbcl-1.2.7 to sbcl-1.2.6 to fix Bug 526194 - dev-
+ lisp/sbcl-1.2.4 does not respect CFLAGS and LDFLAGS
01 Feb 2015; Mark Wright <gienah@gentoo.org> sbcl-1.1.18.ebuild,
sbcl-1.2.2.ebuild, sbcl-1.2.4.ebuild:
diff --git a/dev-lisp/sbcl/sbcl-1.2.6.ebuild b/dev-lisp/sbcl/sbcl-1.2.6.ebuild
index 0d5fb3379944..6cf37af90d20 100644
--- a/dev-lisp/sbcl/sbcl-1.2.6.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.2.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.2.6.ebuild,v 1.1 2014/12/20 15:37:16 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.2.6.ebuild,v 1.2 2015/02/01 07:39:07 gienah Exp $
EAPI=5
inherit multilib eutils flag-o-matic pax-utils
@@ -91,6 +91,11 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.17-gentoo-fix_nopie_for_hardened_toolchain.patch
fi
+ # bug #526194
+ sed -e "s@CFLAGS =@CFLAGS = ${CFLAGS}@" \
+ -e "s@LINKFLAGS =@LINKFLAGS = ${LDFLAGS}@" \
+ -i src/runtime/GNUmakefile || die
+
cp /usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
use source && sed 's%"$(BUILD_ROOT)%$(MODULE).lisp "$(BUILD_ROOT)%' -i contrib/vanilla-module.mk