summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog8
-rw-r--r--dev-libs/botan/botan-1.4.4.ebuild33
-rw-r--r--dev-libs/botan/files/botan-1.4.4-gcc34.patch11
3 files changed, 40 insertions, 12 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index f1dfc1d18a44..f84465396c3a 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.2 2004/12/04 05:26:22 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.3 2004/12/08 10:27:36 dragonheart Exp $
+
+ 08 Dec 2004; Daniel Black <dragonheart@gentoo.org> botan-1.4.4.ebuild,
+ +files/botan-1.4.4-gcc34.patch:
+ Added patch to fix local problem with gcc recognision. Fixed test src_test
+ routine. Added support for module tm_hard in sparc64, mips64 and i586+. ppc
+ tested too
*botan-1.4.4 (04 Dec 2004)
diff --git a/dev-libs/botan/botan-1.4.4.ebuild b/dev-libs/botan/botan-1.4.4.ebuild
index f53df3ac3657..3dd689d7443d 100644
--- a/dev-libs/botan/botan-1.4.4.ebuild
+++ b/dev-libs/botan/botan-1.4.4.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.4.4.ebuild,v 1.1 2004/12/04 05:26:22 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.4.4.ebuild,v 1.2 2004/12/08 10:27:36 dragonheart Exp $
# Comments/fixes to lloyd@randombit.net (author)
+inherit eutils
+
DESCRIPTION="A C++ crypto library"
HOMEPAGE="http://botan.randombit.net/"
SRC_URI="http://botan.randombit.net/files/Botan-${PV}.tgz"
-KEYWORDS="~x86"
+KEYWORDS="x86 ppc"
SLOT="0"
LICENSE="BSD"
IUSE="bzlib zlib gmp ssl debug"
@@ -27,25 +29,33 @@ RDEPEND="virtual/libc
DEPEND="${RDEPEND}
dev-lang/perl"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc34.patch || die "patch failed"
+}
+
src_compile() {
# Modules that should work under any semi-recent Unix
- modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,mux_pthr"
+ local modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,mux_pthr"
if useq bzlib; then modules="$modules,comp_bzip2"; fi
- if use zlib; then modules="$modules,comp_zlib"; fi
- if use gmp; then modules="$modules,eng_gmp"; fi
- if use ssl; then modules="$modules,eng_ossl"; fi
+ if useq zlib; then modules="$modules,comp_zlib"; fi
+ if useq gmp; then modules="$modules,eng_gmp"; fi
+ if useq ssl; then modules="$modules,eng_ossl"; fi
- # This is also supported on i586+ and sparcv9 - how to test for them? CCHOST?
+ # This is also supported on i586+ and sparcv9 - hope this is correct.
if [ ${ARCH} = 'alpha' -o ${ARCH} = 'amd64' ] || \
- [ ${ARCH} = 'x86' -a ${CHOST:0:4} != "i386" -a ${CHOST:0:4} != "i486" ]; then
+ [ ${ARCH} = 'x86' -a ${CHOST:0:4} != "i386" -a ${CHOST:0:4} != "i486" ] || \
+ [ ${CHOSTARCH} = 'sparc32-v9' -a ${PROFILE_ARCH} = 'sparc64' ]; then
modules="$modules,tm_hard"
fi
# Also works on mips64 and sparc64
- if [ ${ARCH} = 'alpha' -o ${ARCH} = 'amd64' -o \
- ${ARCH} = 'ia64' -o ${ARCH} = 'ppc64' ]; then
+ if [ "${ARCH}" = 'alpha' -o "${ARCH}" = 'amd64' -o \
+ "${ARCH}" = 'ia64' -o "${ARCH}" = 'ppc64' -o "${PROFILE_ARCH}" = 'mips64' ] || \
+ [ "${CHOSTARCH}" = 'sparc32-v9' -a "${PROFILE_ARCH}" = 'sparc64' ]; then
modules="$modules,mp_asm64"
fi
@@ -53,7 +63,7 @@ src_compile() {
CHOSTARCH=$(echo ${CHOST} | cut -d - -f 1)
cd ${S}
- einfo "Enabling modules: " $(echo $modules | sed 's/,/ /g')
+ einfo "Enabling modules: " ${modules}
# FIXME: We might actually be on *BSD or OS X...
./configure.pl --noauto gcc-linux-$CHOSTARCH --modules=$modules ||
@@ -62,6 +72,7 @@ src_compile() {
}
src_test() {
+ chmod -R ugo+rX ${S}
emake check || die "emake check failed"
env LD_LIBRARY_PATH=${S} ./check --validate || die "validation tests failed"
}
diff --git a/dev-libs/botan/files/botan-1.4.4-gcc34.patch b/dev-libs/botan/files/botan-1.4.4-gcc34.patch
new file mode 100644
index 000000000000..d0e8d0245b3f
--- /dev/null
+++ b/dev-libs/botan/files/botan-1.4.4-gcc34.patch
@@ -0,0 +1,11 @@
+--- Botan-1.4.4/configure.pl 2004-12-02 23:38:44.000000000 -0500
++++ Botan/configure.pl 2004-12-04 12:45:22.189044368 -0500
+@@ -832,7 +832,7 @@
+ # didn't get output, assume it's a buggy GCC. There is no reduction in code
+ # quality, etc, so even if we're wrong it's no big deal.
+
+- if(($gcc_version =~ /gcc version 3\.[34]/) ||
++ if(($gcc_version =~ /3\.[34]/) ||
+ ($gcc_version =~ /2\.95\.[0-4]/) ||
+ ($gcc_version eq '' && $^O eq 'cygwin'))
+ {