summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gflags/gflags-2.1.1.ebuild')
-rw-r--r--dev-cpp/gflags/gflags-2.1.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-cpp/gflags/gflags-2.1.1.ebuild b/dev-cpp/gflags/gflags-2.1.1.ebuild
new file mode 100644
index 000000000000..874628962f9a
--- /dev/null
+++ b/dev-cpp/gflags/gflags-2.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/gflags-2.1.1.ebuild,v 1.1 2014/07/14 03:34:01 patrick Exp $
+
+EAPI="5"
+
+inherit cmake-multilib multilib-minimal
+
+DESCRIPTION="Google's C++ argument parsing library"
+HOMEPAGE="http://code.google.com/p/gflags/"
+SRC_URI="https://github.com/schuhschuh/gflags/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+multilib_src_install_all() {
+ rm -rf "${ED}"/usr/share/doc
+ dodoc {AUTHORS,ChangeLog,NEWS,README}.txt
+ dohtml doc/*
+}