summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pspresent/pspresent-1.3.ebuild')
-rw-r--r--app-text/pspresent/pspresent-1.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/pspresent/pspresent-1.3.ebuild b/app-text/pspresent/pspresent-1.3.ebuild
new file mode 100644
index 000000000000..4b525a6c3bbb
--- /dev/null
+++ b/app-text/pspresent/pspresent-1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspresent/pspresent-1.3.ebuild,v 1.1 2007/03/05 20:27:40 anant Exp $
+
+IUSE="xinerama"
+
+DESCRIPTION="A tool to display full-screen PostScript presentations."
+SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
+HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
+
+RDEPEND="virtual/libc
+ || ( ( x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama ) )
+ virtual/x11 )
+ virtual/ghostscript"
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto ) )
+ virtual/x11 )
+ >=sys-apps/sed-4"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ if ! use xinerama ; then
+ sed -i -e "/^XINERAMA/s/^/#/g" Makefile
+ fi
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ dobin pspresent
+ doman pspresent.1
+}