summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/ramspeed')
-rw-r--r--app-benchmarks/ramspeed/ChangeLog9
-rw-r--r--app-benchmarks/ramspeed/ramspeed-3.5.0.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/app-benchmarks/ramspeed/ChangeLog b/app-benchmarks/ramspeed/ChangeLog
index 153a6e8a7e3b..c48a705c59a0 100644
--- a/app-benchmarks/ramspeed/ChangeLog
+++ b/app-benchmarks/ramspeed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/ramspeed
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ramspeed/ChangeLog,v 1.4 2010/10/16 15:45:57 c1pher Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ramspeed/ChangeLog,v 1.5 2011/10/22 18:59:34 patrick Exp $
+
+*ramspeed-3.5.0 (22 Oct 2011)
+
+ 22 Oct 2011; Patrick Lauer <patrick@gentoo.org> +ramspeed-3.5.0.ebuild:
+ Bump for #381367, thanks to Michael Seifert
16 Oct 2010; Dane Smith <c1pher@gentoo.org> metadata.xml:
Updated maintainer info in metadata.xml.
diff --git a/app-benchmarks/ramspeed/ramspeed-3.5.0.ebuild b/app-benchmarks/ramspeed/ramspeed-3.5.0.ebuild
new file mode 100644
index 000000000000..53ce7b8c1244
--- /dev/null
+++ b/app-benchmarks/ramspeed/ramspeed-3.5.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/ramspeed/ramspeed-3.5.0.ebuild,v 1.1 2011/10/22 18:59:34 patrick Exp $
+
+EAPI=2
+inherit flag-o-matic toolchain-funcs
+
+MY_PN="ramsmp"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Benchmarking for memory and cache"
+HOMEPAGE="http://www.alasir.com/software/ramspeed/"
+SRC_URI="http://www.alasir.com/software/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Alasir"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse"
+
+src_prepare(){
+ tc-export CC AS
+
+ # Deal with changed package name and file name
+ mv ${MY_P} ${P}
+}
+
+src_configure(){
+ local obj
+ local arch_prefix=./
+
+ use x86 && arch_prefix=i386/
+ use amd64 && arch_prefix=amd64/
+
+ #fix the stack
+ append-ldflags -Wl,-z,noexecstack
+ obj=( ramsmp.o ${arch_prefix}{fltmark,fltmem,intmark,intmem}.o )
+
+ if use x86; then
+ obj=( "${obj[@]}" ${arch_prefix}{cpuinfo/cpuinfo_main,cpuinfo/cpuinfo_ext}.o )
+ fi
+
+ if use sse; then
+ use x86 && append-flags "-DLINUX -DI386_ASM"
+ use amd64 && append-flags "-DLINUX -DAMD64_ASM"
+ obj=( "${obj[@]}" ${arch_prefix}{mmxmark,mmxmem,ssemark,ssemem}.o )
+ fi
+
+ echo "ramsmp: ${obj[@]}" > Makefile || die
+}
+
+src_install(){
+ dobin ramsmp || die
+ dosym /usr/bin/ramsmp /usr/bin/ramspeed || die
+ dodoc HISTORY README || die
+}