summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 10 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 6fb42c33505b..e3a854f895ea 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.687 2013/10/26 07:36:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.688 2013/11/05 19:44:37 aballier Exp $
+
+ 05 Nov 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add ssh useflag
26 Oct 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-0.10.9.ebuild,
ffmpeg-1.0.7.ebuild, ffmpeg-1.0.8.ebuild, ffmpeg-1.2.3.ebuild,
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index bb1ba12f71fa..0bd5b06a3779 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.141 2013/10/26 07:36:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.142 2013/11/05 19:44:37 aballier Exp $
EAPI="5"
@@ -44,7 +44,7 @@ IUSE="
cpudetection debug doc +encode examples faac fdk flite fontconfig frei0r
gme gnutls gsm +hardcoded-tables +iconv iec61883 ieee1394 jack jpeg2k
ladspa libass libcaca libsoxr libv4l modplug mp3 +network openal openssl opus
- oss pic pulseaudio quvi rtmp schroedinger sdl speex static-libs test theora
+ oss pic pulseaudio quvi rtmp schroedinger sdl speex ssh static-libs test theora
threads truetype twolame v4l vaapi vdpau vorbis vpx wavpack X x264 xvid
+zlib zvbi
"
@@ -108,6 +108,7 @@ RDEPEND="
sdl? ( >=media-libs/libsdl-1.2.13-r1[audio,video] )
schroedinger? ( media-libs/schroedinger )
speex? ( >=media-libs/speex-1.2_beta3 )
+ ssh? ( net-libs/libssh )
truetype? ( media-libs/freetype:2 )
vaapi? ( >=x11-libs/libva-0.32 )
vdpau? ( x11-libs/libvdpau )
@@ -210,7 +211,7 @@ src_configure() {
# Decoders
ffuse="${ffuse} amr:libopencore-amrwb amr:libopencore-amrnb fdk:libfdk-aac jpeg2k:libopenjpeg"
use amr && myconf="${myconf} --enable-version3"
- for i in bluray celt gme gsm modplug opus quvi rtmp schroedinger speex vorbis vpx zvbi; do
+ for i in bluray celt gme gsm modplug opus quvi rtmp ssh schroedinger speex vorbis vpx zvbi; do
ffuse="${ffuse} ${i}:lib${i}"
done
use fdk && myconf="${myconf} --enable-nonfree"
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index f93edd22ace8..89ae9bf95737 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -38,6 +38,7 @@
<flag name="quvi">Adds support for playing media from Internet services using the quvi project.</flag>
<flag name="rtmp">Enable Real Time Messaging Protocol using librtmp</flag>
<flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
+ <flag name="ssh">Enable SSH/sftp support via <pkg>net-libs/libssh</pkg>.</flag>
<flag name="ssse3">Faster floating point optimization for SSSE3 capable chips (Intel Core 2 and later chips)</flag>
<flag name="twolame">Enables MP2 encoding via <pkg>media-sound/twolame</pkg> as an alternative to the internal encoder.</flag>
<flag name="vaapi">Enables VAAPI (Video Acceleration API) for hardware decoding</flag>