summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/fluidsynth/ChangeLog7
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.4.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index 88579d0a5559..9f4310d89991 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.66 2011/01/14 21:28:12 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.67 2011/08/07 11:48:30 aballier Exp $
+
+*fluidsynth-1.1.4 (07 Aug 2011)
+
+ 07 Aug 2011; Alexis Ballier <aballier@gentoo.org> +fluidsynth-1.1.4.ebuild:
+ version bump
14 Jan 2011; Brent Baude <ranger@gentoo.org> fluidsynth-1.1.1.ebuild:
stable ppc, bug 343589
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.4.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.4.ebuild
new file mode 100644
index 000000000000..bd32fb229c5b
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.1.4.ebuild,v 1.1 2011/08/07 11:48:30 aballier Exp $
+
+EAPI=2
+inherit cmake-utils
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa dbus debug examples jack ladspa lash portaudio pulseaudio readline sndfile"
+
+RDEPEND=">=dev-libs/glib-2.6.5:2
+ alsa? ( media-libs/alsa-lib
+ lash? ( >=media-sound/lash-0.5 ) )
+ dbus? ( >=sys-apps/dbus-1.0.0 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.8 )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ readline? ( sys-libs/readline )
+ sndfile? ( >=media-libs/libsndfile-1.0.18 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use alsa enable-alsa)
+ $(cmake-utils_use dbus enable-dbus)
+ $(cmake-utils_use debug enable-debug)
+ $(cmake-utils_use jack enable-jack)
+ -Denable-ladcca=OFF
+ $(cmake-utils_use ladspa enable-ladspa)
+ $(cmake-utils_use sndfile enable-libsndfile)
+ $(cmake-utils_use portaudio enable-portaudio)
+ $(cmake-utils_use pulseaudio enable-pulseaudio)
+ $(cmake-utils_use readline enable-readline)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( $(cmake-utils_use lash enable-lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc AUTHORS NEWS README THANKS TODO doc/*.txt
+
+ insinto /usr/share/doc/${PF}/pdf
+ doins doc/*.pdf
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/*.c
+ fi
+}