summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-extra/xfce4-vala/ChangeLog8
-rw-r--r--xfce-extra/xfce4-vala/xfce4-vala-4.10.3.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-vala/ChangeLog b/xfce-extra/xfce4-vala/ChangeLog
index 6fecb962b310..8c6e703c1b6d 100644
--- a/xfce-extra/xfce4-vala/ChangeLog
+++ b/xfce-extra/xfce4-vala/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-vala
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-vala/ChangeLog,v 1.12 2013/04/11 18:08:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-vala/ChangeLog,v 1.13 2013/09/03 14:30:36 ssuominen Exp $
+
+*xfce4-vala-4.10.3 (03 Sep 2013)
+
+ 03 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +xfce4-vala-4.10.3.ebuild:
+ Version bump and force use of vala-0.20 to avoid blockers, as opposed to
+ sticking to vala-0.16 (the version upstream created the package for)
11 Apr 2013; Agostino Sarubbo <ago@gentoo.org> xfce4-vala-4.10.2.ebuild:
Stable for x86, wrt bug #465286
diff --git a/xfce-extra/xfce4-vala/xfce4-vala-4.10.3.ebuild b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3.ebuild
new file mode 100644
index 000000000000..199ab5be12a7
--- /dev/null
+++ b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-vala/xfce4-vala-4.10.3.ebuild,v 1.1 2013/09/03 14:30:35 ssuominen Exp $
+
+EAPI=5
+MY_VALA_VERSION=0.20
+VALA_MIN_API_VERSION=${MY_VALA_VERSION}
+VALA_MAX_API_VERSION=${MY_VALA_VERSION}
+VALA_USE_DEPEND=vapigen
+inherit xfconf vala
+
+DESCRIPTION="Vala bindings for the Xfce desktop environment"
+HOMEPAGE="http://wiki.xfce.org/vala-bindings"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="$(vala_depend)
+ >=xfce-base/exo-0.10
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+ XFCONF=(
+ --with-vala-api=${MY_VALA_VERSION}
+ )
+}
+
+src_prepare() {
+ xfconf_src_prepare
+ vala_src_prepare
+}