summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/rpm/rpm-4.0.ebuild17
-rw-r--r--dev-db/MyODBC/MyODBC-2.50.36.ebuild4
-rw-r--r--dev-lang/php-4/php-4.0.3_p1.ebuild6
-rw-r--r--gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild4
-rw-r--r--gnome-extra/libgda/libgda-0.1.0.ebuild3
-rw-r--r--gnome-libs/libgda/libgda-0.1.0.ebuild3
-rw-r--r--media-video/xawtv/xawtv-3.23.ebuild4
-rw-r--r--net-www/apache-ssl/apache-ssl-1.3.14.2.7.1.ebuild5
8 files changed, 20 insertions, 26 deletions
diff --git a/app-arch/rpm/rpm-4.0.ebuild b/app-arch/rpm/rpm-4.0.ebuild
index ebb7f96f8550..9dd872a12586 100644
--- a/app-arch/rpm/rpm-4.0.ebuild
+++ b/app-arch/rpm/rpm-4.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.0.ebuild,v 1.3 2000/11/17 01:59:33 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.0.ebuild,v 1.4 2000/11/17 11:15:51 achim Exp $
A="${P}.tar.gz"
S=${WORKDIR}/${P}
-DESCRIPTION="RedHat Package Management Utils"
+DESCRIPTION="Red Hat Package Management Utils"
SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/${A}"
HOMEPAGE="http://www.rpm.org/"
@@ -16,19 +16,6 @@ DEPEND=">=sys-apps/bash-2.04
>=sys-libs/db-3.1.17
=sys-libs/db-1.58"
-src_unpack() {
- unpack ${A}
- cd ${S}
- cat ${FILESDIR}/rpm-4.0-rpmgettext.patch.bz2 | bzip2 -d | patch -p0
- cat ${FILESDIR}/rpm-rpmlibsucks.patch.bz2 | bzip2 -d | patch -p1
- cat ${FILESDIR}/rpm-4.0-bashort.patch.bz2 | bzip2 -d | patch -p0
- cat ${FILESDIR}/rpm-3.0.3-compile.patch.bz2 | bzip2 -d | patch -p0
- cat ${FILESDIR}/rpm-3.0.3-fakeroot.patch.bz2 | bzip2 -d | patch -p0
- cat ${FILESDIR}/rpm-skipmntpoints.patch.bz2 | bzip2 -d | patch -p1
- cat ${FILESDIR}/rpm-3.0.5-objdump-shutup.patch.bz2 | bzip2 -d | patch -p1
- cat ${FILESDIR}/rpm-wait-for-lock.patch.bz2 | bzip2 -d | patch -p0
- cat ${FILESDIR}/rpm-4.0.1-install-ugid-h.patch.bz2 | bzip2 -d | patch -p1
-}
src_compile() {
cd ${S}
diff --git a/dev-db/MyODBC/MyODBC-2.50.36.ebuild b/dev-db/MyODBC/MyODBC-2.50.36.ebuild
index 8328eb1fd44c..bd3636c55e94 100644
--- a/dev-db/MyODBC/MyODBC-2.50.36.ebuild
+++ b/dev-db/MyODBC/MyODBC-2.50.36.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/MyODBC/MyODBC-2.50.36.ebuild,v 1.1 2000/11/17 09:35:03 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/MyODBC/MyODBC-2.50.36.ebuild,v 1.2 2000/11/17 11:15:51 achim Exp $
#P=
A=${P}.tar.gz
@@ -10,6 +10,8 @@ DESCRIPTION="ODBC interface for MySQL"
SRC_URI="http://www.mysql.com/Downloads/MyODBC/${A}"
HOMEPAGE="http://www.mysql.com"
+DEPEND=">=dev-db/unixODBC-1.8.13
+ >=dev-db/mysql-3.23.27"
src_compile() {
diff --git a/dev-lang/php-4/php-4.0.3_p1.ebuild b/dev-lang/php-4/php-4.0.3_p1.ebuild
index 66d6ec7de0b3..0ecbd6a931fb 100644
--- a/dev-lang/php-4/php-4.0.3_p1.ebuild
+++ b/dev-lang/php-4/php-4.0.3_p1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.3_p1.ebuild,v 1.3 2000/11/02 02:17:12 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.3_p1.ebuild,v 1.4 2000/11/17 11:15:51 achim Exp $
P=php-4.0.3pl1
A="${P}.tar.gz number4.tar.gz"
@@ -22,13 +22,15 @@ DEPEND=">=sys-libs/glibc-2.1.3
>=media-libs/t1lib-1.0.1
>=net-www/apache-ssl-1.3
>=dev-db/mysql-3.23.26
+ >=dev-db/unixODBC-1.8.13
>=net-nds/openldap-1.2.11
>=x11-base/xfree-4.0.1"
src_compile() {
export LD_FLAGS="$LD_FLAGS -ltiff -ljpeg -L/usr/X11R6/lib"
- ./configure --with-mysql=/usr --enable-safe-mode \
+ ./configure --with-mysql=/usr --enable-safe-mode --enable-ftp \
+ --enable-dbase --with-unixODBC=/usr --with-gdbm=/usr --with-db3=/usr \
--enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
--with-readline --with-gettext --enable-calendar --with-ldap\
--with-gd --with-ttf --with-t1lib --with-jpeg-dir=/usr/lib \
diff --git a/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild b/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild
index 54872d8ba26c..8151199b7bce 100644
--- a/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild
+++ b/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild,v 1.7 2000/11/03 09:11:31 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild,v 1.8 2000/11/17 11:15:51 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -15,7 +15,7 @@ DEPEND=">=media-libs/imlib-1.9.8.1
src_compile() {
cd ${S}
- try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --enable-prefer-db1
try make
}
diff --git a/gnome-extra/libgda/libgda-0.1.0.ebuild b/gnome-extra/libgda/libgda-0.1.0.ebuild
index 66b23c077c2e..95e6d9f86717 100644
--- a/gnome-extra/libgda/libgda-0.1.0.ebuild
+++ b/gnome-extra/libgda/libgda-0.1.0.ebuild
@@ -12,6 +12,7 @@ HOMEPAGE="http://www.gnome.org/gnome-db"
DEPEND=">=gnome-base/gconf-0.8
>=gnome-base/gnome-libs-1.2.4
>=dev-db/mysql-3.23.26
+ >=dev-db/unixODBC-1.8.13
>=net-nds/openldap-1.2.11"
src_unpack() {
@@ -21,7 +22,7 @@ src_unpack() {
src_compile() {
cd ${S}
try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --with-mysql=/usr --with-ldap=/usr --with-catgets
+ --with-mysql=/usr --with-ldap=/usr --with-odbc --with-catgets
try make
}
diff --git a/gnome-libs/libgda/libgda-0.1.0.ebuild b/gnome-libs/libgda/libgda-0.1.0.ebuild
index 66b23c077c2e..95e6d9f86717 100644
--- a/gnome-libs/libgda/libgda-0.1.0.ebuild
+++ b/gnome-libs/libgda/libgda-0.1.0.ebuild
@@ -12,6 +12,7 @@ HOMEPAGE="http://www.gnome.org/gnome-db"
DEPEND=">=gnome-base/gconf-0.8
>=gnome-base/gnome-libs-1.2.4
>=dev-db/mysql-3.23.26
+ >=dev-db/unixODBC-1.8.13
>=net-nds/openldap-1.2.11"
src_unpack() {
@@ -21,7 +22,7 @@ src_unpack() {
src_compile() {
cd ${S}
try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --with-mysql=/usr --with-ldap=/usr --with-catgets
+ --with-mysql=/usr --with-ldap=/usr --with-odbc --with-catgets
try make
}
diff --git a/media-video/xawtv/xawtv-3.23.ebuild b/media-video/xawtv/xawtv-3.23.ebuild
index 65fde4ce4e40..4c6823286322 100644
--- a/media-video/xawtv/xawtv-3.23.ebuild
+++ b/media-video/xawtv/xawtv-3.23.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/xawtv/xawtv-3.23.ebuild,v 1.1 2000/11/15 16:33:15 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xawtv/xawtv-3.23.ebuild,v 1.2 2000/11/17 11:15:51 achim Exp $
A=xawtv_${PV}.tar.gz
S=${WORKDIR}/${P}
@@ -21,7 +21,7 @@ src_unpack() {
src_compile() {
cd ${S}
- unset ROOT BUILDDIR
+ unset DEPEND
try ./configure --host=${CHOST} --prefix=/usr \
--enable-jpeg --enable-xfree-ext --enable-xvideo --with-x
try make
diff --git a/net-www/apache-ssl/apache-ssl-1.3.14.2.7.1.ebuild b/net-www/apache-ssl/apache-ssl-1.3.14.2.7.1.ebuild
index 0c6837ed5750..f5ffbfa13ed4 100644
--- a/net-www/apache-ssl/apache-ssl-1.3.14.2.7.1.ebuild
+++ b/net-www/apache-ssl/apache-ssl-1.3.14.2.7.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache-ssl/apache-ssl-1.3.14.2.7.1.ebuild,v 1.4 2000/11/15 16:33:16 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache-ssl/apache-ssl-1.3.14.2.7.1.ebuild,v 1.5 2000/11/17 11:15:51 achim Exp $
A="apache_1.3.14.tar.gz mod_ssl-2.7.1-1.3.14.tar.gz"
S=${WORKDIR}/apache_1.3.14
@@ -12,6 +12,7 @@ HOMEPAGE="http://www.apache.org http://www.modssl.org"
DEPEND=">=sys-apps/bash-2.04
>=sys-libs/glibc-2.1.3
+ >=sys-libs/db-3.1
>=dev-libs/openssl-0.9.6"
src_compile() {
@@ -25,10 +26,10 @@ src_compile() {
--mandir=/usr/man --logfiledir=/var/log/apache --localstatedir=/var/lock \
--proxycachedir=/var/cache/httpd --includedir=/usr/include/apache \
--enable-module=all --enable-module=ssl \
- --disable-module=auth_dbm \
--enable-shared=max --enable-suexec --suexec-caller=wwwrun \
--suexec-userdir=public_html --suexec-uidmin=96 \
--suexec-gidmin=96 --suexec-safepath="/bin:/usr/bin"
+# --disable-module=auth_dbm"
try make
try make certificate TYPE=dummy
}