summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/tribler/ChangeLog7
-rw-r--r--net-p2p/tribler/tribler-5.9.14.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/net-p2p/tribler/ChangeLog b/net-p2p/tribler/ChangeLog
index ed32432c6c11..85b78dd8aadd 100644
--- a/net-p2p/tribler/ChangeLog
+++ b/net-p2p/tribler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/tribler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/ChangeLog,v 1.16 2012/06/05 16:45:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/ChangeLog,v 1.17 2012/06/07 10:17:39 blueness Exp $
+
+*tribler-5.9.14 (07 Jun 2012)
+
+ 07 Jun 2012; Anthony G. Basile <blueness@gentoo.org> +tribler-5.9.14.ebuild:
+ Version bump
*tribler-5.9.13 (05 Jun 2012)
diff --git a/net-p2p/tribler/tribler-5.9.14.ebuild b/net-p2p/tribler/tribler-5.9.14.ebuild
new file mode 100644
index 000000000000..91f2ad495102
--- /dev/null
+++ b/net-p2p/tribler/tribler-5.9.14.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/tribler-5.9.14.ebuild,v 1.1 2012/06/07 10:17:39 blueness Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
+
+inherit eutils python
+
+MY_PV="${PN}_${PV}-1ubuntu1_all"
+
+DESCRIPTION="Bittorrent client that does not require a website to discover content"
+HOMEPAGE="http://www.tribler.org/"
+SRC_URI="http://dl.tribler.org/${MY_PV}.deb"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vlc"
+
+RDEPEND=">=dev-python/m2crypto-0.16
+ >=dev-python/wxpython-2.8
+ >=dev-python/apsw-3.6
+ >=dev-libs/openssl-0.9.8
+ vlc? ( >=media-video/vlc-1.1.0 )"
+
+# Skipping for now:
+# xulrunner-sdk >= 1.9.1.5 < 1.9.2 (optional, to run SwarmTransport)
+# 7-Zip >= 4.6.5 (optional, to build SwarmTransport)
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ unpack ./data.tar.gz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-5.9.12-fix-global-declarations.patch"
+ epatch "${FILESDIR}/${PN}-5.9.12-remove-garbage.patch"
+ epatch "${FILESDIR}/${PN}-log2homedir.patch"
+
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() { :; }
+
+src_install() {
+ #Rename the doc dir properly
+ mv usr/share/doc/${PN} usr/share/doc/${P}
+
+ #Move the readme to the doc dir
+ mv usr/share/${PN}/Tribler/readme.txt usr/share/doc/${P}
+
+ #Remove the licenses scattered throughout
+ rm usr/share/doc/${P}/copyright
+ rm usr/share/${PN}/Tribler/*.txt
+ rm usr/share/${PN}/Tribler/Core/DecentralizedTracking/pymdht/{LGPL-2.1.txt,LICENSE.txt}
+
+ #Copy the rest over
+ cp -pPR usr/ "${ED}"/
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT}"usr/share/${PN}
+}