summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2007-01-29 18:44:53 +0000
committerPeter Weller <welp@gentoo.org>2007-01-29 18:44:53 +0000
commit84d9fdf1e6fe1df99df4d0290dfc0f3d421b2617 (patch)
tree7c734be9e596509a7a1f1e1fb765a97c7f18a623 /xfce-base
parentRemove trailing white space. (diff)
downloadgentoo-2-84d9fdf1e6fe1df99df4d0290dfc0f3d421b2617.tar.gz
gentoo-2-84d9fdf1e6fe1df99df4d0290dfc0f3d421b2617.tar.bz2
gentoo-2-84d9fdf1e6fe1df99df4d0290dfc0f3d421b2617.zip
A number of fixes
(Portage version: 2.1.2-r5)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog5
-rw-r--r--xfce-base/thunar/thunar-0.5.0_rc2-r3.ebuild8
-rw-r--r--xfce-base/thunar/thunar-0.8.0.ebuild18
3 files changed, 23 insertions, 8 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index d1f49417475f..99a7b58c7d03 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.14 2007/01/28 14:37:31 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.15 2007/01/29 18:44:53 welp Exp $
+
+ 29 Jan 2007; Peter Weller <welp@gentoo.org> thunar-0.8.0.ebuild:
+ A number of fixes
28 Jan 2007; Peter Weller <welp@gentoo.org> thunar-0.8.0.ebuild:
Dep fixes, various other fixes
diff --git a/xfce-base/thunar/thunar-0.5.0_rc2-r3.ebuild b/xfce-base/thunar/thunar-0.5.0_rc2-r3.ebuild
index 74b7b0f636bc..5b44d9de8466 100644
--- a/xfce-base/thunar/thunar-0.5.0_rc2-r3.ebuild
+++ b/xfce-base/thunar/thunar-0.5.0_rc2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.5.0_rc2-r3.ebuild,v 1.2 2007/01/06 19:10:50 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.5.0_rc2-r3.ebuild,v 1.3 2007/01/29 18:44:53 welp Exp $
inherit xfce44 versionator
@@ -18,7 +18,7 @@ DESCRIPTION="Xfce 4 file manager"
HOMEPAGE="http://thunar.xfce.org"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc dbus debug exif hal pcre startup-notification thumbnail trash-panel-plugin"
+IUSE="doc dbus debug exif hal pcre startup-notification thumbnail plugins"
# The order of RDEPEND is based on the list in README, by:
# required packages
@@ -50,7 +50,7 @@ RDEPEND="
>=media-libs/jpeg-6b
startup-notification? ( >=x11-libs/startup-notification-0.4 )
pcre? ( >=dev-libs/libpcre-6.0 )
- trash-panel-plugin? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} )
+ plugins? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} )
"
DEPEND="${RDEPEND}
@@ -68,7 +68,7 @@ XFCE_CONFIG="
$(use_enable pcre) \
$(use_enable startup-notification) \
$(use_enable thumbnail gnome-thumbnailers) \
- $(use_enable trash-panel-plugin tpa-plugin)
+ $(use_enable plugins tpa-plugin)
"
if use hal; then
diff --git a/xfce-base/thunar/thunar-0.8.0.ebuild b/xfce-base/thunar/thunar-0.8.0.ebuild
index 4e2c040e89e9..6dd77e339ef2 100644
--- a/xfce-base/thunar/thunar-0.8.0.ebuild
+++ b/xfce-base/thunar/thunar-0.8.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.8.0.ebuild,v 1.3 2007/01/28 14:37:31 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.8.0.ebuild,v 1.4 2007/01/29 18:44:53 welp Exp $
-inherit xfce44
+inherit eutils xfce44
MY_P="${P/t/T}"
S="${WORKDIR}/${MY_P}"
@@ -39,16 +39,28 @@ DEPEND="${RDEPEND}
doc? ( dev-util/gtk-doc )"
XFCE_CONFIG="${XFCE_CONFIG} $(use_enable exif) $(use_enable gnome gnome-thumbnailers) \
- $(use_enable dbus) $(use_with hal volume-manager hal) $(use_enable pcre)"
+ $(use_enable dbus) $(use_enable pcre)"
use plugins && use dbus || XFCE_CONFIG="${XFCE_CONFIG} --disable-tpa-plugin"
+if use hal; then
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=hal"
+ else
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
+fi
+
pkg_setup() {
if use plugins && ! use dbus ; then
ewarn "Plugins requires ${PN} with dbus support. Enable dbus use flag"
ewarn "and re-emerge this ebuild if you want this feature."
epause 3
fi
+
+ if use hal && ! use dbus ; then
+ ewarn "HAL requires ${PN} with dbus support. Enable dbus use flag"
+ ewarn "and re-emerge this ebuild if you want this feature."
+ die "re-emerge with USE dbus"
+ fi
}
DOCS="AUTHORS ChangeLog HACKING FAQ THANKS TODO README NEWS"