summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2007-01-28 14:37:31 +0000
committerPeter Weller <welp@gentoo.org>2007-01-28 14:37:31 +0000
commit28e65085a686b30de656fb0d8c32b0681d68f628 (patch)
tree54f74fd32dee8ba236f0c13212ec8335c93a64fe /xfce-base
parentDep fixes, various other fixes (diff)
downloadgentoo-2-28e65085a686b30de656fb0d8c32b0681d68f628.tar.gz
gentoo-2-28e65085a686b30de656fb0d8c32b0681d68f628.tar.bz2
gentoo-2-28e65085a686b30de656fb0d8c32b0681d68f628.zip
Dep fixes, various other fixes
(Portage version: 2.1.2-r4)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog5
-rw-r--r--xfce-base/thunar/thunar-0.8.0.ebuild81
2 files changed, 31 insertions, 55 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 9d8e02dbbad7..d1f49417475f 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.13 2007/01/23 16:57:24 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.14 2007/01/28 14:37:31 welp Exp $
+
+ 28 Jan 2007; Peter Weller <welp@gentoo.org> thunar-0.8.0.ebuild:
+ Dep fixes, various other fixes
23 Jan 2007; Peter Weller <welp@gentoo.org> thunar-0.8.0.ebuild:
Removing usage of virtual/x11, and hardcoding in depends. Minor clean ups.
diff --git a/xfce-base/thunar/thunar-0.8.0.ebuild b/xfce-base/thunar/thunar-0.8.0.ebuild
index 422cd00b0dcb..4e2c040e89e9 100644
--- a/xfce-base/thunar/thunar-0.8.0.ebuild
+++ b/xfce-base/thunar/thunar-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.8.0.ebuild,v 1.2 2007/01/23 16:57:24 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.8.0.ebuild,v 1.3 2007/01/28 14:37:31 welp Exp $
inherit xfce44
@@ -8,76 +8,49 @@ MY_P="${P/t/T}"
S="${WORKDIR}/${MY_P}"
xfce44
-xfce44_extra_package # technically, it's core, but in terms of what the eclass
- # does, it's more akin to 'extra' -nichoj
-DESCRIPTION="Xfce4 file manager"
+DESCRIPTION="File manager"
HOMEPAGE="http://thunar.xfce.org"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc dbus debug exif gnome hal plugins pcre startup-notification"
-IUSE="doc dbus debug exif hal pcre startup-notification thumbnail trash-panel-plugin"
-
-# The order of RDEPEND is based on the list in README, by:
-# required packages
-# required packages not listed in README
-# optional packages
-# optional packages not listed
-RDEPEND="
- >=dev-lang/perl-5.6
- >=x11-libs/gtk+-2.6.4
- >=dev-libs/glib-2.6.4
+RDEPEND=">=dev-lang/perl-5.6
+ x11-libs/libSM
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
>=xfce-extra/exo-0.3.2
- >=media-libs/libpng-1.2.0
>=x11-misc/shared-mime-info-0.15
>=dev-util/desktop-file-utils-0.10
>=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
virtual/fam
- doc? ( >=dev-util/gtk-doc-1 dev-libs/libxslt )
- dbus? ( || ( >=dev-libs/dbus-glib-0.71
- ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) )
- )
- hal? ( >=sys-apps/hal-0.5
- || ( >=dev-libs/dbus-glib-0.71
- ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.34 ) )
- )
+ dbus? ( dev-libs/dbus-glib )
+ hal? ( sys-apps/hal )
>=media-libs/freetype-2.0
- thumbnail? ( >=gnome-base/gconf-2.4 )
+ gnome? ( gnome-base/gconf )
exif? ( >=media-libs/libexif-0.6 )
>=media-libs/jpeg-6b
- startup-notification? ( >=x11-libs/startup-notification-0.4 )
- pcre? ( >=dev-libs/libpcre-6.0 )
- trash-panel-plugin? ( dbus? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} ) )"
-
+ startup-notification? ( x11-libs/startup-notification )
+ pcre? ( >=dev-libs/libpcre-6 )
+ plugins? ( dbus? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} ) )
+ gnome-base/librsvg"
DEPEND="${RDEPEND}
+ dev-util/pkgconfig
dev-util/intltool
- x11-proto/xproto"
-
-# TODO report upstream:
-# --enable/disable for jpeg
-# --enable/disable for freetype
-# when those are fixed, we make IUSE="jpeg freetype"
-XFCE_CONFIG="
- $(use_enable dbus) \
- $(use_enable doc gtk-doc) \
- $(use_enable doc xsltproc) \
- $(use_enable exif) \
- $(use_enable pcre) \
- $(use_enable startup-notification) \
- $(use_enable thumbnail gnome-thumbnailers) \
- "
+ doc? ( dev-util/gtk-doc )"
-if use hal; then
- XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=hal"
-else
- XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
-fi
+XFCE_CONFIG="${XFCE_CONFIG} $(use_enable exif) $(use_enable gnome gnome-thumbnailers) \
+ $(use_enable dbus) $(use_with hal volume-manager hal) $(use_enable pcre)"
-use trash-panel-plugin && use dbus || XFCE_CONFIG="${XFCE_CONFIG} --disable-tpa-plugin"
+use plugins && use dbus || XFCE_CONFIG="${XFCE_CONFIG} --disable-tpa-plugin"
pkg_setup() {
- if use trash-panel-plugin && ! use dbus ; then
- ewarn "trash-panel-plugin requires ${PN} with dbus support"
- ewarn "Enable dbus use flag and re-emerge this ebuild if you want this feature."
- epause 3
+ if use plugins && ! use dbus ; then
+ ewarn "Plugins requires ${PN} with dbus support. Enable dbus use flag"
+ ewarn "and re-emerge this ebuild if you want this feature."
+ epause 3
fi
}
+
+DOCS="AUTHORS ChangeLog HACKING FAQ THANKS TODO README NEWS"
+
+xfce44_extra_package