summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 18:42:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 18:42:19 +0000
commit04454b0f9ac566d1a36c1ec4ad9547e64eac4c06 (patch)
tree7921ddb7a06d6e9bba6a58f7f0e660d100b2efee /xfce-base/xfdesktop
parentalpha/sparc stable wrt #348978 (diff)
downloadgentoo-2-04454b0f9ac566d1a36c1ec4ad9547e64eac4c06.tar.gz
gentoo-2-04454b0f9ac566d1a36c1ec4ad9547e64eac4c06.tar.bz2
gentoo-2-04454b0f9ac566d1a36c1ec4ad9547e64eac4c06.zip
Version bump.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfdesktop')
-rw-r--r--xfce-base/xfdesktop/ChangeLog7
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.8.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/xfce-base/xfdesktop/ChangeLog b/xfce-base/xfdesktop/ChangeLog
index 880f08a28354..b472c86669de 100644
--- a/xfce-base/xfdesktop/ChangeLog
+++ b/xfce-base/xfdesktop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfdesktop
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.182 2011/01/25 20:29:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.183 2011/01/30 18:42:19 ssuominen Exp $
+
+*xfdesktop-4.8.1 (30 Jan 2011)
+
+ 30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> +xfdesktop-4.8.1.ebuild:
+ Version bump.
25 Jan 2011; Jeroen Roovers <jer@gentoo.org> xfdesktop-4.8.0.ebuild:
Stable for HPPA (bug #349053).
diff --git a/xfce-base/xfdesktop/xfdesktop-4.8.1.ebuild b/xfce-base/xfdesktop/xfdesktop-4.8.1.ebuild
new file mode 100644
index 000000000000..893b6c9a8ebf
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.8.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.8.1.ebuild,v 1.1 2011/01/30 18:42:19 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/xfdesktop/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify thunar"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.22
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/garcon-0.1.5
+ >=xfce-base/xfconf-4.8
+ libnotify? ( >=x11-libs/libnotify-0.4 )
+ thunar? ( >=xfce-base/exo-0.6
+ >=xfce-base/thunar-1.2
+ >=dev-libs/dbus-glib-0.88 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable thunar exo)
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}