summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-06-30 08:25:32 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-06-30 08:25:32 +0000
commit2741820790238e9e2324ffba6ccfefafd2c04bd4 (patch)
treec91d46fff075255e8c931956e7b0ec4915b471cc /x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
parentbump x11-plugins/wmweather+ to version 2.9. clean up old ebuilds... (Manifest... (diff)
downloadgentoo-2-2741820790238e9e2324ffba6ccfefafd2c04bd4.tar.gz
gentoo-2-2741820790238e9e2324ffba6ccfefafd2c04bd4.tar.bz2
gentoo-2-2741820790238e9e2324ffba6ccfefafd2c04bd4.zip
bump x11-plugins/wmsmixer to version 0.5.1...
Diffstat (limited to 'x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild')
-rw-r--r--x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild b/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
new file mode 100644
index 000000000000..7e77eecc63e7
--- /dev/null
+++ b/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild,v 1.1 2004/06/30 08:25:32 s4t4n Exp $
+
+inherit eutils
+IUSE=""
+DESCRIPTION="fork of wmmixer adding scrollwheel support and other features"
+HOMEPAGE="http://www.hibernaculum.net/wmsmixer.html"
+SRC_URI="http://www.hibernaculum.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc"
+
+DEPEND="virtual/libc
+ virtual/x11"
+
+src_compile() {
+ g++ -m32 ${CFLAGS} -I/usr/X11R6/include -c -o wmsmixer.o wmsmixer.cc
+ rm -f wmsmixer
+ g++ -o wmsmixer ${CFLAGS} -L/usr/X11R6/lib wmsmixer.o -lXpm -lXext -lX11
+}
+
+src_install() {
+ insinto /usr/bin
+ insopts -m0655
+ doins wmsmixer
+ dodoc README README.wmmixer
+}