summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-05-01 15:55:03 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-05-01 15:55:03 +0000
commit890aa0d51bca96f15386dd7c325d80136efb22c4 (patch)
tree69d8af2b168f4e38c49143efedd5b57b07702a9b /x11-libs
parentAdd libwnck to the glade/introspection lists (diff)
downloadgentoo-2-890aa0d51bca96f15386dd7c325d80136efb22c4.tar.gz
gentoo-2-890aa0d51bca96f15386dd7c325d80136efb22c4.tar.bz2
gentoo-2-890aa0d51bca96f15386dd7c325d80136efb22c4.zip
Move libwnck:3 from the gnome overlay to the tree, use GNOME2_LA_PUNT
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libwnck/ChangeLog8
-rw-r--r--x11-libs/libwnck/libwnck-2.30.6.ebuild9
-rw-r--r--x11-libs/libwnck/libwnck-3.0.0.ebuild62
3 files changed, 71 insertions, 8 deletions
diff --git a/x11-libs/libwnck/ChangeLog b/x11-libs/libwnck/ChangeLog
index efbda5decf42..77461515a7ca 100644
--- a/x11-libs/libwnck/ChangeLog
+++ b/x11-libs/libwnck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libwnck
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/ChangeLog,v 1.264 2011/04/10 08:39:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/ChangeLog,v 1.265 2011/05/01 15:55:03 nirbheek Exp $
+
+*libwnck-3.0.0 (01 May 2011)
+
+ 01 May 2011; Nirbheek Chauhan <nirbheek@gentoo.org> libwnck-2.30.6.ebuild,
+ +libwnck-3.0.0.ebuild:
+ Move libwnck:3 from the gnome overlay to the tree, use GNOME2_LA_PUNT
10 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> libwnck-2.30.6.ebuild:
Punt useless libtool file.
diff --git a/x11-libs/libwnck/libwnck-2.30.6.ebuild b/x11-libs/libwnck/libwnck-2.30.6.ebuild
index 3371ae9f9ac8..4885bf48b782 100644
--- a/x11-libs/libwnck/libwnck-2.30.6.ebuild
+++ b/x11-libs/libwnck/libwnck-2.30.6.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/libwnck-2.30.6.ebuild,v 1.10 2011/04/10 08:39:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/libwnck-2.30.6.ebuild,v 1.11 2011/05/01 15:55:03 nirbheek Exp $
EAPI="3"
+GNOME2_LA_PUNT="yes"
GCONF_DEBUG="no"
inherit gnome2
@@ -50,9 +51,3 @@ src_prepare() {
append-ldflags "-L${EPREFIX}/usr/lib/bind"
fi
}
-
-src_install() {
- gnome2_src_install
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-}
diff --git a/x11-libs/libwnck/libwnck-3.0.0.ebuild b/x11-libs/libwnck/libwnck-3.0.0.ebuild
new file mode 100644
index 000000000000..1a58d9b89592
--- /dev/null
+++ b/x11-libs/libwnck/libwnck-3.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/libwnck-3.0.0.ebuild,v 1.1 2011/05/01 15:55:03 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A window navigation construction kit"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE="doc +introspection startup-notification"
+
+RDEPEND=">=x11-libs/gtk+-3.0:3[introspection?]
+ >=dev-libs/glib-2.16:2
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXext
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14 )
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ x86-interix? ( sys-libs/itx-bind )"
+# eautoreconf needs
+# dev-util/gtk-doc-am
+# gnome-base/gnome-common
+
+pkg_setup() {
+ # Don't collide with SLOT=1
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable introspection)
+ $(use_enable startup-notification)
+ --program-suffix=-${SLOT}"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if use x86-interix; then
+ # activate the itx-bind package...
+ append-flags "-I${EPREFIX}/usr/include/bind"
+ append-ldflags "-L${EPREFIX}/usr/lib/bind"
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "wnckprop is now called wnckprop-${SLOT}"
+ elog "wnck-urgency-monitor is now called wnck-urgency-monitor-${SLOT}"
+}