summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-17 03:17:51 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-17 03:17:51 +0000
commit1f1b7780334a658528ee376ba6bffd8d63104739 (patch)
tree08891e1ad41fb6cfd36686727db09d9de15d6ff2 /x11-libs
parentadded a depend on ypbind for autofs (diff)
downloadgentoo-2-1f1b7780334a658528ee376ba6bffd8d63104739.tar.gz
gentoo-2-1f1b7780334a658528ee376ba6bffd8d63104739.tar.bz2
gentoo-2-1f1b7780334a658528ee376ba6bffd8d63104739.zip
Initial libwmfun ebuild patched for freetype2 and the latest WindowMaker
build that doesn't include libPropList.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libwmfun/files/digest-libwmfun-0.0.41
-rw-r--r--x11-libs/libwmfun/files/proplist-freetype2.diff21
-rw-r--r--x11-libs/libwmfun/libwmfun-0.0.4.ebuild41
3 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/libwmfun/files/digest-libwmfun-0.0.4 b/x11-libs/libwmfun/files/digest-libwmfun-0.0.4
new file mode 100644
index 000000000000..0ad6081d3cf7
--- /dev/null
+++ b/x11-libs/libwmfun/files/digest-libwmfun-0.0.4
@@ -0,0 +1 @@
+MD5 af1ad49bada4b8f0df9377a133f109c4 libwmfun-0.0.4.tar.gz 127228
diff --git a/x11-libs/libwmfun/files/proplist-freetype2.diff b/x11-libs/libwmfun/files/proplist-freetype2.diff
new file mode 100644
index 000000000000..ee51aa3c17ef
--- /dev/null
+++ b/x11-libs/libwmfun/files/proplist-freetype2.diff
@@ -0,0 +1,21 @@
+diff -urN libwmfun-0.0.4/libwmfun/Makefile.in libwmfun-0.0.4-modified/libwmfun/Makefile.in
+--- libwmfun-0.0.4/libwmfun/Makefile.in Wed Dec 6 17:54:04 2000
++++ libwmfun-0.0.4-modified/libwmfun/Makefile.in Tue Jul 16 22:08:46 2002
+@@ -82,7 +82,7 @@
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+
+
+-DEFS = @DEFS@ -I. -I$(srcdir) -I.
++DEFS = @DEFS@ -I. -I$(srcdir) -I. -I/usr/include/freetype2
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+diff -urN libwmfun-0.0.4/libwmfun/drawstring.c libwmfun-0.0.4-modified/libwmfun/drawstring.c
+--- libwmfun-0.0.4/libwmfun/drawstring.c Sun Jul 29 14:18:48 2001
++++ libwmfun-0.0.4-modified/libwmfun/drawstring.c Tue Jul 16 20:45:39 2002
+@@ -1,4 +1,4 @@
+-#include <proplist.h>
++#include <WINGs/proplist-compat.h>
+ #include <WINGs/WINGs.h>
+ #include <WINGs/WINGsP.h>
+ #include "generic.h"
diff --git a/x11-libs/libwmfun/libwmfun-0.0.4.ebuild b/x11-libs/libwmfun/libwmfun-0.0.4.ebuild
new file mode 100644
index 000000000000..74fefc391f46
--- /dev/null
+++ b/x11-libs/libwmfun/libwmfun-0.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwmfun/libwmfun-0.0.4.ebuild,v 1.1 2002/07/17 03:17:51 raker Exp $
+
+DESCRIPTION="Additional FUN! WindowMaker library"
+HOMEPAGE="http://www.windowmaker.org"
+SRC_URI="http://www.windowmaker.org/pub/libs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ x11-wm/WindowMaker
+ >=media-libs/freetype-2.0.9"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/proplist-freetype2.diff
+
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+}