summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-08-29 12:57:41 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-08-29 12:57:41 +0000
commit10fbb438aa876c07ae9a16a8e9ba39f5cf27f0f1 (patch)
treece0aa0e0da917cda08946a3864f82fce77241283 /www-client
parentversion bump; Added inheritance of eutils for mysql-5.0.* ; Replaced shell fr... (diff)
downloadgentoo-2-10fbb438aa876c07ae9a16a8e9ba39f5cf27f0f1.tar.gz
gentoo-2-10fbb438aa876c07ae9a16a8e9ba39f5cf27f0f1.tar.bz2
gentoo-2-10fbb438aa876c07ae9a16a8e9ba39f5cf27f0f1.zip
fix for no javascript compile failure. Reported upstream with the patch that Az made in files/
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/links/ChangeLog7
-rw-r--r--www-client/links/files/links-2.1pre18-no-javascript-fix.patch18
-rw-r--r--www-client/links/links-2.1_pre18.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/www-client/links/ChangeLog b/www-client/links/ChangeLog
index 774209f50443..a2ab72731dad 100644
--- a/www-client/links/ChangeLog
+++ b/www-client/links/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/links
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.28 2005/08/28 22:14:40 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.29 2005/08/29 12:57:41 seemant Exp $
+
+ 29 Aug 2005; Seemant Kulleen <seemant@gentoo.org>
+ +files/links-2.1pre18-no-javascript-fix.patch, links-2.1_pre18.ebuild:
+ fix for no javascript compile failure. Reported upstream with the patch that
+ Az made in files/
*links-2.1_pre18 (28 Aug 2005)
diff --git a/www-client/links/files/links-2.1pre18-no-javascript-fix.patch b/www-client/links/files/links-2.1pre18-no-javascript-fix.patch
new file mode 100644
index 000000000000..29586a8b753b
--- /dev/null
+++ b/www-client/links/files/links-2.1pre18-no-javascript-fix.patch
@@ -0,0 +1,18 @@
+--- links-2.1pre18/view.c 2005-08-29 13:53:49.000000000 +0200
++++ links-2.1pre18.az/view.c 2005-08-29 13:57:07.000000000 +0200
+@@ -2972,6 +2972,7 @@
+ return 0;
+ }
+
++#ifdef JS
+ if (!event_catchable(ev) || !fd->f_data || !fd->vs) goto dont_catch;
+ if (fd->vs->current_link >= 0 && fd->vs->current_link < fd->f_data->nlinks) {
+ struct link *l = &fd->f_data->links[fd->vs->current_link];
+@@ -2993,6 +2994,7 @@
+ if (!(call_keyboard_event(fd, fd->f_data->js_event->keypress_code, ev))) return 1;
+ }
+ dont_catch:
++#endif
+
+ if (!F) r = frame_ev(ses, fd, ev);
+ #ifdef G
diff --git a/www-client/links/links-2.1_pre18.ebuild b/www-client/links/links-2.1_pre18.ebuild
index a2fcc6016d19..bfb4a4fc1ce9 100644
--- a/www-client/links/links-2.1_pre18.ebuild
+++ b/www-client/links/links-2.1_pre18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.1_pre18.ebuild,v 1.1 2005/08/28 22:14:40 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.1_pre18.ebuild,v 1.2 2005/08/29 12:57:41 seemant Exp $
inherit eutils toolchain-funcs
@@ -70,6 +70,8 @@ src_unpack (){
export LANG=C
cd ${S}/intl && ./gen-intl && cd .. || die "gen-intl filed"
fi
+
+ epatch ${FILESDIR}/links-2.1pre18-no-javascript-fix.patch
}
src_compile (){