summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-05-02 03:12:18 +0000
committerBrian Evans <grknight@gentoo.org>2015-05-02 03:12:18 +0000
commitb887ae238830c2851da4fd7f75cd92284a84780e (patch)
treeaff679986ad0762330342c5c1cde9ed938710989 /www-apps
parentRevbump to eliminate the unnecessary re-building of the documentation which i... (diff)
downloadgentoo-2-b887ae238830c2851da4fd7f75cd92284a84780e.tar.gz
gentoo-2-b887ae238830c2851da4fd7f75cd92284a84780e.tar.bz2
gentoo-2-b887ae238830c2851da4fd7f75cd92284a84780e.zip
Revbump to update EAPI, fix DEPEND and eliminate the unnecessary re-building of the documentation which is present in the archive
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/davical/ChangeLog14
-rw-r--r--www-apps/davical/davical-1.0.2-r2.ebuild (renamed from www-apps/davical/davical-1.0.2-r1.ebuild)33
-rw-r--r--www-apps/davical/davical-1.1.0-r1.ebuild (renamed from www-apps/davical/davical-1.1.0.ebuild)34
-rw-r--r--www-apps/davical/davical-1.1.1-r2.ebuild (renamed from www-apps/davical/davical-1.1.1-r1.ebuild)32
-rw-r--r--www-apps/davical/davical-1.1.1.ebuild77
-rw-r--r--www-apps/davical/davical-1.1.3.1-r2.ebuild (renamed from www-apps/davical/davical-1.1.3.1-r1.ebuild)17
6 files changed, 60 insertions, 147 deletions
diff --git a/www-apps/davical/ChangeLog b/www-apps/davical/ChangeLog
index 89c728b120a5..1892aaf9ae0c 100644
--- a/www-apps/davical/ChangeLog
+++ b/www-apps/davical/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for www-apps/davical
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/ChangeLog,v 1.8 2015/02/14 02:13:24 mjo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/ChangeLog,v 1.9 2015/05/02 03:12:18 grknight Exp $
+
+*davical-1.1.0-r1 (02 May 2015)
+*davical-1.1.1-r2 (02 May 2015)
+*davical-1.0.2-r2 (02 May 2015)
+*davical-1.1.3.1-r2 (02 May 2015)
+
+ 02 May 2015; Brian Evans <grknight@gentoo.org> +davical-1.0.2-r2.ebuild,
+ +davical-1.1.0-r1.ebuild, +davical-1.1.1-r2.ebuild,
+ +davical-1.1.3.1-r2.ebuild, -davical-1.0.2-r1.ebuild, -davical-1.1.0.ebuild,
+ -davical-1.1.1-r1.ebuild, -davical-1.1.1.ebuild, -davical-1.1.3.1-r1.ebuild:
+ Revbump to update EAPI, fix DEPEND and eliminate the unnecessary re-building
+ of the documentation which is present in the archive
*davical-1.1.3.1-r1 (14 Feb 2015)
diff --git a/www-apps/davical/davical-1.0.2-r1.ebuild b/www-apps/davical/davical-1.0.2-r2.ebuild
index f4949b1e4d6d..bf3908720216 100644
--- a/www-apps/davical/davical-1.0.2-r1.ebuild
+++ b/www-apps/davical/davical-1.0.2-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.0.2-r1.ebuild,v 1.1 2012/03/14 06:46:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.0.2-r2.ebuild,v 1.1 2015/05/02 03:12:18 grknight Exp $
-EAPI=2
+EAPI=5
inherit depend.php webapp
@@ -14,9 +14,11 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
-RDEPEND="app-admin/pwgen
- dev-lang/php[calendar,curl,pdo,postgres,xml]
+DEPEND=">=dev-php/awl-0.51
+ sys-devel/gettext"
+RDEPEND="
+ app-admin/pwgen
+ dev-lang/php:*[calendar,curl,pdo,postgres,xml]
dev-perl/DBI
dev-perl/DBD-Pg
dev-perl/yaml
@@ -32,24 +34,18 @@ src_prepare() {
}
src_compile() {
- if use doc ; then
- einfo "Generating documentation"
- phpdoc -q -c "docs/api/phpdoc.ini"\
- || die "Documentation failed to build"
- fi
- emake built-po || die "emake failed"
+ emake built-po
}
src_install() {
webapp_src_preinst
dodoc-php INSTALL README debian/README.Debian \
- testing/README.regression_tests TODO debian/changelog \
- || die "dodoc failed"
+ testing/README.regression_tests TODO debian/changelog
einfo "Installing web files"
insinto "${MY_HTDOCSDIR}"
- doins -r htdocs/* htdocs/.htaccess || die "doins failed"
+ doins -r htdocs/* htdocs/.htaccess
einfo "Installing main files and i18n"
insinto "${MY_HOSTROOTDIR}/${PN}"
@@ -58,16 +54,15 @@ src_install() {
einfo "Installing sql files"
insinto "${MY_SQLSCRIPTSDIR}"
- doins -r dba/* || die "doins failed"
+ doins -r dba/*
if use doc ; then
einfo "Installing documentation"
- dohtml -r docs/api/ docs/website/ || die "dohtml failed"
+ dohtml -r docs/api/ docs/website/
fi
insinto /etc/${PN}
- doins config/* "${FILESDIR}/vhost-example" \
- || die "newins failed"
+ doins config/* "${FILESDIR}/vhost-example"
webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
webapp_src_install
diff --git a/www-apps/davical/davical-1.1.0.ebuild b/www-apps/davical/davical-1.1.0-r1.ebuild
index 7f1deca5a3cb..296e36541936 100644
--- a/www-apps/davical/davical-1.1.0.ebuild
+++ b/www-apps/davical/davical-1.1.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.1.0.ebuild,v 1.1 2012/06/26 09:39:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.1.0-r1.ebuild,v 1.1 2015/05/02 03:12:18 grknight Exp $
-EAPI=2
+EAPI=5
inherit depend.php webapp
@@ -14,9 +14,12 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
+DEPEND="
+ >=dev-php/awl-0.51
+ sys-devel/gettext
+ "
RDEPEND="app-admin/pwgen
- dev-lang/php[calendar,curl,pdo,postgres,xml]
+ dev-lang/php:*[calendar,curl,pdo,postgres,xml]
dev-perl/DBI
dev-perl/DBD-Pg
dev-perl/yaml
@@ -32,42 +35,35 @@ src_prepare() {
}
src_compile() {
- if use doc ; then
- einfo "Generating documentation"
- phpdoc -q -c "docs/api/phpdoc.ini"\
- || die "Documentation failed to build"
- fi
- emake built-po || die "emake failed"
+ emake built-po
}
src_install() {
webapp_src_preinst
dodoc-php INSTALL README debian/README.Debian \
- testing/README.regression_tests TODO debian/changelog \
- || die "dodoc failed"
+ testing/README.regression_tests TODO debian/changelog
einfo "Installing web files"
insinto "${MY_HTDOCSDIR}"
- doins -r htdocs/* htdocs/.htaccess || die "doins failed"
+ doins -r htdocs/* htdocs/.htaccess
einfo "Installing main files and i18n"
insinto "${MY_HOSTROOTDIR}/${PN}"
- doins -r inc locale || die "doins failed"
+ doins -r inc locale
rm "${D}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
einfo "Installing sql files"
insinto "${MY_SQLSCRIPTSDIR}"
- doins -r dba/* || die "doins failed"
+ doins -r dba/*
if use doc ; then
einfo "Installing documentation"
- dohtml -r docs/api/ docs/website/ || die "dohtml failed"
+ dohtml -r docs/api/ docs/website/
fi
insinto /etc/${PN}
- doins config/* "${FILESDIR}/vhost-example" \
- || die "newins failed"
+ doins config/* "${FILESDIR}/vhost-example"
webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
webapp_src_install
diff --git a/www-apps/davical/davical-1.1.1-r1.ebuild b/www-apps/davical/davical-1.1.1-r2.ebuild
index 59daf954c6fd..e4088223566e 100644
--- a/www-apps/davical/davical-1.1.1-r1.ebuild
+++ b/www-apps/davical/davical-1.1.1-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.1.1-r1.ebuild,v 1.1 2013/01/28 08:16:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.1.1-r2.ebuild,v 1.1 2015/05/02 03:12:18 grknight Exp $
-EAPI=2
+EAPI=5
inherit depend.php webapp
@@ -14,9 +14,10 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
+DEPEND=">=dev-php/awl-0.51
+ sys-devel/gettext"
RDEPEND="app-admin/pwgen
- dev-lang/php[calendar,curl,pdo,postgres,xml]
+ dev-lang/php:*[calendar,curl,pdo,postgres,xml]
dev-perl/DBI
dev-perl/DBD-Pg
dev-perl/yaml
@@ -32,42 +33,35 @@ src_prepare() {
}
src_compile() {
- if use doc ; then
- einfo "Generating documentation"
- phpdoc -q -c "docs/api/phpdoc.ini"\
- || die "Documentation failed to build"
- fi
- emake built-po || die "emake failed"
+ emake built-po
}
src_install() {
webapp_src_preinst
dodoc-php INSTALL README debian/README.Debian \
- testing/README.regression_tests TODO debian/changelog \
- || die "dodoc failed"
+ testing/README.regression_tests TODO debian/changelog
einfo "Installing web files"
insinto "${MY_HTDOCSDIR}"
- doins -r htdocs/* htdocs/.htaccess || die "doins failed"
+ doins -r htdocs/* htdocs/.htaccess
einfo "Installing main files and i18n"
insinto "${MY_HOSTROOTDIR}/${PN}"
- doins -r inc locale || die "doins failed"
+ doins -r inc locale
rm "${D}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
einfo "Installing sql files"
insinto "${MY_SQLSCRIPTSDIR}"
- doins -r dba/* || die "doins failed"
+ doins -r dba/*
if use doc ; then
einfo "Installing documentation"
- dohtml -r docs/api/ docs/website/ || die "dohtml failed"
+ dohtml -r docs/api/ docs/website/
fi
insinto /etc/${PN}
- doins config/* "${FILESDIR}/vhost-example" \
- || die "newins failed"
+ doins config/* "${FILESDIR}/vhost-example"
webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
webapp_src_install
diff --git a/www-apps/davical/davical-1.1.1.ebuild b/www-apps/davical/davical-1.1.1.ebuild
deleted file mode 100644
index 8da033fec83e..000000000000
--- a/www-apps/davical/davical-1.1.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.1.1.ebuild,v 1.1 2012/07/17 07:21:43 patrick Exp $
-
-EAPI=2
-
-inherit depend.php webapp
-
-DESCRIPTION="A CalDAV and CardDAV Server"
-HOMEPAGE="http://davical.org/"
-SRC_URI="http://debian.mcmillan.net.nz/packages/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
-RDEPEND="app-admin/pwgen
- dev-lang/php[calendar,curl,pdo,postgres,xml]
- dev-perl/DBI
- dev-perl/DBD-Pg
- dev-perl/yaml
- >=dev-php/awl-0.51
- www-servers/apache"
-
-need_php5
-need_httpd
-
-src_prepare() {
- epatch "${FILESDIR}/awl_location.patch"
- epatch "${FILESDIR}/inc_path.patch"
-}
-
-src_compile() {
- if use doc ; then
- einfo "Generating documentation"
- phpdoc -q -c "docs/api/phpdoc.ini"\
- || die "Documentation failed to build"
- fi
- emake built-po || die "emake failed"
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc-php INSTALL README debian/README.Debian \
- testing/README.regression_tests TODO debian/changelog \
- || die "dodoc failed"
-
- einfo "Installing web files"
- insinto "${MY_HTDOCSDIR}"
- doins -r htdocs/* htdocs/.htaccess || die "doins failed"
-
- einfo "Installing main files and i18n"
- insinto "${MY_HOSTROOTDIR}/${PN}"
- doins -r inc locale || die "doins failed"
- rm "${D}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
-
- einfo "Installing sql files"
- insinto "${MY_SQLSCRIPTSDIR}"
- doins -r dba/* || die "doins failed"
-
- if use doc ; then
- einfo "Installing documentation"
- dohtml -r docs/api/ docs/website/ || die "dohtml failed"
- fi
-
- insinto /etc/${PN}
- doins config/* "${FILESDIR}/vhost-example" \
- || die "newins failed"
-
- webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
- webapp_src_install
-
- fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
- fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
-}
diff --git a/www-apps/davical/davical-1.1.3.1-r1.ebuild b/www-apps/davical/davical-1.1.3.1-r2.ebuild
index b238d46cb5a4..e4ca79bfd88c 100644
--- a/www-apps/davical/davical-1.1.3.1-r1.ebuild
+++ b/www-apps/davical/davical-1.1.3.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.1.3.1-r1.ebuild,v 1.1 2015/02/14 02:13:24 mjo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.1.3.1-r2.ebuild,v 1.1 2015/05/02 03:12:18 grknight Exp $
EAPI=5
@@ -14,15 +14,15 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
+DEPEND=">=dev-php/awl-0.55
+ sys-devel/gettext"
RDEPEND="app-admin/pwgen
- dev-lang/php[calendar,curl,pdo,postgres,xml]
+ dev-lang/php:*[calendar,curl,pdo,postgres,xml]
dev-perl/DBI
dev-perl/DBD-Pg
dev-perl/yaml
>=dev-php/awl-0.55
virtual/httpd-php"
-DEPEND="${RDEPEND}
-doc? ( dev-php/PEAR-PhpDocumentor )"
S="${WORKDIR}/${PN}.git"
@@ -36,20 +36,13 @@ src_prepare() {
src_compile() {
emake built-po
-
- if use doc ; then
- einfo "Generating documentation"
- phpdoc -q -c "docs/api/phpdoc.ini"\
- || die "Documentation failed to build"
- fi
}
src_install() {
webapp_src_preinst
dodoc-php INSTALL README debian/README.Debian \
- testing/README.regression_tests TODO debian/changelog \
- || die "dodoc failed"
+ testing/README.regression_tests TODO debian/changelog
einfo "Installing web files"
insinto "${MY_HTDOCSDIR}"