summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-13 16:41:05 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-13 16:41:05 +0000
commit726c1f2e79ca27bcd68b3e005eec90f0b6cff33e (patch)
treeb5f1216233a0e7a8832a0fce32c34162fbf200d8 /sys-fs
parentsci-chemistry/mpqc: Run the intermediate testsuite (diff)
downloadgentoo-2-726c1f2e79ca27bcd68b3e005eec90f0b6cff33e.tar.gz
gentoo-2-726c1f2e79ca27bcd68b3e005eec90f0b6cff33e.tar.bz2
gentoo-2-726c1f2e79ca27bcd68b3e005eec90f0b6cff33e.zip
sys-fs/cachefilesd: Build as PIE binary as suggested by upstream
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cachefilesd/ChangeLog10
-rw-r--r--sys-fs/cachefilesd/cachefilesd-0.10.5-r1.ebuild53
-rw-r--r--sys-fs/cachefilesd/metadata.xml6
3 files changed, 64 insertions, 5 deletions
diff --git a/sys-fs/cachefilesd/ChangeLog b/sys-fs/cachefilesd/ChangeLog
index 815eee6fc613..1b0eca6b0c19 100644
--- a/sys-fs/cachefilesd/ChangeLog
+++ b/sys-fs/cachefilesd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/cachefilesd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/ChangeLog,v 1.5 2011/12/06 16:14:52 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/ChangeLog,v 1.6 2012/12/13 16:41:05 jlec Exp $
+
+*cachefilesd-0.10.5-r1 (13 Dec 2012)
+
+ 13 Dec 2012; Justin Lecher <jlec@gentoo.org> +cachefilesd-0.10.5-r1.ebuild,
+ metadata.xml:
+ Build as PIE binary as suggested by upstream
*cachefilesd-0.10.5 (06 Dec 2011)
diff --git a/sys-fs/cachefilesd/cachefilesd-0.10.5-r1.ebuild b/sys-fs/cachefilesd/cachefilesd-0.10.5-r1.ebuild
new file mode 100644
index 000000000000..ed3aade6cfeb
--- /dev/null
+++ b/sys-fs/cachefilesd/cachefilesd-0.10.5-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/cachefilesd-0.10.5-r1.ebuild,v 1.1 2012/12/13 16:41:05 jlec Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Provides a caching directory on an already mounted filesystem"
+HOMEPAGE="http://people.redhat.com/~dhowells/fscache/"
+SRC_URI="http://people.redhat.com/~dhowells/fscache/${P}.tar.bz2 -> ${P}.tar"
+
+IUSE="doc selinux"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0.10.4-makefile.patch
+ tc-export CC
+ if ! use selinux; then
+ sed -e '/^secctx/s:^:#:g' -i cachefilesd.conf || die
+ fi
+
+ append-flags -fpie
+}
+
+src_install() {
+ default
+
+ if use selinux; then
+ insinto /usr/share/doc/${P}
+ doins -r selinux
+ fi
+
+ dodoc howto.txt
+
+ newconfd "${FILESDIR}"/cachefilesd.conf ${PN}
+ newinitd "${FILESDIR}"/cachefilesd.init ${PN}
+
+ keepdir /var/cache/fscache
+}
+
+pkg_postinst() {
+ [[ -d /var/cache/fscache ]] && return
+ elog "Before CacheFiles can be used, a directory for local storage"
+ elog "must be created. The default configuration of /etc/cachefilesd.conf"
+ elog "uses /var/cache/fscache. The filesystem mounted there must support"
+ elog "extended attributes (mount -o user_xattr)."
+ echo ""
+ elog "Once that is taken care of, start the daemon, add -o ...,fsc"
+ elog "to the mount options of your network mounts, and let it fly!"
+}
diff --git a/sys-fs/cachefilesd/metadata.xml b/sys-fs/cachefilesd/metadata.xml
index c845479d513e..4a00a64b40ae 100644
--- a/sys-fs/cachefilesd/metadata.xml
+++ b/sys-fs/cachefilesd/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>