summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2010-03-09 17:57:08 +0000
committerPatrick McLean <chutzpah@gentoo.org>2010-03-09 17:57:08 +0000
commit3b15635f1ffb7155670aeffe25d01542ebf10e73 (patch)
treee02d6fa67c46ca8f82618935c3e561b9f39416ff /sys-fs
parentFix version hacking, Apple actually parses it back again to set __APPLE_CC__ ... (diff)
downloadgentoo-2-3b15635f1ffb7155670aeffe25d01542ebf10e73.tar.gz
gentoo-2-3b15635f1ffb7155670aeffe25d01542ebf10e73.tar.bz2
gentoo-2-3b15635f1ffb7155670aeffe25d01542ebf10e73.zip
Version bump (bug #308493), fix pulling in of sys-fs/fuse if external-fuse is turned off (bug #282408).
(Portage version: 2.1.8.2/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog6
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild16
2 files changed, 19 insertions, 3 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 223ae72168c6..24ddae60fb87 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.91 2010/03/09 17:35:47 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.92 2010/03/09 17:57:08 chutzpah Exp $
+
+ 09 Mar 2010; Patrick McLean <chutzpah@gentoo.org> ntfs3g-2010.3.6.ebuild:
+ Version bump (bug #308493), fix pulling in of sys-fs/fuse if external-fuse
+ is turned off (bug #282408).
*ntfs3g-2010.3.6 (09 Mar 2010)
diff --git a/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
index 2cd6a7b3adff..926ebe0e68ea 100644
--- a/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild,v 1.1 2010/03/09 17:35:47 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild,v 1.2 2010/03/09 17:57:08 chutzpah Exp $
EAPI=2
+inherit linux-info
MY_PN="${PN/3g/-3g}"
MY_P="${MY_PN}-${PV}"
@@ -16,13 +17,24 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="acl debug hal suid +external-fuse"
-RDEPEND=">=sys-fs/fuse-2.6.0
+RDEPEND="external-fuse? ( >=sys-fs/fuse-2.6.0 )
hal? ( sys-apps/hal )"
DEPEND="${RDEPEND}
sys-apps/attr"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if use external-fuse && use kernel_linux; then
+ if kernel_is lt 2 6 9; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use ntfs-3g"
+ linux-info_pkg_setup
+ fi
+}
+
src_configure() {
econf \
--docdir="/usr/share/doc/${PF}" \