summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2006-04-15 08:02:21 +0000
committerJohn Mylchreest <johnm@gentoo.org>2006-04-15 08:02:21 +0000
commitd4c930dc5762e1a48611536f96bfb8d4f135fa87 (patch)
tree03f1b8fb6ea24ee21ab1775e54d1c4baae25e699 /sys-fs/static-dev
parentarm/hppa/ia64/s390/sh stable (diff)
downloadgentoo-2-d4c930dc5762e1a48611536f96bfb8d4f135fa87.tar.gz
gentoo-2-d4c930dc5762e1a48611536f96bfb8d4f135fa87.tar.bz2
gentoo-2-d4c930dc5762e1a48611536f96bfb8d4f135fa87.zip
bail if trying to install on devfs or udev
(Portage version: 2.1_pre8-r5)
Diffstat (limited to 'sys-fs/static-dev')
-rw-r--r--sys-fs/static-dev/ChangeLog5
-rw-r--r--sys-fs/static-dev/files/digest-static-dev-0.11
-rw-r--r--sys-fs/static-dev/static-dev-0.1.ebuild19
3 files changed, 22 insertions, 3 deletions
diff --git a/sys-fs/static-dev/ChangeLog b/sys-fs/static-dev/ChangeLog
index 02de13cffe03..919af48c86f3 100644
--- a/sys-fs/static-dev/ChangeLog
+++ b/sys-fs/static-dev/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/static-dev
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/static-dev/ChangeLog,v 1.1 2006/03/20 22:01:10 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/static-dev/ChangeLog,v 1.2 2006/04/15 08:02:21 johnm Exp $
+
+ 15 Apr 2006; John Mylchreest <johnm@gentoo.org> static-dev-0.1.ebuild:
+ Exit if trying to install over udev or devfs
*static-dev-0.1 (20 Mar 2006)
diff --git a/sys-fs/static-dev/files/digest-static-dev-0.1 b/sys-fs/static-dev/files/digest-static-dev-0.1
index e69de29bb2d1..8b137891791f 100644
--- a/sys-fs/static-dev/files/digest-static-dev-0.1
+++ b/sys-fs/static-dev/files/digest-static-dev-0.1
@@ -0,0 +1 @@
+
diff --git a/sys-fs/static-dev/static-dev-0.1.ebuild b/sys-fs/static-dev/static-dev-0.1.ebuild
index 0ee900b47e72..775839e41e17 100644
--- a/sys-fs/static-dev/static-dev-0.1.ebuild
+++ b/sys-fs/static-dev/static-dev-0.1.ebuild
@@ -1,17 +1,32 @@
# Copyright 2005-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/static-dev/static-dev-0.1.ebuild,v 1.1 2006/03/20 22:01:10 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/static-dev/static-dev-0.1.ebuild,v 1.2 2006/04/15 08:02:21 johnm Exp $
DESCRIPTION="A skeleton, statically managed /dev"
HOMEPAGE="http://bugs.gentoo.org/show_bug.cgi?id=107875"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha ~arm ~hppa ~ia64 ~m68k ~mips ~s390 ~sparc"
+KEYWORDS="x86 ~ppc ~alpha ~arm ~hppa ~ia64 ~m68k ~mips ~s390 ~sparc"
IUSE=""
RDEPEND="virtual/baselayout"
PROVIDE="virtual/dev-manager"
+pkg_setup() {
+ if [[ -d /dev/.udev/ || ! -c /dev/.devfs ]]; then
+ echo ""
+ eerror "We have detected that you currently use udev or devfs"
+ eerror "and this ebuild cannot install to the same mount-point."
+ eerror "Please reinstall the ebuild (as root) like follows:"
+ eerror ""
+ eerror "mkdir /tmp/newroot"
+ eerror "mount -o bind / /tmp/newroot"
+ eerror "ROOT=/tmp/newroot/ emerge sys-fs/static-dev"
+ eerror "umount /tmp/newroot"
+ die "Cannot install on udev/devfs tmpfs."
+ fi
+}
+
pkg_postinst() {
local x="generic"
local makedev