summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Gaffney <agaffney@gentoo.org>2009-06-01 13:05:09 +0000
committerAndrew Gaffney <agaffney@gentoo.org>2009-06-01 13:05:09 +0000
commitd2fa7ee72cec956c80903254e9a6bdf6804151c7 (patch)
tree223f7897438dfd4afb8ce31d34cb2609e0cfc59e /sys-fs/squashfs-tools
parentamd64/x86 stable, bug #272048 (diff)
downloadgentoo-2-d2fa7ee72cec956c80903254e9a6bdf6804151c7.tar.gz
gentoo-2-d2fa7ee72cec956c80903254e9a6bdf6804151c7.tar.bz2
gentoo-2-d2fa7ee72cec956c80903254e9a6bdf6804151c7.zip
Bumping squashfs-tools to 4.0 for bug #272043
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/squashfs-tools')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog10
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index f3e4375206dc..d2b9d5844557 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/squashfs-tools
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.59 2009/03/25 18:09:20 zmedico Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.60 2009/06/01 13:05:09 agaffney Exp $
+
+*squashfs-tools-4.0 (01 Jun 2009)
+
+ 01 Jun 2009; Andrew Gaffney <agaffney@gentoo.org>
+ +squashfs-tools-4.0.ebuild:
+ Bumping squashfs-tools to 4.0 for bug #272043
*squashfs-tools-4.0_pre20090324 (25 Mar 2009)
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild
new file mode 100644
index 000000000000..6b05bfedd879
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.0.ebuild,v 1.1 2009/06/01 13:05:09 agaffney Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+
+S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:-O2:$(CFLAGS):' \
+ -e 's:$(CC):$(CC) $(LDFLAGS):' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin mksquashfs unsquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README
+}
+
+pkg_postinst() {
+ ewarn "This version of mksquashfs requires a 2.6.24 kernel or better."
+}