summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-01-31 02:53:19 +0000
committerJeroen Roovers <jer@gentoo.org>2011-01-31 02:53:19 +0000
commita1d2c57b32290a330ceb9dcda75974b91df3060c (patch)
tree0223267cc110a2f126b96ca8fe38e828a9b733f1 /sys-fs/squashfs-tools
parentadd kde herd to metadata.xml (diff)
downloadgentoo-2-a1d2c57b32290a330ceb9dcda75974b91df3060c.tar.gz
gentoo-2-a1d2c57b32290a330ceb9dcda75974b91df3060c.tar.bz2
gentoo-2-a1d2c57b32290a330ceb9dcda75974b91df3060c.zip
Die sooner (and explain why) when no compression USE flag is set (bug #352861). Fix USE=-lzma case (it tried to fix xz_SUPPORT in the Makefile instead of XZ_SUPPORT, so it would always link against liblzma or die if not found).
(Portage version: 2.2.0_alpha19/cvs/Linux i686)
Diffstat (limited to 'sys-fs/squashfs-tools')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog12
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.1-r1.ebuild72
2 files changed, 82 insertions, 2 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index da5cbe9ecbfc..344bafc49f7c 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/squashfs-tools
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.72 2010/11/14 13:49:59 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.73 2011/01/31 02:53:19 jer Exp $
+
+*squashfs-tools-4.1-r1 (31 Jan 2011)
+
+ 31 Jan 2011; Jeroen Roovers <jer@gentoo.org> +squashfs-tools-4.1-r1.ebuild:
+ Die sooner (and explain why) when no compression USE flag is set (bug
+ #352861). Fix USE=-lzma case (it tried to fix xz_SUPPORT in the Makefile
+ instead of XZ_SUPPORT, so it would always link against liblzma or die if not
+ found).
14 Nov 2010; Justin Lecher <jlec@gentoo.org> squashfs-tools-3.2_p2.ebuild,
squashfs-tools-3.4.ebuild, squashfs-tools-4.0.ebuild,
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.1-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.1-r1.ebuild
new file mode 100644
index 000000000000..7525627cba4f
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.1-r1.ebuild,v 1.1 2011/01/31 02:53:19 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+gzip +lzma lzo xattr"
+
+RDEPEND="gzip? ( sys-libs/zlib )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ !lzma? ( !lzo? ( sys-libs/zlib ) )
+ xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/squashfs${MY_PV}/squashfs-tools
+
+src_prepare() {
+ sed -i \
+ -e "s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+ -e '/^LIBS =/s:$: $(LDFLAGS):' \
+ Makefile || die
+}
+
+use_sed() {
+ local u=$1 s="${2:-`echo $1 | tr '[:lower:]' '[:upper:]'`}_SUPPORT"
+ printf '/^#?%s =/%s\n' "${s}" \
+ "$( use $u && echo s:.*:${s} = 1: || echo d )"
+}
+src_configure() {
+ tc-export CC
+ local def
+ if use gzip; then def="gzip"
+ einfo "enabling gzip"
+ elif use lzma; then def="lzma"
+ einfo "enabling lzma"
+ elif use lzo; then def="lzo"
+ einfo "enabling lzo"
+ else
+ die "Please set at least one of the gzip, lzma and lzo USE flags as compression algorithm."
+ fi
+
+ einfo "Using ${def} as compression algorithm."
+
+ sed -i -r \
+ -e "/^COMP_DEFAULT =/s:=.*:= ${def}:" \
+ -e "$(use_sed gzip)" \
+ -e "$(use_sed lzma XZ)" \
+ -e "$(use_sed lzo)" \
+ -e "$(use_sed xattr)" \
+ Makefile || die
+}
+
+src_install() {
+ dobin mksquashfs unsquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README || die
+}
+
+pkg_postinst() {
+ ewarn "This version of mksquashfs requires a 2.6.29 kernel or better"
+}