summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2015-05-31 09:45:07 +0000
committerFabian Groffen <grobian@gentoo.org>2015-05-31 09:45:07 +0000
commit2cfa72b6f0c6ea2a5dcb31fb76a63047e83c9045 (patch)
treec2b6c10e6d541edcbaaf681f4445d1ef52967f64 /sys-devel
parentamd64 stable wrt bug #530846 (diff)
downloadgentoo-2-2cfa72b6f0c6ea2a5dcb31fb76a63047e83c9045.tar.gz
gentoo-2-2cfa72b6f0c6ea2a5dcb31fb76a63047e83c9045.tar.bz2
gentoo-2-2cfa72b6f0c6ea2a5dcb31fb76a63047e83c9045.zip
Allow LLVM to compile itself. This is useful for Darwin, where LLVM is going to be the only compiler available by default.
(Portage version: 2.2.14-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog7
-rw-r--r--sys-devel/llvm/llvm-3.4.2.ebuild6
-rw-r--r--sys-devel/llvm/llvm-3.5.2.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.6.1.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
5 files changed, 15 insertions, 10 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index b0cadcc1879e..d596bc84b87b 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.241 2015/05/29 09:24:43 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.242 2015/05/31 09:45:07 grobian Exp $
+
+ 31 May 2015; Fabian Groffen <grobian@gentoo.org> llvm-3.4.2.ebuild,
+ llvm-3.5.2.ebuild, llvm-3.6.1.ebuild, llvm-9999.ebuild:
+ Allow LLVM to compile itself. This is useful for Darwin, where LLVM is going
+ to be the only compiler available by default.
29 May 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-9999.ebuild:
Revert accidental commit on live ebuild, should fix #550608 and #550682
diff --git a/sys-devel/llvm/llvm-3.4.2.ebuild b/sys-devel/llvm/llvm-3.4.2.ebuild
index 200255d140bf..9a6d79614e27 100644
--- a/sys-devel/llvm/llvm-3.4.2.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.2.ebuild,v 1.10 2015/04/16 11:55:18 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.2.ebuild,v 1.11 2015/05/31 09:45:07 grobian Exp $
EAPI=5
@@ -47,7 +47,7 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/make-3.81
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 >=sys-devel/llvm-3.3
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
@@ -56,7 +56,7 @@ DEPEND="${COMMON_DEPEND}
libffi? ( virtual/pkgconfig )
${PYTHON_DEPS}"
RDEPEND="${COMMON_DEPEND}
- clang? ( !<=sys-devel/clang-3.4-r99
+ clang? ( !<=sys-devel/clang-${PV}-r99
!>=sys-devel/clang-9999 )
abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r2
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
diff --git a/sys-devel/llvm/llvm-3.5.2.ebuild b/sys-devel/llvm/llvm-3.5.2.ebuild
index 7e8f4ca0bc73..330de26b69d1 100644
--- a/sys-devel/llvm/llvm-3.5.2.ebuild
+++ b/sys-devel/llvm/llvm-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.2.ebuild,v 1.2 2015/04/16 11:55:18 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.2.ebuild,v 1.3 2015/05/31 09:45:07 grobian Exp $
EAPI=5
@@ -46,7 +46,7 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/make-3.81
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 >=sys-devel/llvm-3.3
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
diff --git a/sys-devel/llvm/llvm-3.6.1.ebuild b/sys-devel/llvm/llvm-3.6.1.ebuild
index 951a2be54be9..9f6086e1acba 100644
--- a/sys-devel/llvm/llvm-3.6.1.ebuild
+++ b/sys-devel/llvm/llvm-3.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild,v 1.1 2015/05/27 11:58:56 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild,v 1.2 2015/05/31 09:45:07 grobian Exp $
EAPI=5
@@ -46,7 +46,7 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/make-3.81
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 >=sys-devel/llvm-3.5
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index ffbe8e876010..ed6b3972d4f4 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.107 2015/05/29 09:24:43 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.108 2015/05/31 09:45:07 grobian Exp $
EAPI=5
@@ -44,7 +44,7 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/make-3.81
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 >=sys-devel/llvm-3.5
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )