summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2015-05-31 14:38:44 +0000
committerFabian Groffen <grobian@gentoo.org>2015-05-31 14:38:44 +0000
commit115390ce5c6fe356e2279e03a36d9dec1a5b0955 (patch)
treea106c528ef0d2a8776618dbbac99d74aa03e90fc /sys-devel
parentported all-gentoo prefs from firefox-bin to address Logjam attack vector, bug... (diff)
downloadgentoo-2-115390ce5c6fe356e2279e03a36d9dec1a5b0955.tar.gz
gentoo-2-115390ce5c6fe356e2279e03a36d9dec1a5b0955.tar.bz2
gentoo-2-115390ce5c6fe356e2279e03a36d9dec1a5b0955.zip
Fix dependencies for Darwin: only 3.4 can be compiled with gcc-apple-4.2.1, later versions need Clang. We can compile 3.4 without libcxx, later versions need it on Darwin, so require it.
(Portage version: 2.2.14-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog8
-rw-r--r--sys-devel/llvm/llvm-3.5.2.ebuild5
-rw-r--r--sys-devel/llvm/llvm-3.6.1.ebuild5
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild5
4 files changed, 16 insertions, 7 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index d596bc84b87b..3ffa7444c99d 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.242 2015/05/31 09:45:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.243 2015/05/31 14:38:44 grobian Exp $
+
+ 31 May 2015; Fabian Groffen <grobian@gentoo.org> llvm-3.4.2.ebuild,
+ llvm-3.5.2.ebuild, llvm-3.6.1.ebuild, llvm-9999.ebuild:
+ Fix dependencies for Darwin: only 3.4 can be compiled with gcc-apple-4.2.1,
+ later versions need Clang. We can compile 3.4 without libcxx, later versions
+ need it on Darwin, so require it.
31 May 2015; Fabian Groffen <grobian@gentoo.org> llvm-3.4.2.ebuild,
llvm-3.5.2.ebuild, llvm-3.6.1.ebuild, llvm-9999.ebuild:
diff --git a/sys-devel/llvm/llvm-3.5.2.ebuild b/sys-devel/llvm/llvm-3.5.2.ebuild
index 330de26b69d1..c2408c32d3f3 100644
--- a/sys-devel/llvm/llvm-3.5.2.ebuild
+++ b/sys-devel/llvm/llvm-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.2.ebuild,v 1.3 2015/05/31 09:45:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.2.ebuild,v 1.4 2015/05/31 14:38:44 grobian Exp $
EAPI=5
@@ -46,10 +46,11 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/make-3.81
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 >=sys-devel/llvm-3.3
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.3
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
+ kernel_Darwin? ( sys-libs/libcxx )
clang? ( xml? ( virtual/pkgconfig ) )
doc? ( dev-python/sphinx )
libffi? ( virtual/pkgconfig )
diff --git a/sys-devel/llvm/llvm-3.6.1.ebuild b/sys-devel/llvm/llvm-3.6.1.ebuild
index 9f6086e1acba..9251facce1ea 100644
--- a/sys-devel/llvm/llvm-3.6.1.ebuild
+++ b/sys-devel/llvm/llvm-3.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild,v 1.2 2015/05/31 09:45:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.1.ebuild,v 1.3 2015/05/31 14:38:44 grobian Exp $
EAPI=5
@@ -46,10 +46,11 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/make-3.81
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 >=sys-devel/llvm-3.5
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.5
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
+ kernel_Darwin? ( sys-libs/libcxx )
clang? ( xml? ( virtual/pkgconfig ) )
doc? ( dev-python/sphinx )
libffi? ( virtual/pkgconfig )
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index ed6b3972d4f4..59644a76c18f 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.108 2015/05/31 09:45:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.109 2015/05/31 14:38:44 grobian Exp $
EAPI=5
@@ -44,10 +44,11 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/make-3.81
>=sys-devel/flex-2.5.4
>=sys-devel/bison-1.875d
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 >=sys-devel/llvm-3.5
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.5
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
+ kernel_Darwin? ( sys-libs/libcxx )
clang? ( xml? ( virtual/pkgconfig ) )
libffi? ( virtual/pkgconfig )
!!<dev-python/configparser-3.3.0.2