summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-10 12:59:49 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-10 12:59:49 +0000
commit4b925e9dc186f82752a2106ec406ebdaa902e6b0 (patch)
tree753d4fe3bdbb9e8281e8066082e364493cd8315e /sys-cluster
parentMask new vzctl and ploop until all deps will be fixed (diff)
downloadgentoo-2-4b925e9dc186f82752a2106ec406ebdaa902e6b0.tar.gz
gentoo-2-4b925e9dc186f82752a2106ec406ebdaa902e6b0.tar.bz2
gentoo-2-4b925e9dc186f82752a2106ec406ebdaa902e6b0.zip
Version bump, wrt bug #437686. Thanks to Andreis Vinogradovs, ebuild is taken from rion overlay with some improvements
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ploop/ChangeLog8
-rw-r--r--sys-cluster/ploop/ploop-1.5.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-cluster/ploop/ChangeLog b/sys-cluster/ploop/ChangeLog
index 7a23d51c979a..3bba7454c610 100644
--- a/sys-cluster/ploop/ChangeLog
+++ b/sys-cluster/ploop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/ploop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.2 2012/07/17 05:23:08 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ChangeLog,v 1.3 2012/12/10 12:59:49 pinkbyte Exp $
+
+*ploop-1.5 (10 Dec 2012)
+
+ 10 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> +ploop-1.5.ebuild:
+ Version bump, wrt bug #437686. Thanks to Andreis Vinogradovs, ebuild is taken
+ from rion overlay with some improvements
*ploop-1.4 (17 Jul 2012)
diff --git a/sys-cluster/ploop/ploop-1.5.ebuild b/sys-cluster/ploop/ploop-1.5.ebuild
new file mode 100644
index 000000000000..753513053a3e
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ploop/ploop-1.5.ebuild,v 1.1 2012/12/10 12:59:49 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="http://wiki.openvz.org/Download/ploop"
+SRC_URI="http://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+DOCS=( tools/README )
+
+src_prepare() {
+ # Respect CFLAGS and CC
+ sed -e 's|CFLAGS =|CFLAGS +=|' -e 's|CC=|CC?=|' \
+ -i Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ epatch "${FILESDIR}/ploop-1.2-soname.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1
+}
+
+src_install() {
+ default
+ ldconfig -n "${D}/usr/$(get_libdir)/" || die
+ use static-libs || rm "${D}/usr/$(get_libdir)/libploop.a" || die 'remove static lib failed'
+}
+
+pkg_postinst() {
+ elog "Warning - API changes"
+ elog "1. This version requires running vzkernel >= 2.6.32-042stab061.1"
+ elog "2. DiskDescriptor.xml created by older ploop versions are converted to current format"
+}