summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-08-21 03:39:21 +0000
committerYixun Lan <dlan@gentoo.org>2014-08-21 03:39:21 +0000
commit565208fa5b0439fe088e6182eba3764e0051bc28 (patch)
tree92dd7c589930b478b56e909da5eb1a09efcb9aef /sys-cluster/ceph
parentVerision bump to 2.0 adding a simple checkconfig and support for chroot (diff)
downloadgentoo-2-565208fa5b0439fe088e6182eba3764e0051bc28.tar.gz
gentoo-2-565208fa5b0439fe088e6182eba3764e0051bc28.tar.bz2
gentoo-2-565208fa5b0439fe088e6182eba3764e0051bc28.zip
roll back old stable versions, bug 520250
(Portage version: 2.2.12/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ChangeLog6
-rw-r--r--sys-cluster/ceph/ceph-0.56.3.ebuild106
-rw-r--r--sys-cluster/ceph/files/ceph.confd8
-rw-r--r--sys-cluster/ceph/files/ceph.initd27
4 files changed, 146 insertions, 1 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 5abf51508689..5874e1a665ce 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.56 2014/08/19 08:57:46 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.57 2014/08/21 03:39:21 dlan Exp $
+
+ 21 Aug 2014; Yixun Lan <dlan@gentoo.org> ceph-0.56.3.ebuild,
+ +files/ceph.confd, +files/ceph.initd:
+ roll back old stable versions, bug 520250
*ceph-0.67.10 (19 Aug 2014)
diff --git a/sys-cluster/ceph/ceph-0.56.3.ebuild b/sys-cluster/ceph/ceph-0.56.3.ebuild
new file mode 100644
index 000000000000..a5da61c9778b
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.56.3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.56.3.ebuild,v 1.5 2014/08/21 03:39:21 dlan Exp $
+
+EAPI=5
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="
+ git://github.com/ceph/ceph.git
+ https://github.com/ceph/ceph.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+ KEYWORDS="amd64 x86"
+fi
+
+inherit autotools eutils multilib udev ${scm_eclass}
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="debug fuse gtk libatomic radosgw static-libs tcmalloc"
+
+CDEPEND="
+ dev-libs/boost
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/crypto++
+ sys-apps/keyutils
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-fs/btrfs-progs"
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+src_prepare() {
+ sed -e 's:invoke-rc\.d.*:/etc/init.d/ceph reload >/dev/null:' \
+ -i src/logrotate.conf || die
+ sed -i "/^docdir =/d" src/Makefile.am || die #fix doc path
+ # disable testsnaps
+ sed -e '/testsnaps/d' -i src/Makefile.am || die
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+ sed -i -e '/AM_INIT_AUTOMAKE/s:-Werror ::' src/leveldb/configure.ac || die #423755
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ rmdir "${ED}/usr/sbin"
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ # install udev rules
+ udev_dorules udev/50-rbd.rules
+}
diff --git a/sys-cluster/ceph/files/ceph.confd b/sys-cluster/ceph/files/ceph.confd
new file mode 100644
index 000000000000..1afc33560e1b
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph.confd
@@ -0,0 +1,8 @@
+# These are passed as arguments to original ceph initscript
+# see also http://ceph.newdream.net/wiki/Starting_and_stopping
+
+# CEPH_COMMON=( --hostname myhost )
+
+CEPH_START=( start )
+CEPH_STOP=( stop )
+CEPH_RELOAD=( reload )
diff --git a/sys-cluster/ceph/files/ceph.initd b/sys-cluster/ceph/files/ceph.initd
new file mode 100644
index 000000000000..993bb01b60a8
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+
+extra_started_commands="reload"
+bin=/usr/lib/ceph/ceph_init.sh
+
+depend() {
+ after net
+ before netmount
+}
+
+start() {
+ ebegin "Initializing local Ceph node"
+ $bin "${CEPH_COMMON[@]}" "${CEPH_START[@]}"
+ eend 0
+}
+
+reload() {
+ ebegin "Reloading ceph configuration"
+ $bin "${CEPH_COMMON[@]}" "${CEPH_RELOAD[@]}"
+ eend 0
+}
+
+stop() {
+ ebegin "Stopping local Ceph node"
+ $bin "${CEPH_COMMON[@]}" "${CEPH_STOP[@]}"
+ eend 0
+}