summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-07-18 06:42:13 +0000
committerYixun Lan <dlan@gentoo.org>2014-07-18 06:42:13 +0000
commit4866a5afb5582bf875498623242c951314225f10 (patch)
treeb89270b251dc7e651b8238cb60c48dcbd3102012 /sys-cluster/ceph
parentVersion bump. (diff)
downloadgentoo-2-4866a5afb5582bf875498623242c951314225f10.tar.gz
gentoo-2-4866a5afb5582bf875498623242c951314225f10.tar.bz2
gentoo-2-4866a5afb5582bf875498623242c951314225f10.zip
revision bump, clean old, bug 517122. thanks @babykart
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ChangeLog10
-rw-r--r--sys-cluster/ceph/ceph-0.67.9.ebuild (renamed from sys-cluster/ceph/ceph-0.67.7.ebuild)16
-rw-r--r--sys-cluster/ceph/ceph-0.72.2-r3.ebuild140
-rw-r--r--sys-cluster/ceph/ceph-0.80.4.ebuild (renamed from sys-cluster/ceph/ceph-0.80.1.ebuild)2
-rw-r--r--sys-cluster/ceph/ceph-9999.ebuild8
5 files changed, 26 insertions, 150 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 532471e78ae4..50e14bbebf2d 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.53 2014/07/06 12:56:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.54 2014/07/18 06:42:13 dlan Exp $
+
+*ceph-0.80.4 (18 Jul 2014)
+*ceph-0.67.9 (18 Jul 2014)
+
+ 18 Jul 2014; Yixun Lan <dlan@gentoo.org> -ceph-0.67.7.ebuild,
+ +ceph-0.67.9.ebuild, -ceph-0.72.2-r3.ebuild, -ceph-0.80.1.ebuild,
+ +ceph-0.80.4.ebuild, ceph-9999.ebuild:
+ revision bump, clean old, bug 517122. thanks @babykart
06 Jul 2014; Michał Górny <mgorny@gentoo.org> ceph-0.67.7.ebuild,
ceph-0.72.2-r3.ebuild, ceph-0.80.1.ebuild, ceph-9999.ebuild:
diff --git a/sys-cluster/ceph/ceph-0.67.7.ebuild b/sys-cluster/ceph/ceph-0.67.9.ebuild
index 516f955ede0f..369762a353eb 100644
--- a/sys-cluster/ceph/ceph-0.67.7.ebuild
+++ b/sys-cluster/ceph/ceph-0.67.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.67.7.ebuild,v 1.3 2014/07/06 12:56:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.67.9.ebuild,v 1.1 2014/07/18 06:42:13 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -111,7 +111,7 @@ src_install() {
newexe src/init-ceph ceph_init.sh
insinto /etc/logrotate.d/
- newins src/logrotate.conf ${PN}
+ newins "${FILESDIR}"/ceph.logrotate ${PN}
chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
@@ -119,8 +119,8 @@ src_install() {
keepdir /var/lib/${PN}/tmp
keepdir /var/log/${PN}/stat
- newinitd "${T}/${PN}.initd" ${PN}
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd-r1" ${PN}
python_fix_shebang \
"${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
@@ -136,4 +136,12 @@ pkg_postinst() {
elog " sys-block/parted to manage disk partions"
elog " sys-fs/btrfs-progs to use btrfs filesytem"
elog " sys-fs/cryptsetup to use encrypted devices with dm-crypt"
+ elog ""
+ elog "To have many daemons of one type, create your own script:"
+ elog ""
+ elog "cd /etc/init.d"
+ elog "for dmn in mds.a mon.a osd.0 osd.1 osd.2; do"
+ elog " ln -s ceph ceph-\${dmn};"
+ elog " rc-update add ceph-\${dmn} default;"
+ elog "done"
}
diff --git a/sys-cluster/ceph/ceph-0.72.2-r3.ebuild b/sys-cluster/ceph/ceph-0.72.2-r3.ebuild
deleted file mode 100644
index fe171bc733a0..000000000000
--- a/sys-cluster/ceph/ceph-0.72.2-r3.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.72.2-r3.ebuild,v 1.3 2014/07/06 12:56:17 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-if [[ $PV = *9999* ]]; then
- scm_eclass=git-r3
- EGIT_REPO_URI="
- git://github.com/ceph/ceph.git
- https://github.com/ceph/ceph.git"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://ceph.com/download/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
-fi
-
-inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}
-
-DESCRIPTION="Ceph distributed filesystem"
-HOMEPAGE="http://ceph.com/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs tcmalloc"
-
-CDEPEND="
- app-arch/snappy
- dev-libs/boost:=[threads]
- dev-libs/fcgi
- dev-libs/libaio
- dev-libs/libedit
- dev-libs/leveldb[snappy]
- nss? ( dev-libs/nss )
- cryptopp? ( dev-libs/crypto++ )
- sys-apps/keyutils
- sys-apps/util-linux
- dev-libs/libxml2
- fuse? ( sys-fs/fuse )
- libatomic? ( dev-libs/libatomic_ops )
- gtk? (
- x11-libs/gtk+:2
- dev-cpp/gtkmm:2.4
- gnome-base/librsvg
- )
- radosgw? (
- dev-libs/fcgi
- dev-libs/expat
- net-misc/curl
- )
- tcmalloc? ( dev-util/google-perftools )
- $(python_gen_any_dep '
- ' )
- ${PYTHON_DEPS}
- "
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
- sys-apps/hdparm
- $(python_gen_any_dep '
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ' )"
-REQUIRED_USE="
- ^^ ( nss cryptopp )
- "
-
-STRIP_MASK="/usr/lib*/rados-classes/*"
-
-PATCHES=( "${FILESDIR}"/${PN}-fix-gnustack.patch )
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- if [ ! -z ${PATCHES[@]} ]; then
- epatch ${PATCHES[@]}
- fi
- sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
- > "${T}"/${PN}.initd || die
-
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- econf \
- --without-hadoop \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --includedir=/usr/include \
- $(use_with debug) \
- $(use_with fuse) \
- $(use_with libaio) \
- $(use_with libatomic libatomic-ops) \
- $(use_with nss) \
- $(use_with cryptopp) \
- $(use_with radosgw) \
- $(use_with gtk gtk2) \
- $(use_enable static-libs static) \
- $(use_with tcmalloc)
-}
-
-src_install() {
- default
-
- prune_libtool_files --all
-
- exeinto /usr/$(get_libdir)/ceph
- newexe src/init-ceph ceph_init.sh
-
- insinto /etc/logrotate.d/
- newins src/logrotate.conf ${PN}
-
- chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
-
- keepdir /var/lib/${PN}
- keepdir /var/lib/${PN}/tmp
- keepdir /var/log/${PN}/stat
-
- newinitd "${T}/${PN}.initd" ${PN}
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
-
- python_fix_shebang \
- "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
- "${ED}"/usr/bin/{ceph,ceph-rest-api}
-
- #install udev rules
- udev_dorules udev/50-rbd.rules
- udev_dorules udev/95-ceph-osd.rules
-}
-
-pkg_postinst() {
- elog "We suggest to install following packages"
- elog " sys-block/parted to manage disk partions"
- elog " sys-fs/btrfs-progs to use btrfs filesytem"
- elog " sys-fs/cryptsetup to use encrypted devices with dm-crypt"
-}
diff --git a/sys-cluster/ceph/ceph-0.80.1.ebuild b/sys-cluster/ceph/ceph-0.80.4.ebuild
index 74672e1d20c0..0731c8a36968 100644
--- a/sys-cluster/ceph/ceph-0.80.1.ebuild
+++ b/sys-cluster/ceph/ceph-0.80.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.80.1.ebuild,v 1.4 2014/07/06 12:56:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.80.4.ebuild,v 1.1 2014/07/18 06:42:13 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
diff --git a/sys-cluster/ceph/ceph-9999.ebuild b/sys-cluster/ceph/ceph-9999.ebuild
index 64e98121ef7a..dc9a84262562 100644
--- a/sys-cluster/ceph/ceph-9999.ebuild
+++ b/sys-cluster/ceph/ceph-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.11 2014/07/06 12:56:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.12 2014/07/18 06:42:13 dlan Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -121,7 +121,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}.initd-r1" ${PN}
newconfd "${FILESDIR}/${PN}.confd-r1" ${PN}
- _python_rewrite_shebang \
+ python_fix_shebang \
"${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
"${ED}"/usr/bin/{ceph,ceph-rest-api}
@@ -140,7 +140,7 @@ pkg_postinst() {
elog ""
elog "cd /etc/init.d"
elog "for dmn in mds.a mon.a osd.0 osd.1 osd.2; do"
- elog " ln -s ceph ceph-${dmn};"
- elog " rc-update add ceph-${dmn} default;"
+ elog " ln -s ceph ceph-\${dmn};"
+ elog " rc-update add ceph-\${dmn} default;"
elog "done"
}