summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-01-31 13:26:02 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-01-31 13:26:02 +0000
commit5535add1637edbad51357e7b8c2013d93e02b0c8 (patch)
treeb44240b1c9b0d32c80c0eb6c51ced9953580bd45 /sys-boot/lilo
parentversion bump (diff)
downloadgentoo-2-5535add1637edbad51357e7b8c2013d93e02b0c8.tar.gz
gentoo-2-5535add1637edbad51357e7b8c2013d93e02b0c8.tar.bz2
gentoo-2-5535add1637edbad51357e7b8c2013d93e02b0c8.zip
Deal with new coreutils, the new cut insists you start from 1, not 0. Also, be a bit more intelligent about generating labels, do not prefix the backup label with o if the name is unique already. Quote a few variables too.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-boot/lilo')
-rw-r--r--sys-boot/lilo/ChangeLog12
-rw-r--r--sys-boot/lilo/lilo-22.7.3-r1.ebuild30
-rw-r--r--sys-boot/lilo/lilo-22.8-r1.ebuild28
-rw-r--r--sys-boot/lilo/lilo-22.8-r2.ebuild182
-rw-r--r--sys-boot/lilo/lilo-22.8.ebuild26
5 files changed, 234 insertions, 44 deletions
diff --git a/sys-boot/lilo/ChangeLog b/sys-boot/lilo/ChangeLog
index 2ca5869193fa..79c1d9d655d8 100644
--- a/sys-boot/lilo/ChangeLog
+++ b/sys-boot/lilo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-boot/lilo
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.50 2007/04/28 22:03:26 ulm Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/ChangeLog,v 1.51 2008/01/31 13:26:02 chainsaw Exp $
+
+*lilo-22.8-r2 (31 Jan 2008)
+
+ 31 Jan 2008; Tony Vroon <chainsaw@gentoo.org> lilo-22.7.3-r1.ebuild,
+ lilo-22.8.ebuild, lilo-22.8-r1.ebuild, +lilo-22.8-r2.ebuild:
+ Deal with new coreutils, the new cut insists you start from 1, not 0. Also,
+ be a bit more intelligent about generating labels, do not prefix the backup
+ label with o if the name is unique already. Quote a few variables too.
*lilo-22.8-r1 (28 Apr 2007)
diff --git a/sys-boot/lilo/lilo-22.7.3-r1.ebuild b/sys-boot/lilo/lilo-22.7.3-r1.ebuild
index 1032400e9c01..3bc122dfeb5c 100644
--- a/sys-boot/lilo/lilo-22.7.3-r1.ebuild
+++ b/sys-boot/lilo/lilo-22.7.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.3-r1.ebuild,v 1.6 2007/07/15 02:25:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.3-r1.ebuild,v 1.7 2008/01/31 13:26:02 chainsaw Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -28,22 +28,22 @@ PROVIDE="virtual/bootloader"
src_unpack() {
unpack ${MY_P}.tar.gz
- cd ${S}
+ cd "${S}"
# Correctly document commandline options -v and -V, bug #43554
- epatch ${FILESDIR}/${P}-correct-usage-info.patch
+ epatch "${FILESDIR}/${P}-correct-usage-info.patch"
# Install manpages to correct location, do not rely on incorrect manpath output, bug #117135
# Do not strip the main binary, it upsets portage, bug #140210
- epatch ${FILESDIR}/${P}-makefile.patch
+ epatch "${FILESDIR}/${P}-makefile.patch"
# Do not install diag1.img, bug #149887
- epatch ${FILESDIR}/${P}-makefile-nodiags.patch
+ epatch "${FILESDIR}/${P}-makefile-nodiags.patch"
# Do not try to read the partition table on LVM2
- epatch ${FILESDIR}/${P}-lvm2-not-partionable.patch
+ epatch "${FILESDIR}/${P}-lvm2-not-partionable.patch"
# this patch is needed when booting PXE and the device you're using
# emulates vga console via serial console.
# IE.. B.B.o.o.o.o.t.t.i.i.n.n.g.g....l.l.i.i.n.n.u.u.x.x and stair stepping.
- use pxeserial && epatch ${FILESDIR}/${P}-novga.patch
+ use pxeserial && epatch "${FILESDIR}/${P}-novga.patch"
unpack ${DOLILO_TAR}
}
@@ -67,22 +67,22 @@ src_compile() {
src_install() {
keepdir /boot
- make ROOT=${D} install || die
+ make ROOT="${D}" install || die
if use !minimal; then
into /
- dosbin ${S}/dolilo/dolilo
+ dosbin "${S}"/dolilo/dolilo
into /usr
dosbin keytab-lilo.pl
insinto /etc
- newins ${FILESDIR}/lilo.conf lilo.conf.example
+ newins "${FILESDIR}"/lilo.conf lilo.conf.example
- newconfd ${S}/dolilo/dolilo.conf.d dolilo.example
+ newconfd "${S}"/dolilo/dolilo.conf.d dolilo.example
doman manPages/*.[5-8]
- dodoc CHANGES COPYING INCOMPAT README*
+ dodoc CHANGES INCOMPAT README*
docinto samples ; dodoc sample/*
fi
}
@@ -145,10 +145,10 @@ lilocheck () {
}
pkg_postinst() {
- if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ if [ ! -e "${ROOT}"/boot/boot.b -a ! -L "${ROOT}"/boot/boot.b ]
then
[ -f "${ROOT}/boot/boot-menu.b" ] && \
- ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ ln -snf boot-menu.b "${ROOT}"/boot/boot.b
fi
if [ "${ROOT}" = "/" ] && use !minimal;
diff --git a/sys-boot/lilo/lilo-22.8-r1.ebuild b/sys-boot/lilo/lilo-22.8-r1.ebuild
index 10e509b468c2..1c968e89b239 100644
--- a/sys-boot/lilo/lilo-22.8-r1.ebuild
+++ b/sys-boot/lilo/lilo-22.8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.8-r1.ebuild,v 1.3 2007/07/15 02:25:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.8-r1.ebuild,v 1.4 2008/01/31 13:26:02 chainsaw Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -29,20 +29,20 @@ PROVIDE="virtual/bootloader"
src_unpack() {
unpack ${MY_P}.tar.gz
- cd ${S}
+ cd "${S}"
# Correctly document commandline options -v and -V, bug #43554
- epatch ${FILESDIR}/${P}-correct-usage-info.patch
+ epatch "${FILESDIR}/${P}-correct-usage-info.patch"
# Install manpages to correct location, do not rely on incorrect manpath output, bug #117135
# Do not strip the main binary, it upsets portage, bug #140210
# Do not install diag1.img, bug #149887
- epatch ${FILESDIR}/${P}-makefile.patch
+ epatch "${FILESDIR}/${P}-makefile.patch"
# this patch is needed when booting PXE and the device you're using
# emulates vga console via serial console.
# IE.. B.B.o.o.o.o.t.t.i.i.n.n.g.g....l.l.i.i.n.n.u.u.x.x and stair stepping.
- use pxeserial && epatch ${FILESDIR}/${P}-novga.patch
- use device-mapper || epatch ${FILESDIR}/${P}-nodevmapper.patch
+ use pxeserial && epatch "${FILESDIR}/${P}-novga.patch"
+ use device-mapper || epatch "${FILESDIR}/${P}-nodevmapper.patch"
unpack ${DOLILO_TAR}
}
@@ -66,22 +66,22 @@ src_compile() {
src_install() {
keepdir /boot
- make ROOT=${D} install || die
+ make ROOT="${D}" install || die
if use !minimal; then
into /
- dosbin ${S}/dolilo/dolilo
+ dosbin "${S}"/dolilo/dolilo
into /usr
dosbin keytab-lilo.pl
insinto /etc
- newins ${FILESDIR}/lilo.conf lilo.conf.example
+ newins "${FILESDIR}"/lilo.conf lilo.conf.example
- newconfd ${S}/dolilo/dolilo.conf.d dolilo.example
+ newconfd "${S}"/dolilo/dolilo.conf.d dolilo.example
doman manPages/*.[5-8]
- dodoc CHANGES COPYING INCOMPAT README*
+ dodoc CHANGES INCOMPAT README*
docinto samples ; dodoc sample/*
fi
}
@@ -144,10 +144,10 @@ lilocheck () {
}
pkg_postinst() {
- if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ if [ ! -e "${ROOT}/boot/boot.b" -a ! -L "${ROOT}/boot/boot.b" ]
then
[ -f "${ROOT}/boot/boot-menu.b" ] && \
- ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ ln -snf boot-menu.b "${ROOT}/boot/boot.b"
fi
if [ "${ROOT}" = "/" ] && use !minimal;
diff --git a/sys-boot/lilo/lilo-22.8-r2.ebuild b/sys-boot/lilo/lilo-22.8-r2.ebuild
new file mode 100644
index 000000000000..874b4a2f214b
--- /dev/null
+++ b/sys-boot/lilo/lilo-22.8-r2.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.8-r2.ebuild,v 1.1 2008/01/31 13:26:02 chainsaw Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DOLILO_V="0.5"
+IUSE="static minimal pxeserial device-mapper"
+
+DESCRIPTION="Standard Linux boot loader"
+HOMEPAGE="http://lilo.go.dyndns.org/pub/linux/lilo/"
+DOLILO_TAR="dolilo-${DOLILO_V}.tar.bz2"
+MY_P=${P}.src
+
+SRC_URI="http://home.san.rr.com/johninsd/pub/linux/lilo/${MY_P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${MY_P}.tar.gz
+ ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/obsolete/${MY_P}.tar.gz
+ mirror://gentoo/${DOLILO_TAR}"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="-* ~x86 ~amd64"
+
+DEPEND=">=sys-devel/bin86-0.15.5
+ device-mapper? ( >=sys-fs/device-mapper-1.02.12 )"
+
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd "${S}"
+
+ # Correctly document commandline options -v and -V, bug #43554
+ epatch "${FILESDIR}/${P}-correct-usage-info.patch"
+ # Install manpages to correct location, do not rely on incorrect manpath output, bug #117135
+ # Do not strip the main binary, it upsets portage, bug #140210
+ # Do not install diag1.img, bug #149887
+ epatch "${FILESDIR}/${P}-makefile.patch"
+
+ # this patch is needed when booting PXE and the device you're using
+ # emulates vga console via serial console.
+ # IE.. B.B.o.o.o.o.t.t.i.i.n.n.g.g....l.l.i.i.n.n.u.u.x.x and stair stepping.
+ use pxeserial && epatch "${FILESDIR}/${P}-novga.patch"
+ use device-mapper || epatch "${FILESDIR}/${P}-nodevmapper.patch"
+
+ unpack ${DOLILO_TAR}
+}
+
+src_compile() {
+ # lilo needs this. bug 140209
+ export LC_ALL=C
+
+ # hardened automatic PIC plus PIE building should be suppressed
+ # because of assembler instructions that cannot be compiled PIC
+ HARDENED_CFLAGS="`test-flags-CC -fno-pic -nopie`"
+
+ # we explicitly prevent the custom CFLAGS for stability reasons
+ if use static; then
+ emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo.static || die
+ mv lilo.static lilo || die
+ else
+ emake CC="$(tc-getCC) ${HARDENED_CFLAGS}" lilo || die
+ fi
+}
+
+src_install() {
+ keepdir /boot
+ make ROOT="${D}" install || die
+
+ if use !minimal; then
+ into /
+ dosbin "${S}"/dolilo/dolilo
+
+ into /usr
+ dosbin keytab-lilo.pl
+
+ insinto /etc
+ newins "${FILESDIR}"/lilo.conf lilo.conf.example
+
+ newconfd "${S}"/dolilo/dolilo.conf.d dolilo.example
+
+ doman manPages/*.[5-8]
+ dodoc CHANGES INCOMPAT README*
+ docinto samples ; dodoc sample/*
+ fi
+}
+
+# Check whether LILO is installed
+# This function is from /usr/sbin/mkboot from debianutils, with copyright:
+#
+# Debian GNU/Linux
+# Copyright 1996-1997 Guy Maor <maor@debian.org>
+#
+# Modified for Gentoo for use with the lilo ebuild by:
+# Martin Schlemmer <azarah@gentoo.org> (16 Mar 2003)
+#
+lilocheck () {
+ local bootpart=
+ local rootpart="$(mount | grep -v "tmpfs" | grep -v "rootfs" | grep "on / " | cut -f1 -d " ")"
+
+ echo
+ einfon "Checking for LILO ..."
+
+ if [ "$(whoami)" != "root" ]
+ then
+ echo; echo
+ eerror "Only root can check for LILO!"
+ return 1
+ fi
+
+ if [ -z "${rootpart}" ]
+ then
+ echo; echo
+ eerror "Could not determine root partition!"
+ return 1
+ fi
+
+ if [ ! -f /etc/lilo.conf -o ! -x /sbin/lilo ]
+ then
+ echo " No"
+ return 1
+ fi
+
+ bootpart="$(sed -n "s:^boot[ ]*=[ ]*\(.*\)[ ]*:\1:p" /etc/lilo.conf)"
+
+ if [ -z "${bootpart}" ]
+ then
+ # lilo defaults to current root when 'boot=' is not present
+ bootpart="${rootpart}"
+ fi
+
+ if ! dd if=${bootpart} ibs=16 count=1 2>&- | grep -q 'LILO'
+ then
+ echo; echo
+ ewarn "Yes, but I couldn't find a LILO signature on ${bootpart}"
+ ewarn "Check your /etc/lilo.conf, or run /sbin/lilo by hand."
+ return 1
+ fi
+
+ echo " Yes, on ${bootpart}"
+
+ return 0
+}
+
+pkg_postinst() {
+ if [ ! -e "${ROOT}/boot/boot.b" -a ! -L "${ROOT}/boot/boot.b" ]
+ then
+ [ -f "${ROOT}/boot/boot-menu.b" ] && \
+ ln -snf boot-menu.b "${ROOT}/boot/boot.b"
+ fi
+
+ if [ "${ROOT}" = "/" ] && use !minimal;
+ then
+ if lilocheck
+ then
+ einfo "Running DOLILO to complete the install ..."
+ # do not redirect to /dev/null because it may display some input
+ # prompt
+ /sbin/dolilo
+ if [ "$?" -ne 0 ]
+ then
+ echo
+ ewarn "Running /sbin/dolilo failed! Please check what the problem is"
+ ewarn "before your next reboot."
+
+ ebeep 5
+ epause 5
+ fi
+ fi
+ echo
+ fi
+ if use !minimal; then
+ echo
+ einfo "Issue 'dolilo' instead of 'lilo' to have a friendly wrapper that"
+ einfo "handles mounting and unmounting /boot for you. It can do more then"
+ einfo "that when asked, edit /etc/conf.d/dolilo to harness it's full potential."
+ ebeep 5
+ epause 3
+ echo
+ fi
+}
diff --git a/sys-boot/lilo/lilo-22.8.ebuild b/sys-boot/lilo/lilo-22.8.ebuild
index 0347d9763669..8ca82185b5ef 100644
--- a/sys-boot/lilo/lilo-22.8.ebuild
+++ b/sys-boot/lilo/lilo-22.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.8.ebuild,v 1.4 2007/07/15 02:25:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.8.ebuild,v 1.5 2008/01/31 13:26:02 chainsaw Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -28,19 +28,19 @@ PROVIDE="virtual/bootloader"
src_unpack() {
unpack ${MY_P}.tar.gz
- cd ${S}
+ cd "${S}"
# Correctly document commandline options -v and -V, bug #43554
- epatch ${FILESDIR}/${P}-correct-usage-info.patch
+ epatch "${FILESDIR}/${P}-correct-usage-info.patch"
# Install manpages to correct location, do not rely on incorrect manpath output, bug #117135
# Do not strip the main binary, it upsets portage, bug #140210
# Do not install diag1.img, bug #149887
- epatch ${FILESDIR}/${P}-makefile.patch
+ epatch "${FILESDIR}/${P}-makefile.patch"
# this patch is needed when booting PXE and the device you're using
# emulates vga console via serial console.
# IE.. B.B.o.o.o.o.t.t.i.i.n.n.g.g....l.l.i.i.n.n.u.u.x.x and stair stepping.
- use pxeserial && epatch ${FILESDIR}/${P}-novga.patch
+ use pxeserial && epatch "${FILESDIR}/${P}-novga.patch"
unpack ${DOLILO_TAR}
}
@@ -64,22 +64,22 @@ src_compile() {
src_install() {
keepdir /boot
- make ROOT=${D} install || die
+ make ROOT="${D}" install || die
if use !minimal; then
into /
- dosbin ${S}/dolilo/dolilo
+ dosbin "${S}"/dolilo/dolilo
into /usr
dosbin keytab-lilo.pl
insinto /etc
- newins ${FILESDIR}/lilo.conf lilo.conf.example
+ newins "${FILESDIR}"/lilo.conf lilo.conf.example
- newconfd ${S}/dolilo/dolilo.conf.d dolilo.example
+ newconfd "${S}"/dolilo/dolilo.conf.d dolilo.example
doman manPages/*.[5-8]
- dodoc CHANGES COPYING INCOMPAT README*
+ dodoc CHANGES INCOMPAT README*
docinto samples ; dodoc sample/*
fi
}
@@ -142,10 +142,10 @@ lilocheck () {
}
pkg_postinst() {
- if [ ! -e ${ROOT}/boot/boot.b -a ! -L ${ROOT}/boot/boot.b ]
+ if [ ! -e "${ROOT}"/boot/boot.b -a ! -L "${ROOT}"/boot/boot.b ]
then
[ -f "${ROOT}/boot/boot-menu.b" ] && \
- ln -snf boot-menu.b ${ROOT}/boot/boot.b
+ ln -snf boot-menu.b "${ROOT}"/boot/boot.b
fi
if [ "${ROOT}" = "/" ] && use !minimal;