summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-06-20 06:19:16 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-06-20 06:19:16 +0000
commitfdc4398f33f839db6969f03eb472cc62d0999319 (patch)
tree4695e467bc299d9c4428045148b44a8875ee53ee /sys-apps
parentParaellel make fixes still needed during install phase. installdirs needs to ... (diff)
downloadgentoo-2-fdc4398f33f839db6969f03eb472cc62d0999319.tar.gz
gentoo-2-fdc4398f33f839db6969f03eb472cc62d0999319.tar.bz2
gentoo-2-fdc4398f33f839db6969f03eb472cc62d0999319.zip
Bump. Should fix #164329 zlib linking issue. Also respects CC, LDFLAGS, etc, might even crosscompile, and removes patches required for pre-2.2.4 pciutils. Incorporate the sparc patch from upstream instead of our own. Compile the Python module.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kudzu/ChangeLog11
-rw-r--r--sys-apps/kudzu/files/1.2.71-sparc-updates.patch174
-rw-r--r--sys-apps/kudzu/files/digest-kudzu-1.2.713
-rw-r--r--sys-apps/kudzu/kudzu-1.2.71.ebuild73
4 files changed, 260 insertions, 1 deletions
diff --git a/sys-apps/kudzu/ChangeLog b/sys-apps/kudzu/ChangeLog
index b3221cb7a65f..60dd5b65adf6 100644
--- a/sys-apps/kudzu/ChangeLog
+++ b/sys-apps/kudzu/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-apps/kudzu
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kudzu/ChangeLog,v 1.25 2007/05/02 06:46:27 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kudzu/ChangeLog,v 1.26 2007/06/20 06:19:16 dberkholz Exp $
+
+*kudzu-1.2.71 (20 Jun 2007)
+
+ 20 Jun 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/1.2.71-sparc-updates.patch, +kudzu-1.2.71.ebuild:
+ Bump. Should fix #164329 zlib linking issue. Also respects CC, LDFLAGS, etc,
+ might even crosscompile, and removes patches required for pre-2.2.4
+ pciutils. Incorporate the sparc patch from upstream instead of our own.
+ Compile the Python module.
02 May 2007; Donnie Berkholz <dberkholz@gentoo.org>; kudzu-1.2.52.ebuild:
Update homepage, since the old one vanished.
diff --git a/sys-apps/kudzu/files/1.2.71-sparc-updates.patch b/sys-apps/kudzu/files/1.2.71-sparc-updates.patch
new file mode 100644
index 000000000000..609a4c3da60b
--- /dev/null
+++ b/sys-apps/kudzu/files/1.2.71-sparc-updates.patch
@@ -0,0 +1,174 @@
+revision 1.19
+date: 2007/06/13 02:33:34; author: notting; state: Exp; lines: +24 -38
+sparc updates (<tcallawa@redhat.com>)
+
+Index: sbus.c
+===================================================================
+RCS file: /usr/local/CVS/kudzu/sbus.c,v
+retrieving revision 1.18
+retrieving revision 1.19
+diff -u -b -B -r1.18 -r1.19
+--- sbus.c 15 Sep 2005 15:33:07 -0000 1.18
++++ sbus.c 13 Jun 2007 02:33:34 -0000 1.19
+@@ -162,6 +162,7 @@
+ devClass = CLASS_NETWORK;
+ } else if (!strcmp(prop, "le")) {
+ type = "Sun Lance Ethernet";
++ module = "sunlance";
+ devClass = CLASS_NETWORK;
+ } else if (!strcmp(prop, "qe")) {
+ prop = prom_getproperty("channel#", &len);
+@@ -206,9 +207,11 @@
+ devClass = CLASS_SCSI;
+ } else if (!strcmp(prop, "esp")) {
+ type = "Sun Enhanced SCSI Processor (ESP)";
++ module = "esp";
+ devClass = CLASS_SCSI;
+ } else if (!strcmp(prop, "fas")) {
+ type = "Sun Swift (ESP)";
++ module = "esp";
+ devClass = CLASS_SCSI;
+ } else if (!strcmp(prop, "ptisp")) {
+ type = "Performance Technologies ISP";
+@@ -232,19 +235,19 @@
+ while ((*prop >= 'A' && *prop <= 'Z') || *prop == ',')
+ if (*prop++ == ',') break;
+ if (!strcmp(prop, "audio")) {
+- type = "AMD7930";
+- module = "amd7930";
++ type = "Sun|AMD7930";
++ module = "snd-sun-amd7930";
+ devClass = CLASS_AUDIO;
+ } else if (!strcmp(prop, "CS4231")) {
+ if (ebus)
+- type = "CS4231 EB2 DMA (PCI)";
++ type = "Sun|CS4231 EB2 DMA (PCI)";
+ else
+- type = "CS4231 APC DMA (SBUS)";
+- module = "cs4231";
++ type = "Sun|CS4231 APC DMA (SBUS)";
++ module = "snd-sun-cs4231";
+ devClass = CLASS_AUDIO;
+ } else if (!strcmp(prop, "DBRIe")) {
+- type = "SS10/SS20 DBRI";
+- module = "dbri";
++ type = "Sun|SS10/SS20 DBRI";
++ module = "snd-sun-dbri";
+ devClass = CLASS_AUDIO;
+ }
+ prop = prom_getproperty("device_type", &len);
+@@ -268,9 +271,11 @@
+ if (!strcmp(prop, "bwtwo")) {
+ type = "Sun|Monochrome (bwtwo)";
+ depth = 1;
++ module = "sunbw2";
+ } else if (!strcmp(prop, "cgthree")) {
+ type = "Sun|Color3 (cgthree)";
+ depth = 8;
++ module = "suncg3";
+ } else if (!strcmp(prop, "cgeight")) {
+ type = "Sun|CG8/RasterOps";
+ depth = 8;
+@@ -314,6 +319,7 @@
+ }
+ }
+ depth = 8;
++ module = "suncg6";
+ } else if (!strcmp(prop, "cgfourteen")) {
+ int size = 0;
+ prop = prom_getproperty("vfreq", &len);
+@@ -328,6 +334,7 @@
+ default: type = "Sun|SX";
+ }
+ depth = 24;
++ module = "suncg14";
+ } else if (!strcmp(prop, "leo")) {
+ prop = prom_getproperty("model", &len);
+ if (prop && len > 0 && !strstr(prop, "501-2503"))
+@@ -335,6 +342,7 @@
+ else
+ type = "Sun|ZX or Turbo ZX";
+ depth = 24;
++ module = "sunleo";
+ } else if (!strcmp(prop, "tcx")) {
+ if (prom_getbool("tcx-8-bit")) {
+ type = "Sun|TCX (8bit)";
+@@ -343,6 +351,7 @@
+ type = "Sun|TCX (S24)";
+ depth = 24;
+ }
++ module = "suntcx";
+ } else if (!strcmp(prop, "afb")) {
+ int btype = 0;
+ prop = prom_getproperty("vfreq", &len);
+@@ -356,6 +365,7 @@
+ else
+ type = "Sun|Elite3D";
+ depth = 24;
++ module = "sunffb";
+ } else if (!strcmp(prop, "ffb")) {
+ int btype = 0;
+ prop = prom_getproperty("vfreq", &len);
+@@ -381,6 +391,7 @@
+ default: type = "Sun|FFB"; break;
+ }
+ depth = 24;
++ module = "sunffb";
+ }
+ if (type) {
+ prop = prom_getproperty("width", &len);
+@@ -402,26 +413,17 @@
+ newDev->height = height;
+ newDev->freq = freq;
+ newDev->monitor = sense;
++ if (module) {
++ newDev->driver = strdup(module);
++ newDev->classprivate = (void *)strdup(module);
+ }
+- newDev->desc = strdup(type);
+- switch (depth) {
+- case 1:
+- newDev->driver = strdup("Server:SunMono");
+- newDev->type = CLASS_VIDEO;
+- break;
+- case 8:
+- newDev->driver = strdup("Server:Sun");
+- newDev->type = CLASS_VIDEO;
+- break;
+- case 24:
+- newDev->driver = strdup("Server:Sun24");
+ newDev->type = CLASS_VIDEO;
+- break;
+- default:
++ } else {
+ if (module)
+ newDev->driver = strdup(module);
+ newDev->type = devClass;
+ }
++ newDev->desc = strdup(type);
+ if (newDev->type == CLASS_NETWORK)
+ newDev->device = strdup("eth");
+ if (port) newDev->device = strdup(port);
+@@ -452,22 +454,6 @@
+
+ struct device *sbusProbe( enum deviceClass probeClass, int probeFlags,
+ struct device *devlist) {
+- if (probeClass & CLASS_MOUSE) {
+- int fd;
+- struct sbusDevice *mousedev;
+-
+- if ((fd = open("/dev/sunmouse", O_RDONLY)) != -1) {
+- /* FIXME: Should probably talk to the mouse to see
+- if the connector is not empty. */
+- close (fd);
+- mousedev = sbusNewDevice(NULL);
+- mousedev->type = CLASS_MOUSE;
+- mousedev->device = strdup("sunmouse");
+- mousedev->desc = strdup("Sun Mouse");
+- mousedev->next = devlist;
+- devlist = (struct device *)mousedev;
+- }
+- }
+ if (
+ (probeClass & CLASS_OTHER) ||
+ (probeClass & CLASS_NETWORK) ||
diff --git a/sys-apps/kudzu/files/digest-kudzu-1.2.71 b/sys-apps/kudzu/files/digest-kudzu-1.2.71
new file mode 100644
index 000000000000..afc4b5e686d4
--- /dev/null
+++ b/sys-apps/kudzu/files/digest-kudzu-1.2.71
@@ -0,0 +1,3 @@
+MD5 102c307286cd5a6bca3da3ccde4f6c2d kudzu-1.2.71-1.src.rpm 227710
+RMD160 e119daa4f98dcea5bbd19b48a262eee7cb2de8ee kudzu-1.2.71-1.src.rpm 227710
+SHA256 fe7cfe267616f8b5301a7dbe92254a309d3af189bdb3064edb87ce86fdd68f0f kudzu-1.2.71-1.src.rpm 227710
diff --git a/sys-apps/kudzu/kudzu-1.2.71.ebuild b/sys-apps/kudzu/kudzu-1.2.71.ebuild
new file mode 100644
index 000000000000..fd7ff319efca
--- /dev/null
+++ b/sys-apps/kudzu/kudzu-1.2.71.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kudzu/kudzu-1.2.71.ebuild,v 1.1 2007/06/20 06:19:16 dberkholz Exp $
+
+inherit eutils python rpm multilib toolchain-funcs
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+MY_P="${PN/lib}-${PV}"
+
+DESCRIPTION="Red Hat Hardware detection tools"
+SRC_URI="mirror://fedora/development/source/SRPMS/${MY_P}-${RPMREV}.src.rpm"
+HOMEPAGE="http://rhlinux.redhat.com/kudzu/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/popt
+ sys-apps/hwdata-redhat
+ !sys-libs/libkudzu"
+DEPEND="dev-libs/popt
+ >=sys-apps/pciutils-2.2.4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/1.2.52-remove-pci-device-class.patch \
+ "${FILESDIR}"/${PV}-sparc-updates.patch
+}
+
+src_compile() {
+ emake \
+ all \
+ CC=$(tc-getCC) \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB) \
+ RPM_OPT_FLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ install \
+ install-program \
+ DESTDIR="${D}" \
+ libdir="${D}/usr/$(get_libdir)" \
+ CC=$(tc-getCC) \
+ || die "install failed"
+
+ # don't install incompatible init scripts
+ rm -rf \
+ "${D}"/etc/rc.d \
+ || die "removing rc.d files failed"
+}
+
+pkg_postinst() {
+ python_version
+
+ python_mod_compile \
+ "${ROOT}"/usr/$(get_libdir)/python${PYVER}/site-packages/kudzu.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}