summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-06 12:26:54 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-06 12:26:54 +0000
commit04e7a15711f78e9a16e3c10c9403902909c33981 (patch)
treee7220dac95c584852f6c2375ca3e4393f11a5934 /sys-apps
parentStable for amd64, wrt bug #436774 (diff)
downloadgentoo-2-04e7a15711f78e9a16e3c10c9403902909c33981.tar.gz
gentoo-2-04e7a15711f78e9a16e3c10c9403902909c33981.tar.bz2
gentoo-2-04e7a15711f78e9a16e3c10c9403902909c33981.zip
virtual/awk support and move to /usr/bin (bug #426628)
(Portage version: 2.2.0_alpha135/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gawk/ChangeLog7
-rw-r--r--sys-apps/gawk/gawk-4.0.1-r1.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index 94eeeb612438..34ffcf50cea9 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/gawk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.156 2012/10/03 18:03:45 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.157 2012/10/06 12:26:54 ottxor Exp $
+
+*gawk-4.0.1-r1 (06 Oct 2012)
+
+ 06 Oct 2012; Christoph Junghans <ottxor@gentoo.org> +gawk-4.0.1-r1.ebuild:
+ virtual/awk support and move to /usr/bin (bug #426628)
03 Oct 2012; Brent Baude <ranger@gentoo.org> gawk-4.0.1.ebuild:
Marking gawk-4.0.1 ppc for bug 431954
diff --git a/sys-apps/gawk/gawk-4.0.1-r1.ebuild b/sys-apps/gawk/gawk-4.0.1-r1.ebuild
new file mode 100644
index 000000000000..c2a15db9262c
--- /dev/null
+++ b/sys-apps/gawk/gawk-4.0.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-4.0.1-r1.ebuild,v 1.1 2012/10/06 12:26:54 ottxor Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls readline"
+
+# older gawk's provided shared lib for baselayout-1
+RDEPEND="!<sys-apps/baselayout-2.0.1
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # use symlinks rather than hardlinks, and disable version links
+ sed -i \
+ -e '/^LN =/s:=.*:= $(LN_S):' \
+ -e '/install-exec-hook:/s|$|\nfoo:|' \
+ Makefile.in doc/Makefile.in
+ sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in #413327
+}
+
+src_configure() {
+ export ac_cv_libsigsegv=no
+ econf \
+ --libexec='$(libdir)/misc' \
+ $(use_enable nls) \
+ $(use_with readline)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ # Install headers
+ insinto /usr/include/awk
+ doins *.h || die
+ rm "${ED}"/usr/include/awk/config.h || die
+
+ dodoc AUTHORS ChangeLog FUTURES LIMITATIONS NEWS PROBLEMS POSIX.STD README README_d/*.*
+ for x in */ChangeLog ; do
+ newdoc ${x} ${x##*/}.${x%%/*}
+ done
+}
+
+pkg_postinst() {
+ # symlink creation here as the links do not belong to gawk, but to any awk
+ if has_version app-admin/eselect && has_version app-admin/eselect-awk ; then
+ eselect awk update ifunset
+ else
+ local l
+ for l in "${EROOT}"usr/share/man/man1/gawk.1* "${EROOT}"usr/bin/gawk; do
+ [[ -e ${l} && ! -e ${l/gawk/awk} ]] && ln -s "${l##*/}" "${l/gawk/awk}"
+ done
+ [[ ! -e ${EROOT}bin/awk ]] && ln -s "../usr/bin/gawk" "${EROOT}bin/awk"
+ fi
+}
+
+pkg_postrm() {
+ if has_version app-admin/eselect && has_version app-admin/eselect-awk ; then
+ eselect awk update ifunset
+ fi
+}