summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-22 22:29:53 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-22 22:29:53 +0000
commit452eab94b441c66ec5f316f0930923c6047dad14 (patch)
tree633d46c246fb08f25c5459b1612c6e38a49f39d2 /sys-apps/findutils
parentFix building with glibc-2.16+. (diff)
downloadgentoo-2-452eab94b441c66ec5f316f0930923c6047dad14.tar.gz
gentoo-2-452eab94b441c66ec5f316f0930923c6047dad14.tar.bz2
gentoo-2-452eab94b441c66ec5f316f0930923c6047dad14.zip
Fix building with glibc-2.16+.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/ChangeLog6
-rw-r--r--sys-apps/findutils/files/findutils-4.5.10-no-gets.patch22
-rw-r--r--sys-apps/findutils/findutils-4.5.10-r1.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 51290956b436..3dc1a49f61c2 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.208 2012/04/26 21:35:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.209 2012/05/22 22:29:53 vapier Exp $
+
+ 22 May 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/findutils-4.5.10-no-gets.patch, findutils-4.5.10-r1.ebuild:
+ Fix building with glibc-2.16+.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> findutils-4.5.10-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/sys-apps/findutils/files/findutils-4.5.10-no-gets.patch b/sys-apps/findutils/files/findutils-4.5.10-no-gets.patch
new file mode 100644
index 000000000000..85230b37b814
--- /dev/null
+++ b/sys-apps/findutils/files/findutils-4.5.10-no-gets.patch
@@ -0,0 +1,22 @@
+hack until gzip pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/gnulib/lib/stdio.in.h
++++ b/gnulib/lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
diff --git a/sys-apps/findutils/findutils-4.5.10-r1.ebuild b/sys-apps/findutils/findutils-4.5.10-r1.ebuild
index b44b593a261b..c0c4a99fdeea 100644
--- a/sys-apps/findutils/findutils-4.5.10-r1.ebuild
+++ b/sys-apps/findutils/findutils-4.5.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.10-r1.ebuild,v 1.5 2012/04/26 21:35:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.10-r1.ebuild,v 1.6 2012/05/22 22:29:53 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-gets.patch
# Don't build or install locate because it conflicts with slocate,
# which is a secure version of locate. See bug 18729