summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-24 11:16:23 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-24 11:16:23 +0000
commit19d830e8e53ed476429fd6e94750cb360b624962 (patch)
treec8d3a31ac549e6db0428711dd0f37f92f27fb76b /sci-visualization
parentVersion bump (diff)
downloadgentoo-2-19d830e8e53ed476429fd6e94750cb360b624962.tar.gz
gentoo-2-19d830e8e53ed476429fd6e94750cb360b624962.tar.bz2
gentoo-2-19d830e8e53ed476429fd6e94750cb360b624962.zip
update REQUIRED_USE, fix automagic enabling of qt4, fix building with latest dev-db/mysql wrt #475492
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/paraview/ChangeLog6
-rw-r--r--sci-visualization/paraview/paraview-4.0.1.ebuild9
2 files changed, 11 insertions, 4 deletions
diff --git a/sci-visualization/paraview/ChangeLog b/sci-visualization/paraview/ChangeLog
index dd81cf8bb87e..741a70ec9323 100644
--- a/sci-visualization/paraview/ChangeLog
+++ b/sci-visualization/paraview/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/paraview
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.70 2013/07/01 23:33:28 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.71 2013/07/24 11:16:23 hasufell Exp $
+
+ 24 Jul 2013; Julian Ospald <hasufell@gentoo.org> paraview-4.0.1.ebuild:
+ update REQUIRED_USE, fix automagic enabling of qt4, fix building with latest
+ dev-db/mysql wrt #475492
*paraview-4.0.1 (01 Jul 2013)
diff --git a/sci-visualization/paraview/paraview-4.0.1.ebuild b/sci-visualization/paraview/paraview-4.0.1.ebuild
index a5df7de36a74..ffb829a3d245 100644
--- a/sci-visualization/paraview/paraview-4.0.1.ebuild
+++ b/sci-visualization/paraview/paraview-4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-4.0.1.ebuild,v 1.1 2013/07/01 23:33:28 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-4.0.1.ebuild,v 1.2 2013/07/24 11:16:23 hasufell Exp $
EAPI=5
@@ -21,7 +21,8 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="boost cg coprocessing development doc examples ffmpeg mpi mysql nvcontrol plugins python qt4 sqlite tcl test tk"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ mysql? ( sqlite )" # "vtksqlite, needed by vtkIOSQL" and "vtkIOSQL, needed by vtkIOMySQL"
RDEPEND="
dev-libs/expat
@@ -148,6 +149,8 @@ src_configure() {
-DVTK_USE_FFMPEG_ENCODER=OFF
-DPROTOC_LOCATION=$(type -P protoc)
-DVTK_Group_StandAlone=ON
+ -DMYSQL_INCLUDE_DIRECTORIES="$(usex mysql "$(mysql_config --variable=pkgincludedir)" "")"
+ -DMYSQL_LIBRARY="$(usex mysql "$(mysql_config --variable=pkglibdir)/libmysqlclient.so" "")"
# force this module due to incorrect build system deps
# wrt bug 460528
-DModule_vtkUtilitiesProcessXML=ON
@@ -185,7 +188,7 @@ src_configure() {
$(cmake-utils_use python Module_Twisted)
$(cmake-utils_use python Module_ZopeInterface)
$(cmake-utils_use python Module_vtkmpi4py)
- $(cmake-utils_use python Module_pqPython)
+ $(usex qt4 "$(cmake-utils_use python Module_pqPython)" "-DModule_pqPython=OFF")
$(cmake-utils_use doc BUILD_DOCUMENTATION)
$(cmake-utils_use doc PARAVIEW_BUILD_WEB_DOCUMENTATION)
$(cmake-utils_use examples BUILD_EXAMPLES)