summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-04-13 16:30:07 +0000
committerThomas Kahle <tomka@gentoo.org>2012-04-13 16:30:07 +0000
commita7347a1d77c72d4e47d632c5a0d14ad507ca33d9 (patch)
tree2c28b02aaa8eb19229cc92755a6e03a9ff00f0a7 /sci-mathematics/frobby/frobby-0.9.0.ebuild
parentFix SRC_URI now that Debian has stopped supporting this package, by Marcin Mi... (diff)
downloadgentoo-2-a7347a1d77c72d4e47d632c5a0d14ad507ca33d9.tar.gz
gentoo-2-a7347a1d77c72d4e47d632c5a0d14ad507ca33d9.tar.bz2
gentoo-2-a7347a1d77c72d4e47d632c5a0d14ad507ca33d9.zip
Bump to 0.9.0
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/frobby/frobby-0.9.0.ebuild')
-rw-r--r--sci-mathematics/frobby/frobby-0.9.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/frobby/frobby-0.9.0.ebuild b/sci-mathematics/frobby/frobby-0.9.0.ebuild
new file mode 100644
index 000000000000..9ab8a918ee34
--- /dev/null
+++ b/sci-mathematics/frobby/frobby-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.9.0.ebuild,v 1.1 2012/04/13 16:30:07 tomka Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Frobby is a software system and project for computations with monomial ideals"
+HOMEPAGE="http://www.broune.com/frobby/"
+SRC_URI="http://www.broune.com/frobby/frobby_v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/gmp[cxx]"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/frobby_v${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-cflags-no-strip.patch"
+}
+
+src_compile() {
+ emake
+ emake library
+ if use doc; then
+ # latex loops don't parallelize well
+ emake -j1 doc
+ fi
+}
+
+src_install() {
+ dobin bin/frobby
+ dolib.a bin/libfrobby.a
+ insinto /usr/include
+ doins src/frobby.h
+ dodir /usr/include/"${PN}"
+ insinto /usr/include/"${PN}"
+ doins src/stdinc.h
+ if use doc; then
+ dodoc bin/manual.pdf
+ fi
+}