summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Bienstman <pbienst@gentoo.org>2005-08-22 16:31:29 +0000
committerPeter Bienstman <pbienst@gentoo.org>2005-08-22 16:31:29 +0000
commita6f8c5fe183068d4048b4b3291397a142c0197be (patch)
tree26f900b117bfe3f3ea536443f3885ddfd0475be6 /sci-libs
parentapply whitespace checks from repoman to eclasses (diff)
downloadgentoo-2-a6f8c5fe183068d4048b4b3291397a142c0197be.tar.gz
gentoo-2-a6f8c5fe183068d4048b4b3291397a142c0197be.tar.bz2
gentoo-2-a6f8c5fe183068d4048b4b3291397a142c0197be.zip
First import.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/ChangeLog10
-rw-r--r--sci-libs/scipy/Manifest4
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.3.21
-rw-r--r--sci-libs/scipy/files/system_info.diff67
-rw-r--r--sci-libs/scipy/metadata.xml5
-rw-r--r--sci-libs/scipy/scipy-0.3.2.ebuild65
6 files changed, 152 insertions, 0 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
new file mode 100644
index 000000000000..7b2cf1645b70
--- /dev/null
+++ b/sci-libs/scipy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/scipy
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.1 2005/08/22 16:31:29 pbienst Exp $
+
+*scipy-0.3.2 (22 Aug 2005)
+
+ 22 Aug 2005; Peter Bienstman <pbienst@gentoo.org> +files/system_info.diff,
+ +metadata.xml, +scipy-0.3.2.ebuild:
+ Initial import. Closes 24593. Thanks to D. Grant, D. Dale and others.
+
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
new file mode 100644
index 000000000000..fb3c4e2141df
--- /dev/null
+++ b/sci-libs/scipy/Manifest
@@ -0,0 +1,4 @@
+MD5 69ab409108c754e9560b9caf5cf802ef scipy-0.3.2.ebuild 1454
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 a5ac5edc39d8266b13659fd429e8e939 files/system_info.diff 2155
+MD5 1b281bbd7d7655bf8fb89c5cb8e05db0 files/digest-scipy-0.3.2 73
diff --git a/sci-libs/scipy/files/digest-scipy-0.3.2 b/sci-libs/scipy/files/digest-scipy-0.3.2
new file mode 100644
index 000000000000..1daba1be229f
--- /dev/null
+++ b/sci-libs/scipy/files/digest-scipy-0.3.2
@@ -0,0 +1 @@
+MD5 5ae2280ab2c4c653cb0ff8479e81284a SciPy_complete-0.3.2.tar.gz 3368595
diff --git a/sci-libs/scipy/files/system_info.diff b/sci-libs/scipy/files/system_info.diff
new file mode 100644
index 000000000000..fb220305b082
--- /dev/null
+++ b/sci-libs/scipy/files/system_info.diff
@@ -0,0 +1,67 @@
+*** SciPy_complete-0.3.2/scipy_core/scipy_distutils/system_info.py Tue Jun 1 10:27:47 2004
+--- SciPy_complete-0.3.2_new/scipy_core/scipy_distutils/system_info.py Mon Aug 22 15:06:44 2005
+***************
+*** 1,3 ****
+--- 1,7 ----
++ # Modified to avoid linking directly to the atlas libraries if present.
++ # This would break the dynamic switching between different lapack
++ # implementations at run time (pbienst@gentoo.org)
++
+ #!/usr/bin/env python
+ """
+ This file defines a set of system_info classes for getting
+***************
+*** 553,558 ****
+--- 557,563 ----
+ atlas = None
+ lapack = None
+ atlas_1 = None
++ return
+ for d in lib_dirs:
+ atlas = self.check_libs(d,atlas_libs,[])
+ lapack_atlas = self.check_libs(d,['lapack_atlas'],[])
+***************
+*** 635,640 ****
+--- 640,646 ----
+ self._lib_names + ['atlas'])
+ atlas = None
+ atlas_1 = None
++ return
+ for d in lib_dirs:
+ atlas = self.check_libs(d,atlas_libs,[])
+ if atlas is not None:
+***************
+*** 659,674 ****
+ return
+
+ class atlas_threads_info(atlas_info):
+! _lib_names = ['ptf77blas','ptcblas']
+
+ class atlas_blas_threads_info(atlas_blas_info):
+! _lib_names = ['ptf77blas','ptcblas']
+
+ class lapack_atlas_info(atlas_info):
+! _lib_names = ['lapack_atlas'] + atlas_info._lib_names
+
+ class lapack_atlas_threads_info(atlas_threads_info):
+! _lib_names = ['lapack_atlas'] + atlas_threads_info._lib_names
+
+ class lapack_info(system_info):
+ section = 'lapack'
+--- 665,680 ----
+ return
+
+ class atlas_threads_info(atlas_info):
+! _lib_names = [] #['ptf77blas','ptcblas']
+
+ class atlas_blas_threads_info(atlas_blas_info):
+! _lib_names = [] #['ptf77blas','ptcblas']
+
+ class lapack_atlas_info(atlas_info):
+! _lib_names = [] #['lapack_atlas'] + atlas_info._lib_names
+
+ class lapack_atlas_threads_info(atlas_threads_info):
+! _lib_names = [] #['lapack_atlas'] + atlas_threads_info._lib_names
+
+ class lapack_info(system_info):
+ section = 'lapack'
diff --git a/sci-libs/scipy/metadata.xml b/sci-libs/scipy/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/sci-libs/scipy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>
diff --git a/sci-libs/scipy/scipy-0.3.2.ebuild b/sci-libs/scipy/scipy-0.3.2.ebuild
new file mode 100644
index 000000000000..f2c5d1312fdc
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.3.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2005-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.3.2.ebuild,v 1.1 2005/08/22 16:31:29 pbienst Exp $
+
+inherit distutils
+
+MY_P="SciPy_complete-${PV}"
+SRC_URI="http://www.scipy.org/download/scipy/src/${MY_P}.tar.gz"
+DESCRIPTION="Open source scientific tools for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+IUSE="fftw wxwindows"
+KEYWORDS="~x86"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=dev-lang/python-2.3.3
+ >=dev-python/numeric-21.0
+ >=sys-devel/gcc-3
+ virtual/lapack
+ virtual/blas
+ >=dev-python/f2py-2.39.235.1644
+ fftw? ( =sci-libs/fftw-2.1* )
+ wxwindows? ( >=dev-python/wxpython-2.4 )"
+
+RDEPEND=">=dev-lang/python-2.3.3
+ >=dev-python/numeric-21.0
+ virtual/lapack
+ virtual/blas
+ fftw? ( =sci-libs/fftw-2.1* )
+ wxwindows? ( >=dev-python/wxpython-2.4 )"
+
+src_unpack() {
+ if [ -z `which g77` ]; then
+ eerror "No Fortran compiler found on the system!"
+ eerror "Please add fortran to your USE flags and reemerge gcc!"
+ die
+ fi
+ unpack ${A} || die
+ cd ${S}
+ epatch ${FILESDIR}/system_info.diff
+}
+
+src_test() {
+ einfo "Testing installation ..."
+ python -c "import scipy; scipy.test(level=1)" || \
+ die "Unit tests failed!"
+}
+
+src_install() {
+ distutils_src_install
+ dodoc `ls *.txt`
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo ""
+ einfo "Emerge media-gfx/gnuplot to use the 'gplt' plotting facility."
+ if use wxwindows; then
+ einfo "Set USE=wxwindows and reemerge to use the newer 'plt' plotter."
+ fi
+ einfo ""
+}