summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-02 11:26:20 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-02 11:26:20 +0000
commit70c17a84c3fdb83bc6792145782931ddf9ff4c70 (patch)
tree87be5880c44ddfdfd0bb5e14353ef34e6ba749d0 /sci-libs
parentAdd ~mips per #444688 (diff)
downloadgentoo-2-70c17a84c3fdb83bc6792145782931ddf9ff4c70.tar.gz
gentoo-2-70c17a84c3fdb83bc6792145782931ddf9ff4c70.tar.bz2
gentoo-2-70c17a84c3fdb83bc6792145782931ddf9ff4c70.zip
sci-libs/scipy: Drop vulnerable versions, #488048
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/ChangeLog6
-rw-r--r--sci-libs/scipy/scipy-0.12.0.ebuild135
-rw-r--r--sci-libs/scipy/scipy-0.9.0-r1.ebuild139
3 files changed, 5 insertions, 275 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index ec76cdf3124b..ef0aded56697 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.103 2013/11/02 09:58:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.104 2013/11/02 11:26:20 jlec Exp $
+
+ 02 Nov 2013; Justin Lecher <jlec@gentoo.org> -scipy-0.9.0-r1.ebuild,
+ -scipy-0.12.0.ebuild:
+ Drop vulnerable versions, #488048
02 Nov 2013; Agostino Sarubbo <ago@gentoo.org> scipy-0.12.1.ebuild:
Stable for x86, wrt bug #488048
diff --git a/sci-libs/scipy/scipy-0.12.0.ebuild b/sci-libs/scipy/scipy-0.12.0.ebuild
deleted file mode 100644
index b3b8868fefcf..000000000000
--- a/sci-libs/scipy/scipy-0.12.0.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.12.0.ebuild,v 1.6 2013/09/10 02:43:58 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit eutils fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${PN}/${PN}-html.zip -> ${P}-html.zip
- http://docs.scipy.org/doc/${PN}/${PN}-ref.pdf -> ${P}-ref.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc sparse test"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- dev-python/numpy[lapack,${PYTHON_USEDEP}]
- sci-libs/arpack
- virtual/cblas
- virtual/lapack
- sparse? ( sci-libs/umfpack )"
-DEPEND="${CDEPEND}
- dev-lang/swig
- dev-python/cython[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND="${CDEPEND}
- virtual/python-imaging[${PYTHON_USEDEP}]"
-
-DOCS=( HACKING.rst.txt README.txt THANKS.txt LATEST.txt TOCHANGE.txt )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${P}-html.zip -d html || die
- fi
-}
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//'
-}
-
-python_prepare_all() {
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use sparse && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-
- local PATCHES=(
- "${FILESDIR}"/${P}-gerqf.patch
- "${FILESDIR}"/${P}-blitz.patch
- "${FILESDIR}"/${P}-restore-sys-argv.patch
- "${FILESDIR}"/${P}-cephes-missing-include.patch
- )
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- distutils_install_for_testing ${SCIPY_FCONFIG}
- cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
- # nasty hack to remove weave tests because it is not python3 compat
- [[ ${TEST_DIR} =~ python3 ]] && rm -r "${TEST_DIR}"/lib/scipy/weave
-#r = scipy.test('full', verbose=10)
- "${EPYTHON}" -c "
-import scipy, sys
-r = scipy.test('fast',verbose=2)
-sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r "${WORKDIR}"/html/.
- dodoc "${DISTDIR}"/${P}*pdf
- fi
- distutils-r1_python_install_all
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer. Example:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy/scipy-0.9.0-r1.ebuild b/sci-libs/scipy/scipy-0.9.0-r1.ebuild
deleted file mode 100644
index 2e560519bd98..000000000000
--- a/sci-libs/scipy/scipy-0.9.0-r1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.9.0-r1.ebuild,v 1.14 2013/06/17 23:29:09 bicatali Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="*::3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.3 *-jython"
-
-inherit eutils fortran-2 distutils flag-o-matic toolchain-funcs versionator
-
-SP="${PN}-$(get_version_component_range 1-2)"
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${SP}-html.zip
- http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${SP}-ref.pdf
- )"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc sparse"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- >=dev-python/numpy-1.5[lapack]
- >=media-libs/qhull-2012.1-r1
- sci-libs/arpack
- sci-libs/superlu
- virtual/cblas
- virtual/lapack
- sparse? ( sci-libs/umfpack )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- sparse? ( dev-lang/swig )"
-RDEPEND="${CDEPEND}
- dev-python/imaging"
-
-# buggy test suite - still true for 0.9.0
-#RESTRICT="test"
-
-DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
-
-pkg_setup() {
- fortran-2_pkg_setup
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use sparse && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-}
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${SP}-html.zip -d html || die
- fi
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-superlu.patch \
- "${FILESDIR}"/${P}-qhull.patch
- rm -rf ./scipy/sparse/linalg/dsolve/SuperLU ./scipy/spatial/qhull
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat > site.cfg <<-EOF
- [atlas]
- include_dirs = $($(tc-getPKG_CONFIG) --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $($(tc-getPKG_CONFIG) --libs-only-L \
- cblas blas lapack| sed -e \
- 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- atlas_libs = $($(tc-getPKG_CONFIG) --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- lapack_libs = $($(tc-getPKG_CONFIG) --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [blas_opt]
- include_dirs = $($(tc-getPKG_CONFIG) --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $($(tc-getPKG_CONFIG) --libs-only-L \
- cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' \
- -e 's/ //g'):${libdir}
- libraries = $($(tc-getPKG_CONFIG) --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [lapack_opt]
- library_dirs = $($(tc-getPKG_CONFIG) --libs-only-L \
- lapack | sed -e 's/^-L//' -e 's/ -L/:/g' \
- -e 's/ //g'):${libdir}
- libraries = $($(tc-getPKG_CONFIG) --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- EOF
-}
-
-src_compile() {
- distutils_src_compile ${SCIPY_FCONFIG}
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} || die "install test failed"
- pushd "${S}/test-${PYTHON_ABI}/"lib*/python > /dev/null
- PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full')" 2>&1 | tee test.log
- grep -q ^ERROR test.log && die "test failed"
- popd > /dev/null
- rm -fr test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install ${SCIPY_FCONFIG}
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r "${WORKDIR}"/html || die
- doins "${DISTDIR}"/${SP}*pdf || die
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}