summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-05-22 05:45:17 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-05-22 05:45:17 +0000
commit18fc518b271d0f5367250ec712e035a6a752a489 (patch)
tree9edcd1a45b6a3bea0b9c5aee88aff68ff94cc9db /sci-libs/jmol-acme/jmol-acme-1.0.ebuild
parentAdded ACME license for jmol. http://www.acme.com/license.html (diff)
downloadgentoo-2-18fc518b271d0f5367250ec712e035a6a752a489.tar.gz
gentoo-2-18fc518b271d0f5367250ec712e035a6a752a489.tar.bz2
gentoo-2-18fc518b271d0f5367250ec712e035a6a752a489.zip
Initial import...feel free to test and add your arch.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sci-libs/jmol-acme/jmol-acme-1.0.ebuild')
-rw-r--r--sci-libs/jmol-acme/jmol-acme-1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/jmol-acme/jmol-acme-1.0.ebuild b/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
new file mode 100644
index 000000000000..a3fd6dbd5f21
--- /dev/null
+++ b/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/jmol-acme/jmol-acme-1.0.ebuild,v 1.1 2007/05/22 05:45:17 je_fro Exp $
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="Acme"
+
+# It proved difficult to recompile the whole Acme package, so we'll only take what we need.
+
+DESCRIPTION="Portions of the Acme collection required for jMol. Courtesy of ACME - Purveyors of fine freeware since 1972."
+HOMEPAGE="http://www.acme.com/"
+SRC_URI="http://www.acme.com/resources/classes/${MY_P}.tar.gz"
+
+LICENSE="ACME"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ mkdir -p "${S}/classes"
+ unpack ${A}
+}
+
+src_compile() {
+ cp "${FILESDIR}/src.list" "${T}"
+ ejavac -sourcepath "" -d "${S}/classes" "@${T}/src.list"
+ cd "${S}/classes"
+ jar -cf "${PN}.jar" * || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar "${S}/classes/${PN}.jar"
+}