summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-07-07 08:44:26 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-07-07 08:44:26 +0000
commit60d97e22eb11ad25751d50a6043ba4fabb2ec8d7 (patch)
tree8fb944c62d35899995702e06b4b45781d36c3d96 /sci-electronics/kicad
parentVersion bump; remove sqlite USE flag as it is no longer used; remove mirror r... (diff)
downloadgentoo-2-60d97e22eb11ad25751d50a6043ba4fabb2ec8d7.tar.gz
gentoo-2-60d97e22eb11ad25751d50a6043ba4fabb2ec8d7.tar.bz2
gentoo-2-60d97e22eb11ad25751d50a6043ba4fabb2ec8d7.zip
Locked required wxGTK to version 2.6 to prepare for new wxwidget eclass.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'sci-electronics/kicad')
-rw-r--r--sci-electronics/kicad/ChangeLog6
-rw-r--r--sci-electronics/kicad/kicad-20070115.ebuild10
-rw-r--r--sci-electronics/kicad/kicad-20070525.ebuild10
3 files changed, 15 insertions, 11 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index 05f8377b1562..052a6cfdb8d0 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/kicad
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.24 2007/06/23 20:12:59 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.25 2007/07/07 08:44:26 calchan Exp $
+
+ 07 Jul 2007; Denis Dupeyron <calchan@gentoo.org> kicad-20070115.ebuild,
+ kicad-20070525.ebuild:
+ Locked required wxGTK to version 2.6 to prepare for new wxwidget eclass.
23 Jun 2007; Markus Rothe <corsair@gentoo.org> kicad-20070525.ebuild:
Added ~ppc
diff --git a/sci-electronics/kicad/kicad-20070115.ebuild b/sci-electronics/kicad/kicad-20070115.ebuild
index 0603c6d66632..068b8c3d42e4 100644
--- a/sci-electronics/kicad/kicad-20070115.ebuild
+++ b/sci-electronics/kicad/kicad-20070115.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070115.ebuild,v 1.8 2007/06/06 19:59:14 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070115.ebuild,v 1.9 2007/07/07 08:44:26 calchan Exp $
inherit wxwidgets
@@ -15,11 +15,11 @@ SLOT="0"
KEYWORDS="amd64 ppc64 x86"
IUSE="unicode doc examples minimal"
-DEPEND=">=x11-libs/wxGTK-2.6"
+DEPEND="=x11-libs/wxGTK-2.6*"
pkg_setup() {
- # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
- WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
+ # Tell wxwidgets.eclass which version we need
+ WX_GTK_VER="2.6"
# Check for proper wxGTK USE flags.
if use unicode; then
@@ -27,7 +27,7 @@ pkg_setup() {
else
need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
fi
- built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
+ built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
}
src_unpack() {
diff --git a/sci-electronics/kicad/kicad-20070525.ebuild b/sci-electronics/kicad/kicad-20070525.ebuild
index 1a6cdf552853..a7cb7ef1af22 100644
--- a/sci-electronics/kicad/kicad-20070525.ebuild
+++ b/sci-electronics/kicad/kicad-20070525.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070525.ebuild,v 1.3 2007/06/23 20:12:59 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070525.ebuild,v 1.4 2007/07/07 08:44:26 calchan Exp $
inherit wxwidgets
@@ -15,11 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="doc examples minimal unicode"
-DEPEND=">=x11-libs/wxGTK-2.6"
+DEPEND="=x11-libs/wxGTK-2.6*"
pkg_setup() {
- # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
- WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
+ # Tell wxwidgets.eclass which version we need
+ WX_GTK_VER="2.6"
# Check for proper wxGTK USE flags.
if use unicode; then
@@ -27,7 +27,7 @@ pkg_setup() {
else
need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
fi
- built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
+ built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
}
src_unpack() {