summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-02-26 11:30:08 +0000
committerJustin Lecher <jlec@gentoo.org>2011-02-26 11:30:08 +0000
commitf35173d32a669a47ea0d7a214cf378a8bbf871b9 (patch)
tree768f464cc0238fc705848230653d0dfcb6cf32e0 /sci-chemistry
parentamd64 stable wrt #355077 (diff)
downloadgentoo-2-f35173d32a669a47ea0d7a214cf378a8bbf871b9.tar.gz
gentoo-2-f35173d32a669a47ea0d7a214cf378a8bbf871b9.tar.bz2
gentoo-2-f35173d32a669a47ea0d7a214cf378a8bbf871b9.zip
Version Bump
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/refmac/ChangeLog7
-rw-r--r--sci-chemistry/refmac/refmac-5.6.0110.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/sci-chemistry/refmac/ChangeLog b/sci-chemistry/refmac/ChangeLog
index b3b528407a98..892f4241ba48 100644
--- a/sci-chemistry/refmac/ChangeLog
+++ b/sci-chemistry/refmac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/refmac
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.42 2011/01/31 21:14:39 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.43 2011/02/26 11:30:08 jlec Exp $
+
+*refmac-5.6.0110 (26 Feb 2011)
+
+ 26 Feb 2011; Justin Lecher <jlec@gentoo.org> +refmac-5.6.0110.ebuild:
+ Version Bump
*refmac-5.6.0102-r1 (31 Jan 2011)
*refmac-5.5.0110-r3 (31 Jan 2011)
diff --git a/sci-chemistry/refmac/refmac-5.6.0110.ebuild b/sci-chemistry/refmac/refmac-5.6.0110.ebuild
new file mode 100644
index 000000000000..0222f07faf31
--- /dev/null
+++ b/sci-chemistry/refmac/refmac-5.6.0110.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.6.0110.ebuild,v 1.1 2011/02/26 11:30:08 jlec Exp $
+
+EAPI="2"
+
+inherit base toolchain-funcs versionator
+
+MY_PV="$(get_version_component_range 1-2)_source_v${PV}"
+
+DESCRIPTION="Macromolecular crystallographic refinement program"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~garib/refmac"
+SRC_URI="
+ ${HOMEPAGE}/data/refmac_experimental/${PN}${MY_PV}.tar.gz
+ test? ( http://dev.gentooexperimental.org/~jlec/distfiles/test-framework.tar.gz )"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=sci-libs/ccp4-libs-6.1.3-r7
+ sci-libs/mmdb
+ >sci-libs/monomer-db-1
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+PATCHES=(
+# "${FILESDIR}"/${PV}-allow-dynamic-linking.patch
+ "${FILESDIR}"/5.6.0102-allow-dynamic-linking.patch
+ )
+
+src_prepare() {
+ base_src_prepare
+ use test && epatch "${FILESDIR}"/5.5-test.log.patch
+}
+
+src_compile() {
+ emake \
+ FC=$(tc-getFC) \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ COPTIM="${CFLAGS}" \
+ FOPTIM="${FFLAGS:- -O2}" \
+ VERSION="" \
+ XFFLAGS="-fno-second-underscore -fwhole-file" \
+ LLIBCCP="-lccp4f -lccp4c -lccif -lmmdb -lstdc++" \
+ LLIBLAPACK="$(pkg-config --libs lapack blas)" \
+ || die
+}
+
+src_test() {
+ einfo "Starting tests ..."
+ source "${EPREFIX}/etc/profile.d/40ccp4.setup.sh"
+ export PATH="${WORKDIR}/test-framework/scripts:${S}:${PATH}"
+ export CCP4_TEST="${WORKDIR}"/test-framework
+ export CCP4_SCR="${T}"
+ ln -sf refmac "${S}"/refmac5
+ sed '/^ANISOU/d' -i ${CCP4_TEST}/data/pdb/1vr7.pdb
+ ccp4-run-thorough-tests -v test_refmac5 || die
+}
+
+src_install() {
+ for i in refmac libcheck FreeTwin header2matr; do
+ exeinto /usr/libexec/ccp4/bin/
+ doexe ${i} || die
+ dosym ../libexec/ccp4/bin/${i} /usr/bin/${i}
+ done
+ dosym refmac /usr/bin/refmac5 || die
+ dosym refmac /usr/libexec/ccp4/bin/refmac5 || die
+}