summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-12 07:48:27 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-12 07:48:27 +0000
commitd9dccd7848a2ed00999f2798d1922431384ef405 (patch)
tree300f2e6551d4335d2b649a1dba78c92497df738c /sci-chemistry
parentFixed wrong quotation, thank Markus Meier for report, #307425. (diff)
downloadgentoo-2-d9dccd7848a2ed00999f2798d1922431384ef405.tar.gz
gentoo-2-d9dccd7848a2ed00999f2798d1922431384ef405.tar.bz2
gentoo-2-d9dccd7848a2ed00999f2798d1922431384ef405.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/sfcheck/ChangeLog8
-rw-r--r--sci-chemistry/sfcheck/sfcheck-7.03.18.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/sci-chemistry/sfcheck/ChangeLog b/sci-chemistry/sfcheck/ChangeLog
index d9391442a856..63a09663ada3 100644
--- a/sci-chemistry/sfcheck/ChangeLog
+++ b/sci-chemistry/sfcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/sfcheck
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sfcheck/ChangeLog,v 1.1 2010/02/06 22:13:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sfcheck/ChangeLog,v 1.2 2010/03/12 07:48:27 jlec Exp $
+
+*sfcheck-7.03.18 (12 Mar 2010)
+
+ 12 Mar 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +sfcheck-7.03.18.ebuild:
+ Version Bump
*sfcheck-7.03.17 (06 Feb 2010)
diff --git a/sci-chemistry/sfcheck/sfcheck-7.03.18.ebuild b/sci-chemistry/sfcheck/sfcheck-7.03.18.ebuild
new file mode 100644
index 000000000000..6f27a36a5809
--- /dev/null
+++ b/sci-chemistry/sfcheck/sfcheck-7.03.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sfcheck/sfcheck-7.03.18.ebuild,v 1.1 2010/03/12 07:48:27 jlec Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Program for assessing the agreement between the atomic model and X-ray data or EM map"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/sfcheck.html"
+#SRC_URI="http://www.ysbl.york.ac.uk/~alexei/downloads/sfcheck.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="ccp4"
+IUSE=""
+
+RDEPEND="sci-libs/ccp4-libs"
+DEPEND="${RDEPEND}
+ !<sci-chmistry/ccp4-apps-6.1.3"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/7.03.17-ldflags.patch
+
+ emake \
+ -C src \
+ clean || die
+}
+
+src_compile() {
+ MR_FORT="$(tc-getFC) ${FFLAGS}" \
+ MR_LIBRARY="-lccp4f" \
+ emake \
+ -C src \
+ all || die
+}
+
+src_install() {
+ dobin bin/${PN} || die
+ dodoc readme ${PN}.com.gz doc/${PN}* || die
+}