summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-03 08:28:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-03 08:28:36 +0000
commit9a39cb9bd31efa15a1cdb3fcf59bcf082f8ae757 (patch)
treeaafd56e7b58bc4edd0bdd81541ac9ee01ff43f02 /sci-chemistry/prekin
parentInstall VERSION.yml as some code depends on it. (diff)
downloadgentoo-2-9a39cb9bd31efa15a1cdb3fcf59bcf082f8ae757.tar.gz
gentoo-2-9a39cb9bd31efa15a1cdb3fcf59bcf082f8ae757.tar.bz2
gentoo-2-9a39cb9bd31efa15a1cdb3fcf59bcf082f8ae757.zip
Fixes for overflows, 337779
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/prekin')
-rw-r--r--sci-chemistry/prekin/ChangeLog9
-rw-r--r--sci-chemistry/prekin/files/6.51.081122-overflow.patch28
-rw-r--r--sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild54
-rw-r--r--sci-chemistry/prekin/prekin-6.51.081122.ebuild6
4 files changed, 94 insertions, 3 deletions
diff --git a/sci-chemistry/prekin/ChangeLog b/sci-chemistry/prekin/ChangeLog
index 47e68d5f385a..2595587cf474 100644
--- a/sci-chemistry/prekin/ChangeLog
+++ b/sci-chemistry/prekin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/prekin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/ChangeLog,v 1.1 2010/07/18 08:57:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/ChangeLog,v 1.2 2010/10/03 08:28:36 jlec Exp $
+
+*prekin-6.51.081122-r1 (03 Oct 2010)
+
+ 03 Oct 2010; Justin Lecher <jlec@gentoo.org>
+ +files/6.51.081122-overflow.patch, prekin-6.51.081122.ebuild,
+ +prekin-6.51.081122-r1.ebuild:
+ Fixes for overflows, 337779
*prekin-6.51.081122 (18 Jul 2010)
diff --git a/sci-chemistry/prekin/files/6.51.081122-overflow.patch b/sci-chemistry/prekin/files/6.51.081122-overflow.patch
new file mode 100644
index 000000000000..27bc01d61a52
--- /dev/null
+++ b/sci-chemistry/prekin/files/6.51.081122-overflow.patch
@@ -0,0 +1,28 @@
+diff --git a/PKIN.h b/PKIN.h
+index 6cb6670..c9c6b89 100755
+--- a/PKIN.h
++++ b/PKIN.h
+@@ -533,8 +533,8 @@ EXTERN float xnext,ynext,znext,onext,Bnext,Uvalnext;
+ EXTERN char aspectstrnext[MAXaspects+3]; /*in parens: (XXXX)*/
+
+ /* possible overlap with earlier PREKIN variables */
+-EXTERN char word[256],texts[256],temps[256];
+-EXTERN char alertstr[256],alertstr2[256],alertstr3[256];
++EXTERN char word[256],texts[256],temps[512];
++EXTERN char alertstr[1024],alertstr2[256],alertstr3[256];
+ EXTERN char oldstr[256],olderstr[256],newstr[256],InfoStr[256],MolNameStr[16];
+ EXTERN char NameStr[256],OutfileStr[256],ScriptinStr[256],ShortNameStr[256];
+ EXTERN char DirStr[256],PDBfileStr[256],helpoutStr[256]; /*040425 helpout*/
+diff --git a/PKINCOUT.c b/PKINCOUT.c
+index af8eb24..a9f3a5f 100755
+--- a/PKINCOUT.c
++++ b/PKINCOUT.c
+@@ -17,7 +17,7 @@ static float VRMLx=0,VRMLy=0,VRMLz=0;
+ void writeoutput()
+ {
+ char cntl[5]; /* 4 actual characters */
+- char kol[20],extra[256],aname[13];
++ char kol[20],extra[256],aname[32];
+ char chain[32],atoms[32],cpks[32],hygen[32],hbond[32];
+ char subname[32],allstr[32];
+ char mastername[32]; /*051128*/
diff --git a/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild b/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild
new file mode 100644
index 000000000000..c7ee55b7b884
--- /dev/null
+++ b/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild,v 1.1 2010/10/03 08:28:36 jlec Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils multilib
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="Prepares molecular kinemages (input files for Mage & KiNG) from PDB-format coordinate files"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/prekin.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/prekin/${MY_P}.src.tgz"
+
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ X? ( x11-libs/openmotif )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-Makefile.patch \
+ "${FILESDIR}"/${PV}-overflow.patch
+ sed \
+ -e 's:cc:$(CC):g' \
+ -e "s:GENTOOLIBDIR:$(get_libdir):g" \
+ "${S}"/Makefile.linux > Makefile
+}
+
+src_compile() {
+ local mytarget
+
+ if use X; then
+ mytarget="${PN}"
+ else
+ mytarget="nogui"
+ fi
+
+ emake \
+ CC="$(tc-getCC)" \
+ ${mytarget} || die "make failed"
+}
+
+src_install() {
+ dobin "${S}"/prekin || die "dobin failed"
+}
diff --git a/sci-chemistry/prekin/prekin-6.51.081122.ebuild b/sci-chemistry/prekin/prekin-6.51.081122.ebuild
index efe0dabb7ea2..47d3d446b1b2 100644
--- a/sci-chemistry/prekin/prekin-6.51.081122.ebuild
+++ b/sci-chemistry/prekin/prekin-6.51.081122.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/prekin-6.51.081122.ebuild,v 1.1 2010/07/18 08:57:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/prekin-6.51.081122.ebuild,v 1.2 2010/10/03 08:28:36 jlec Exp $
EAPI="2"
@@ -26,7 +26,9 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
src_prepare() {
- epatch "${FILESDIR}"/${PV}-Makefile.patch
+ epatch \
+ "${FILESDIR}"/${PV}-Makefile.patch \
+ "${FILESDIR}"/${PV}-overflow.patch
sed \
-e 's:cc:$(CC):g' \
-e "s:GENTOOLIBDIR:$(get_libdir):g" \