summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-19 17:49:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-19 17:49:24 +0000
commit3cad5eff327f2fc8558ec61e7c5863790b68f30d (patch)
treee191ef96fbaf561c65670b5b80c99beefb029b9c /sci-chemistry/mead
parentsh stable (diff)
downloadgentoo-2-3cad5eff327f2fc8558ec61e7c5863790b68f30d.tar.gz
gentoo-2-3cad5eff327f2fc8558ec61e7c5863790b68f30d.tar.bz2
gentoo-2-3cad5eff327f2fc8558ec61e7c5863790b68f30d.zip
resepect LDFLAGS, #316059
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/mead')
-rw-r--r--sci-chemistry/mead/ChangeLog9
-rw-r--r--sci-chemistry/mead/files/mead-2.2.7-respect-flags.patch74
-rw-r--r--sci-chemistry/mead/files/respect-cflags.patch57
-rw-r--r--sci-chemistry/mead/mead-2.2.7-r1.ebuild44
-rw-r--r--sci-chemistry/mead/mead-2.2.7.ebuild4
5 files changed, 128 insertions, 60 deletions
diff --git a/sci-chemistry/mead/ChangeLog b/sci-chemistry/mead/ChangeLog
index 478d87319926..fc75f94f5ed3 100644
--- a/sci-chemistry/mead/ChangeLog
+++ b/sci-chemistry/mead/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/mead
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mead/ChangeLog,v 1.7 2010/04/19 07:02:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mead/ChangeLog,v 1.8 2010/04/19 17:49:23 jlec Exp $
+
+*mead-2.2.7-r1 (19 Apr 2010)
+
+ 19 Apr 2010; Justin Lecher <jlec@gentoo.org> mead-2.2.7.ebuild,
+ +mead-2.2.7-r1.ebuild, +files/mead-2.2.7-respect-flags.patch,
+ -files/respect-cflags.patch:
+ respect LDFLAGS, #316059
19 Apr 2010; Justin Lecher <jlec@gentoo.org> -mead-2.2.5.ebuild,
mead-2.2.7.ebuild:
diff --git a/sci-chemistry/mead/files/mead-2.2.7-respect-flags.patch b/sci-chemistry/mead/files/mead-2.2.7-respect-flags.patch
new file mode 100644
index 000000000000..9ffb238ece8c
--- /dev/null
+++ b/sci-chemistry/mead/files/mead-2.2.7-respect-flags.patch
@@ -0,0 +1,74 @@
+diff --git a/apps/Makefile.common.in b/apps/Makefile.common.in
+index 15c61ae..f15d71d 100644
+--- a/apps/Makefile.common.in
++++ b/apps/Makefile.common.in
+@@ -36,10 +36,10 @@ REGEX_CPP = @REGEX_CPP@
+ LIBS = @LIBS@ -lm
+
+ ALL_CPPFLAGS = -I. $(LOCALINCS) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
+-ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS)
+-ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
++ALL_CXXFLAGS = @CXXFLAGS@
++ALL_CFLAGS = @CFLAGS@
+
+-CXXLINK = $(CXX) $(ALL_CPPFLAGS) $(CXX_DEBUGFLAGS) $(CXX_OPTFLAGS) \
++CXXLINK = $(CXX) $(ALL_CPPFLAGS) @CXXFLAGS@ \
+ $(LDFLAGS)
+
+ .SUFFIXES: .cc .o
+diff --git a/apps/libmso/Makefile.in b/apps/libmso/Makefile.in
+index 249c25b..9d23665 100644
+--- a/apps/libmso/Makefile.in
++++ b/apps/libmso/Makefile.in
+@@ -35,8 +35,8 @@ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+
+ ALL_CPPFLAGS = -I. $(LOCALINCS) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
+-ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS)
+-ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
++ALL_CXXFLAGS = @CXXFLAGS@
++ALL_CFLAGS = @CFLAGS@
+
+ .SUFFIXES:
+ .SUFFIXES: .cc .o
+diff --git a/apps/redti/Makefile.in b/apps/redti/Makefile.in
+index c4aa5ca..9561bf3 100644
+--- a/apps/redti/Makefile.in
++++ b/apps/redti/Makefile.in
+@@ -21,7 +21,7 @@ CFLAGS = @CFLAGS@
+ redti_objs = redti.o rfixpro.o rfixprosee.o pfix.o tc.o
+
+ redti : $(redti_objs)
+- $(CC) $(CFLAGS) $(redti_objs) -lm -o redti
++ $(CC) $(CFLAGS) $(LDFLAGS) $(redti_objs) -lm -o redti
+
+ appname = redti
+ include ../Makefile.common
+diff --git a/libmead/Makefile.in b/libmead/Makefile.in
+index 3d4d5f0..8b4a4ac 100644
+--- a/libmead/Makefile.in
++++ b/libmead/Makefile.in
+@@ -99,8 +99,8 @@ PYTHONINC = @PYTHONINC@
+ INCLUDES = -I$(top_srcdir)
+
+ ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
+-ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS) $(CXX_SHAREDFLAGS)
+-ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
++ALL_CXXFLAGS = @CXXFLAGS@
++ALL_CFLAGS = @CFLAGS@
+
+
+
+diff --git a/swig/Makefile.in b/swig/Makefile.in
+index 81b3b4e..8410307 100644
+--- a/swig/Makefile.in
++++ b/swig/Makefile.in
+@@ -58,7 +58,7 @@ CPP_FLAGS = -DSWIG @CPPFLAGS@
+ CXX_FLAGS = @CXX_NOOPTFLAGS@ @CXX_DEBUGFLAGS@ @CXX_SHAREDFLAGS@
+ CXX_DYNLIB_FLAGS = @CXX_DYNLIB_FLAGS@
+
+-ALL_CXXFLAGS = $(CPP_FLAGS) $(CXX_FLAGS)
++ALL_CXXFLAGS = $(CPP_FLAGS) @CXXFLAGS@ @CXX_SHAREDFLAGS@
+
+ MEADINC = -I$(top_srcdir) -I$(srcdir)
+ MEADLIBS = -L../libmead -lmead
diff --git a/sci-chemistry/mead/files/respect-cflags.patch b/sci-chemistry/mead/files/respect-cflags.patch
deleted file mode 100644
index 5b982aaebb4b..000000000000
--- a/sci-chemistry/mead/files/respect-cflags.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff -ur mead-2.2.5.orig/apps/libmso/Makefile.in mead-2.2.5/apps/libmso/Makefile.in
---- mead-2.2.5.orig/apps/libmso/Makefile.in 2004-12-10 12:33:49.000000000 -0800
-+++ mead-2.2.5/apps/libmso/Makefile.in 2005-12-17 12:43:10.000000000 -0800
-@@ -35,8 +35,8 @@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
-
- ALL_CPPFLAGS = -I. $(LOCALINCS) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
--ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS)
--ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
-+ALL_CXXFLAGS = @CXXFLAGS@
-+ALL_CFLAGS = @CFLAGS@
-
- .SUFFIXES:
- .SUFFIXES: .cc .o
-diff -ur mead-2.2.5.orig/apps/Makefile.common.in mead-2.2.5/apps/Makefile.common.in
---- mead-2.2.5.orig/apps/Makefile.common.in 2004-11-19 14:49:56.000000000 -0800
-+++ mead-2.2.5/apps/Makefile.common.in 2005-12-17 12:38:33.000000000 -0800
-@@ -36,10 +36,10 @@
- LIBS = @LIBS@ -lm
-
- ALL_CPPFLAGS = -I. $(LOCALINCS) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
--ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS)
--ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
-+ALL_CXXFLAGS = @CXXFLAGS@
-+ALL_CFLAGS = @CFLAGS@
-
--CXXLINK = $(CXX) $(ALL_CPPFLAGS) $(CXX_DEBUGFLAGS) $(CXX_OPTFLAGS) \
-+CXXLINK = $(CXX) $(ALL_CPPFLAGS) @CXXFLAGS@ \
- $(LDFLAGS)
-
- .SUFFIXES: .cc .o
-diff -ur mead-2.2.5.orig/libmead/Makefile.in mead-2.2.5/libmead/Makefile.in
---- mead-2.2.5.orig/libmead/Makefile.in 2004-12-10 13:14:40.000000000 -0800
-+++ mead-2.2.5/libmead/Makefile.in 2005-12-17 12:40:12.000000000 -0800
-@@ -99,8 +99,8 @@
- INCLUDES = -I$(top_srcdir)
-
- ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS) $(REGEX_CPP) $(CXX_DEFS)
--ALL_CXXFLAGS = $(CXX_OPTFLAGS) $(CXX_DEBUGFLAGS)
--ALL_CFLAGS = $(CC_DEBUGFLAGS) $(CC_OPTFLAGS)
-+ALL_CXXFLAGS = @CXXFLAGS@
-+ALL_CFLAGS = @CFLAGS@
-
-
-
-diff -ur mead-2.2.5.orig/swig/Makefile.in mead-2.2.5/swig/Makefile.in
---- mead-2.2.5.orig/swig/Makefile.in 2004-12-09 10:37:41.000000000 -0800
-+++ mead-2.2.5/swig/Makefile.in 2005-12-17 12:51:47.000000000 -0800
-@@ -58,7 +58,7 @@
- CXX_FLAGS = @CXX_NOOPTFLAGS@ @CXX_DEBUGFLAGS@ @CXX_SHAREDFLAGS@
- CXX_DYNLIB_FLAGS = @CXX_DYNLIB_FLAGS@
-
--ALL_CXXFLAGS = $(CPP_FLAGS) $(CXX_FLAGS)
-+ALL_CXXFLAGS = $(CPP_FLAGS) @CXXFLAGS@ @CXX_SHAREDFLAGS@
-
- MEADINC = -I$(top_srcdir) -I$(srcdir)
- MEADLIBS = -L../libmead -lmead
diff --git a/sci-chemistry/mead/mead-2.2.7-r1.ebuild b/sci-chemistry/mead/mead-2.2.7-r1.ebuild
new file mode 100644
index 000000000000..fe7e92af18ce
--- /dev/null
+++ b/sci-chemistry/mead/mead-2.2.7-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mead/mead-2.2.7-r1.ebuild,v 1.1 2010/04/19 17:49:23 jlec Exp $
+
+inherit eutils
+
+DESCRIPTION="Macroscopic Electrostatics with Atomic Detail"
+HOMEPAGE="http://www.teokem.lu.se/~ulf/Methods/mead.html"
+SRC_URI="ftp://ftp.scripps.edu/pub/bashford/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="python"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Download ${SRC_URI}"
+ elog "and place it in ${DISTDIR}."
+ elog
+ elog "Use \"anonymous\" as a login, and an email address as a password."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-respect-flags.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ econf \
+ ${conf_opts} \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ # package hates emake DESTDIR="${D}" install
+ einstall || die "install failed"
+}
diff --git a/sci-chemistry/mead/mead-2.2.7.ebuild b/sci-chemistry/mead/mead-2.2.7.ebuild
index 1d835c53b78b..44c0d212f06a 100644
--- a/sci-chemistry/mead/mead-2.2.7.ebuild
+++ b/sci-chemistry/mead/mead-2.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mead/mead-2.2.7.ebuild,v 1.2 2010/04/19 07:02:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mead/mead-2.2.7.ebuild,v 1.3 2010/04/19 17:49:23 jlec Exp $
inherit eutils
@@ -27,7 +27,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-respect-cflags.patch
+ epatch "${FILESDIR}"/${P}-respect-flags.patch
epatch "${FILESDIR}"/${P}-gcc43.patch
}