summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-19 14:53:11 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-19 14:53:11 +0000
commitf6a9d4859d458fdbc11dca7fb5b330b592a39d79 (patch)
tree88bf08575a1d665542abfbad5cd61639e8d8f257 /sci-chemistry/babel
parentamd64/x86 stable, bug #242596 (diff)
downloadgentoo-2-f6a9d4859d458fdbc11dca7fb5b330b592a39d79.tar.gz
gentoo-2-f6a9d4859d458fdbc11dca7fb5b330b592a39d79.tar.bz2
gentoo-2-f6a9d4859d458fdbc11dca7fb5b330b592a39d79.zip
Added new and significantly cleaned up revision which also fixes pre-stripping and LDFLAGS issues (see bug #241184).
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-SENTINEL-3 i686)
Diffstat (limited to 'sci-chemistry/babel')
-rw-r--r--sci-chemistry/babel/ChangeLog11
-rw-r--r--sci-chemistry/babel/babel-1.6-r1.ebuild38
-rw-r--r--sci-chemistry/babel/babel-1.6.ebuild16
-rw-r--r--sci-chemistry/babel/files/babel-1.6-makefile.patch33
4 files changed, 88 insertions, 10 deletions
diff --git a/sci-chemistry/babel/ChangeLog b/sci-chemistry/babel/ChangeLog
index 377f9a3ef29f..829bcc3a784d 100644
--- a/sci-chemistry/babel/ChangeLog
+++ b/sci-chemistry/babel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/babel
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/ChangeLog,v 1.5 2007/04/28 16:43:58 swegener Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/ChangeLog,v 1.6 2008/10/19 14:53:11 markusle Exp $
+
+*babel-1.6-r1 (19 Oct 2008)
+
+ 19 Oct 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/babel-1.6-makefile.patch, babel-1.6.ebuild, +babel-1.6-r1.ebuild:
+ Added new and significantly cleaned up revision which also fixes
+ pre-stripping and LDFLAGS issues (see bug #241184).
28 Apr 2007; Sven Wegener <swegener@gentoo.org> babel-1.6.ebuild:
Fix *initd, *confd and *envd calls (#17388, #174266)
diff --git a/sci-chemistry/babel/babel-1.6-r1.ebuild b/sci-chemistry/babel/babel-1.6-r1.ebuild
new file mode 100644
index 000000000000..4d7c9e1420e7
--- /dev/null
+++ b/sci-chemistry/babel/babel-1.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6-r1.ebuild,v 1.1 2008/10/19 14:53:11 markusle Exp $
+
+inherit eutils
+
+DESCRIPTION="Babel is a program to interconvert file formats used in molecular modeling."
+
+SRC_URI="http://smog.com/chem/babel/files/${P}.tar.Z"
+HOMEPAGE="http://smog.com/chem/babel/"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+SLOT="0"
+LICENSE="as-is"
+IUSE=""
+
+#Doesn't really seem to depend on anything (?)
+DEPEND="!sci-chemistry/openbabel"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc32.diff
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ CC=$(tc-getCC) emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}"/usr/bin install || die
+
+ insinto /usr/share/${PN}
+ doins *.lis || die "Failed to install *.lis files"
+
+ doenvd "${FILESDIR}"/10babel || die "doenvd failed"
+ dodoc README.1ST || die "dodoc failed"
+}
diff --git a/sci-chemistry/babel/babel-1.6.ebuild b/sci-chemistry/babel/babel-1.6.ebuild
index c5b00a140629..4cef63df75d0 100644
--- a/sci-chemistry/babel/babel-1.6.ebuild
+++ b/sci-chemistry/babel/babel-1.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6.ebuild,v 1.4 2007/07/13 05:48:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6.ebuild,v 1.5 2008/10/19 14:53:11 markusle Exp $
inherit eutils
@@ -20,10 +20,10 @@ DEPEND="!sci-chemistry/openbabel"
src_unpack() {
unpack ${P}.tar.Z
- cd ${S}
+ cd "${S}"
#Patch the Makefile for gentoo-isms
- epatch ${FILESDIR}/${P}-gentoo.diff
- epatch ${FILESDIR}/${P}-gcc32.diff
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-gcc32.diff
}
@@ -35,12 +35,12 @@ src_compile() {
src_install () {
- make DESTDIR=${D}/usr/bin install || die
+ make DESTDIR="${D}"/usr/bin install || die
insinto /usr/share/${PN}
- doins ${S}/*.lis
+ doins "${S}"/*.lis
- doenvd ${FILESDIR}/10babel
+ doenvd "${FILESDIR}"/10babel
dodoc README.1ST
diff --git a/sci-chemistry/babel/files/babel-1.6-makefile.patch b/sci-chemistry/babel/files/babel-1.6-makefile.patch
new file mode 100644
index 000000000000..33b158d1b2cf
--- /dev/null
+++ b/sci-chemistry/babel/files/babel-1.6-makefile.patch
@@ -0,0 +1,33 @@
+diff -Naur babel-1.6/Makefile babel-1.6.new/Makefile
+--- babel-1.6/Makefile 1997-01-21 10:53:05.000000000 -0500
++++ babel-1.6.new/Makefile 2008-10-19 10:41:42.000000000 -0400
+@@ -1,12 +1,16 @@
+-CFLAGS = -O
++#Commented out to pull CFLAGS from make.conf
++#CFLAGS = -O
+
+ LIBFLAGS = -O -DLIBRARY
+
+-CC = cc
++#Probably not necessary to specify gcc
++#CC = gcc
+
+ PROGRAM = babel
+
+-LDFLAGS =
++DEST = ${DESTDIR}/$(PROGRAM)
++
++#LDFLAGS =
+
+ LIBS =
+
+@@ -334,7 +338,8 @@
+ index:; ctags -wx $(HDRS) $(SRCS)
+
+ install: $(PROGRAM)
+- install -s $(PROGRAM) $(DEST)
++ install -d ${DESTDIR}
++ install $(PROGRAM) $(DEST)
+
+ print:; $(PRINT) $(HDRS) $(SRCS)
+