summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-09-17 16:07:56 +0000
committerJustin Lecher <jlec@gentoo.org>2013-09-17 16:07:56 +0000
commitd431440a0bee4e87ba9ef2d202b557a094ec023e (patch)
tree0f9fc6b24936d4ebd0221d47e0216663391570d2 /sci-biology
parentIntroduce python-exec:2. (diff)
downloadgentoo-2-d431440a0bee4e87ba9ef2d202b557a094ec023e.tar.gz
gentoo-2-d431440a0bee4e87ba9ef2d202b557a094ec023e.tar.bz2
gentoo-2-d431440a0bee4e87ba9ef2d202b557a094ec023e.zip
sci-biology/biopython: Version Bump
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biopython/ChangeLog7
-rw-r--r--sci-biology/biopython/biopython-1.62.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index 52f4ef7be870..51abd0392438 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.71 2013/07/02 12:47:34 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.72 2013/09/17 16:07:56 jlec Exp $
+
+*biopython-1.62 (17 Sep 2013)
+
+ 17 Sep 2013; Justin Lecher <jlec@gentoo.org> +biopython-1.62.ebuild:
+ Version Bump
02 Jul 2013; Justin Lecher <jlec@gentoo.org> biopython-1.61.ebuild:
Fix deps for python
diff --git a/sci-biology/biopython/biopython-1.62.ebuild b/sci-biology/biopython/biopython-1.62.ebuild
new file mode 100644
index 000000000000..7d36020e90a7
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.62.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.62.ebuild,v 1.1 2013/09/17 16:07:56 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org/ http://pypi.python.org/pypi/biopython/"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="mysql postgres"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
+
+python_test() {
+ cd Tests || die
+ ${PYTHON} run_tests.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}