summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-10 15:37:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-10 15:37:33 +0000
commit84863789fa91eb25900bd057165c64c86d3a9787 (patch)
tree2cf90ee6f38481ebba50051139a212b1dd86ba25 /net-zope/zconfig
parentMerge from Prefix (diff)
downloadgentoo-2-84863789fa91eb25900bd057165c64c86d3a9787.tar.gz
gentoo-2-84863789fa91eb25900bd057165c64c86d3a9787.tar.bz2
gentoo-2-84863789fa91eb25900bd057165c64c86d3a9787.zip
Initial addition (bug #191252).
(Portage version: 14556-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zconfig')
-rw-r--r--net-zope/zconfig/ChangeLog11
-rw-r--r--net-zope/zconfig/files/zconfig-2.7.1-fix_tests.patch11
-rw-r--r--net-zope/zconfig/metadata.xml6
-rw-r--r--net-zope/zconfig/zconfig-2.7.1.ebuild49
4 files changed, 77 insertions, 0 deletions
diff --git a/net-zope/zconfig/ChangeLog b/net-zope/zconfig/ChangeLog
new file mode 100644
index 000000000000..3fa3ae2e9204
--- /dev/null
+++ b/net-zope/zconfig/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-zope/zconfig
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zconfig/ChangeLog,v 1.1 2009/10/10 15:37:32 arfrever Exp $
+
+*zconfig-2.7.1 (10 Oct 2009)
+
+ 10 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zconfig-2.7.1.ebuild, +files/zconfig-2.7.1-fix_tests.patch,
+ +metadata.xml:
+ Initial addition (bug #191252). Ebuild rewritten by me.
+
diff --git a/net-zope/zconfig/files/zconfig-2.7.1-fix_tests.patch b/net-zope/zconfig/files/zconfig-2.7.1-fix_tests.patch
new file mode 100644
index 000000000000..66580476be9e
--- /dev/null
+++ b/net-zope/zconfig/files/zconfig-2.7.1-fix_tests.patch
@@ -0,0 +1,11 @@
+--- ZConfig/components/logger/tests/test_logger.py
++++ ZConfig/components/logger/tests/test_logger.py
+@@ -360,6 +360,8 @@
+
+ # These tests should not be run on Windows.
+
++ handler_factory = loghandler.FileHandler
++
+ _schematext = """
+ <schema>
+ <import package='ZConfig.components.logger'/>
diff --git a/net-zope/zconfig/metadata.xml b/net-zope/zconfig/metadata.xml
new file mode 100644
index 000000000000..ecc751f37510
--- /dev/null
+++ b/net-zope/zconfig/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/net-zope/zconfig/zconfig-2.7.1.ebuild b/net-zope/zconfig/zconfig-2.7.1.ebuild
new file mode 100644
index 000000000000..60f08b0995c3
--- /dev/null
+++ b/net-zope/zconfig/zconfig-2.7.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zconfig/zconfig-2.7.1.ebuild,v 1.1 2009/10/10 15:37:32 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+MY_PN="ZConfig"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Structured Configuration Library"
+HOMEPAGE="http://pypi.python.org/pypi/ZConfig"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools
+ test? ( dev-python/nose net-zope/zope-testing )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"
+DOCS="NEWS.txt README.txt"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-fix_tests.patch"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ # Don't install tests.
+ rm -fr "${D}"usr/$(get_libdir)/python*/site-packages/ZConfig/tests
+}