summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-10-13 10:35:28 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-10-13 10:35:28 +0000
commit039bbdf0b01433e0dfa38e55a28222d7e8c8e863 (patch)
treeb0458040aa71e9123ba4e2d32b371faa81408402 /net-p2p
parentadd ~arm, bug #487560 (diff)
downloadgentoo-2-039bbdf0b01433e0dfa38e55a28222d7e8c8e863.tar.gz
gentoo-2-039bbdf0b01433e0dfa38e55a28222d7e8c8e863.tar.bz2
gentoo-2-039bbdf0b01433e0dfa38e55a28222d7e8c8e863.zip
Use system qtsingleapplication per #487560 thanks to Nikoli
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.0.11-r1.ebuild54
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild3
3 files changed, 63 insertions, 2 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 6389e647a8b9..94c3a7a208df 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.215 2013/09/27 21:51:31 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.216 2013/10/13 10:35:28 hwoarang Exp $
+
+*qbittorrent-3.0.11-r1 (13 Oct 2013)
+
+ 13 Oct 2013; Markos Chandras <hwoarang@gentoo.org>
+ +qbittorrent-3.0.11-r1.ebuild, qbittorrent-9999.ebuild:
+ Use system qtsingleapplication per #487560 thanks to Nikoli
27 Sep 2013; Markos Chandras <hwoarang@gentoo.org> -qbittorrent-3.0.8.ebuild,
-qbittorrent-3.0.9.ebuild:
diff --git a/net-p2p/qbittorrent/qbittorrent-3.0.11-r1.ebuild b/net-p2p/qbittorrent/qbittorrent-3.0.11-r1.ebuild
new file mode 100644
index 000000000000..d8fb30b5b398
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.0.11-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.0.11-r1.ebuild,v 1.1 2013/10/13 10:35:28 hwoarang Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1 qt4-r2
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus +X geoip"
+
+# python-2 is a runtime dep only, for the search engine (see INSTALL file)
+CDEPEND="dev-libs/boost
+ dev-qt/qtcore:4
+ dev-qt/qtsingleapplication
+ >=net-libs/rb_libtorrent-0.16.3
+ X? ( dev-qt/qtgui:4 )
+ dbus? ( dev-qt/qtdbus:4 )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libboost-inc=/usr/include/boost \
+ --with-qtsingleapplication=system \
+ ${myconf} || die "configure failed"
+ eqmake4
+}
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index 933a38cb13ea..c41b592a6779 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.10 2013/09/05 19:44:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.11 2013/10/13 10:35:28 hwoarang Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -22,6 +22,7 @@ IUSE="dbus +X geoip"
# python-2 is a runtime dep only, for the search engine (see INSTALL file)
CDEPEND="dev-libs/boost
dev-qt/qtcore:4
+ dev-qt/qtsingleapplication
net-libs/rb_libtorrent
X? ( dev-qt/qtgui:4 )
dbus? ( dev-qt/qtdbus:4 )"