summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-03-09 19:37:27 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-03-09 19:37:27 +0000
commit898ecb53388502b76ba52158b4411a3ca9fa8590 (patch)
treeea4c0953802febcd676420ef5cca8ca911d5cf55 /net-misc
parentStabilize for all #502810 by Paweł Hajdan, Jr.. (diff)
downloadgentoo-2-898ecb53388502b76ba52158b4411a3ca9fa8590.tar.gz
gentoo-2-898ecb53388502b76ba52158b4411a3ca9fa8590.tar.bz2
gentoo-2-898ecb53388502b76ba52158b4411a3ca9fa8590.zip
rev bump for #503738
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8568F528)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog8
-rw-r--r--net-misc/dhcpcd/dhcpcd-6.3.1-r1.ebuild95
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-6.3.1-fix-udev.patch45
3 files changed, 147 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index cc3e4da5c559..eb10325541c9 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.390 2014/03/08 14:19:21 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.391 2014/03/09 19:37:27 williamh Exp $
+
+*dhcpcd-6.3.1-r1 (09 Mar 2014)
+
+ 09 Mar 2014; William Hubbs <williamh@gentoo.org> +dhcpcd-6.3.1-r1.ebuild,
+ +files/dhcpcd-6.3.1-fix-udev.patch:
+ rev bump for #503738
*dhcpcd-6.3.1 (08 Mar 2014)
diff --git a/net-misc/dhcpcd/dhcpcd-6.3.1-r1.ebuild b/net-misc/dhcpcd/dhcpcd-6.3.1-r1.ebuild
new file mode 100644
index 000000000000..5ca50ee0d015
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-6.3.1-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-6.3.1-r1.ebuild,v 1.1 2014/03/09 19:37:27 williamh Exp $
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://roy.marples.name/${PN}.git"
+ inherit git-r3
+else
+ MY_P="${P/_alpha/-alpha}"
+ MY_P="${MY_P/_beta/-beta}"
+ MY_P="${MY_P/_rc/-rc}"
+ SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+inherit eutils systemd
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="elibc_glibc ipv6 kernel_linux +udev"
+
+COMMON_DEPEND="udev? ( virtual/udev )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare()
+{
+ epatch "${FILESDIR}"/${P}-fix-udev.patch
+ epatch_user
+}
+
+src_configure()
+{
+ local dev hooks rundir
+ use udev || dev="--without-dev --without-udev"
+ hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ use kernel_linux && rundir="--rundir=${EPREFIX}/run"
+ econf \
+ --prefix="${EPREFIX}" \
+ --libexecdir="${EPREFIX}/lib/dhcpcd" \
+ --dbdir="${EPREFIX}/var/lib/dhcpcd" \
+ --localstatedir="${EPREFIX}/var" \
+ ${rundir} \
+ $(use_enable ipv6) \
+ ${dev} \
+ ${hooks}
+}
+
+src_install()
+{
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst()
+{
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ elog
+ elog "dhcpcd has zeroconf support active by default."
+ elog "This means it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the noipv4ll configuration"
+ elog "file option or the -L command line switch."
+ elog "See the dhcpcd and dhcpcd.conf man pages for more details."
+
+ elog
+ elog "Dhcpcd has duid enabled by default, and this may cause issues"
+ elog "with some dhcp servers. For more information, see"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
+
+ if ! has_version net-dns/bind-tools; then
+ elog
+ elog "If you activate the lookup-hostname hook to look up your hostname"
+ elog "using the dns, you need to install net-dns/bind-tools."
+ fi
+}
diff --git a/net-misc/dhcpcd/files/dhcpcd-6.3.1-fix-udev.patch b/net-misc/dhcpcd/files/dhcpcd-6.3.1-fix-udev.patch
new file mode 100644
index 000000000000..606ab11cf2dd
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-6.3.1-fix-udev.patch
@@ -0,0 +1,45 @@
+Index: dev/udev.c
+==================================================================
+--- dev/udev.c
++++ dev/udev.c
+@@ -42,11 +42,11 @@
+
+ static const char udev_name[]="udev";
+ static struct udev *udev;
+ static struct udev_monitor *monitor;
+
+-static const struct dev_dhcpcd *dhcpcd;
++static struct dev_dhcpcd dhcpcd;
+
+ static int
+ udev_listening(void)
+ {
+
+@@ -90,13 +90,13 @@
+
+ /* udev filter documentation says "usually" so double check */
+ if (strcmp(subsystem, "net") == 0) {
+ syslog(LOG_DEBUG, "%s: libudev: %s", ifname, action);
+ if (strcmp(action, "add") == 0 || strcmp(action, "move") == 0)
+- dhcpcd->handle_interface(ctx, 1, ifname);
++ dhcpcd.handle_interface(ctx, 1, ifname);
+ else if (strcmp(action, "remove") == 0)
+- dhcpcd->handle_interface(ctx, -1, ifname);
++ dhcpcd.handle_interface(ctx, -1, ifname);
+ }
+
+ udev_device_unref(device);
+ return 1;
+ }
+@@ -171,9 +171,9 @@
+ dev->listening = udev_listening;
+ dev->handle_device = udev_handle_device;
+ dev->stop = udev_stop;
+ dev->start = udev_start;
+
+- dhcpcd = dev_dhcpcd;
++ dhcpcd = *dev_dhcpcd;
+
+ return 0;
+ }
+