summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-10-27 15:35:21 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-10-27 15:35:21 +0000
commit37877595cc5086e9292753477dd763812703f18f (patch)
tree2a4ef351a8a6e09fba851fa55ffb654e2c78d947 /net-misc
parentfixed digest (diff)
downloadgentoo-2-37877595cc5086e9292753477dd763812703f18f.tar.gz
gentoo-2-37877595cc5086e9292753477dd763812703f18f.tar.bz2
gentoo-2-37877595cc5086e9292753477dd763812703f18f.zip
Version bump, addition of support for eselect-whois.
Authorized by Roy Marples. (Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/whois/ChangeLog8
-rw-r--r--net-misc/whois/files/digest-whois-4.7.19-r13
-rw-r--r--net-misc/whois/whois-4.7.19-r1.ebuild63
3 files changed, 73 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 620a38310879..c143d21277e1 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.59 2006/10/23 20:55:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.60 2006/10/27 15:35:21 drizzt Exp $
+
+*whois-4.7.19-r1 (27 Oct 2006)
+
+ 27 Oct 2006; Timothy Redaelli <drizzt@gentoo.org> +whois-4.7.19-r1.ebuild:
+ Version bump, addition of support for eselect-whois.
+ Authorized by Roy Marples.
*whois-4.7.19 (23 Oct 2006)
diff --git a/net-misc/whois/files/digest-whois-4.7.19-r1 b/net-misc/whois/files/digest-whois-4.7.19-r1
new file mode 100644
index 000000000000..79726fe4b19b
--- /dev/null
+++ b/net-misc/whois/files/digest-whois-4.7.19-r1
@@ -0,0 +1,3 @@
+MD5 437585d938b0890ff276baad84b753c2 whois_4.7.19.tar.gz 60524
+RMD160 fcd01163739dfabc103665551772c7779868cdbe whois_4.7.19.tar.gz 60524
+SHA256 f39fa19bc834b9d78c3f0f182becf6397eaa010a70d1d1072645ae130df1486d whois_4.7.19.tar.gz 60524
diff --git a/net-misc/whois/whois-4.7.19-r1.ebuild b/net-misc/whois/whois-4.7.19-r1.ebuild
new file mode 100644
index 000000000000..89da718afbc3
--- /dev/null
+++ b/net-misc/whois/whois-4.7.19-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.7.19-r1.ebuild,v 1.1 2006/10/27 15:35:21 drizzt Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+RESTRICT="test" #59327
+
+RDEPEND="net-dns/libidn
+ app-admin/eselect-whois"
+DEPEND="net-dns/libidn
+ >=dev-lang/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.7.19-gentoo-security.patch
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ cd po
+ sed -i -e "s:/usr/bin/install:install:" Makefile
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
+ sed -i -e "s:cd po.*::" Makefile
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake OPTS="${CFLAGS}" HAVE_LIBIDN=1 || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ make BASEDIR="${D}" prefix=/usr install || die
+ insinto /etc
+ doins whois.conf
+ dodoc README
+
+ mv ${D}/usr/share/man/man1/{whois,mdwhois}.1
+ mv ${D}/usr/bin/{whois,mdwhois}
+}
+
+pkg_postinst() {
+ einfo "Setting /usr/bin/whois symlink"
+ eselect whois update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating /usr/bin/whois symlink"
+ eselect whois update
+}
+